CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Fail to compile OpenFoam (

Frank_Wang December 6, 2012 06:55

Fail to compile OpenFoam
Hi, everyone~

I installed OpenFoam2.1.1 on Ubuntu 10.04, then I try to build a debug version of it. There is what I have done and the problem I have got.:

I modified "/opt/openfoam211/etc/bashrc" by setting WM_COMPILE_OPTION to Debug.
I soursed this bashrc file in ~/.bashrc.
I checked that both flex and bison are installed
I start ./Allwmake under directory /opt/openfoam211

There came a lot of error and the original error I found is :

mkdir: cannot create directory `linux64GccDPDebug': Permission denied
    /bin/sh: cannot create linux64GccDPDebug/options: Directory nonexistent

I tried "ln -s linux64GccDPOpt linux64GccDPDebug " and it did not make a difference.

Did I miss something ?:confused:


treima December 6, 2012 07:38


I think, you donīt have the permission to compile and install the program in /opt.
Perhaps you try your home directory for installing OpenFOAM. I think, this might solve your problem.

Or you can change the permission rights of your OpenFOAM folder in /opt, so that you have a writing accesse without being a superuser or using sudo.



Frank_Wang December 7, 2012 03:48

Hi, Treima.
Thanks for your advice. It works now.



WernerW August 6, 2015 10:37

Changing permissions
Hi Frank and Treima,

I'm dealing with the same problem as Frank did. How did it work Frank ?

I'm working in the option of getting permission in the folder opt/openfoam### (240 in my case) but it still doesn't work.

I introduce the command:

sudo chmod 755 ./opt/openfoam240

to give the user read/write/execute permissions (7) and the group and the world read+execute permissions (5 in both digits). I took this info from

When I run ./Allmake again (with the new permissions) the programm faces the same problem to create "linux64GccDPDebug".

Now I'm not even able to run my OpenFoam because the command (in this case pimpleDyMFoam) is not found. I tried to change the Compiler_options back to Opt and it didn't work either.

What should I do Know ? I would appreciate any help.

wyldckat August 10, 2015 16:36

Greetings Werner,

Mmmm... OK, you want to build the Debug version, based on the Deb package for OpenFOAM.
Very well, to avoid a situation where you might damage your system, then run the following command:

sudo chown -R $USER:$USER /opt/openfoam240
This will change the ownership of the folder and files within it to be available to your user. Then you should be able to build on that folder as a normal user.

I say "as a normal user", because the other way would be for you to build as root (super user), but in such a situation, you risk accidentally damaging your whole system, in case you accidentally erase/change the wrong file(s).

Best regards,

All times are GMT -4. The time now is 01:54.