CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   OpenFOAM-2.1.x in OpenSuse-12.1 (

lost December 13, 2012 21:01

HELP !! OpenFOAM-2.1.x in OpenSuse-12.1
Help me with the following error please.

sagun@linux-sbp3:~> sudo rpm -i
root's password:
error: Failed dependencies: is needed by OpenFOAM-2.1.1-1.x86_64 is needed by OpenFOAM-2.1.1-1.x86_64 is needed by OpenFOAM-2.1.1-1.x86_64

wyldckat December 15, 2012 13:33

Greetings lost and welcome to the forum!

I'm assuming you're following these instructions:

Are you certain you have installed the x86_64 version of openSUSE 12.1? Run the following command to confirm:

uname -m
If it shows "i586" or similar, then you should be following the 32bit instructions!

But if you have the x86_64 version, then try doing the first step once again:

sudo zypper in openmpi
Does this display any error message or does it say that it is already installed?

Best regards,

lost December 15, 2012 17:12

Thank you wyldckat for the reply. I got the following message.
sagun@linux-sbp3:~> uname -m
sagun@linux-sbp3:~> sudo zypper in openmpi
Loading repository data...
Reading installed packages...
'openmpi' is already installed.
No update candidate for 'openmpi-1.5.4-4.1.4.x86_64'. The highest available version is already installed.
Resolving package dependencies...

Nothing to do.

wyldckat December 16, 2012 06:58

Hi lost,

Well, if you have Open-MPI 1.5.4 installed, then that means that you in fact have openSUSE 12.2 instead of 12.1. Therefore I suggest that instead of trying to use the RPM version, you should build OpenFOAM and ParaView from source, for which you'll find unofficial instructions here:

Best regards,

cab January 22, 2013 05:13

Anybody solved this problem?
I also have the same problem that the mpi lib couldnt be found although it is installed (same error messages). Did anybody solve the problem?
Thanks very much for any help!!!

Vladimir_Lomakin January 30, 2013 06:12

Good day,
I had the same problem. And I did all recomendations in
If I'm not mistaken it's all right with openFOAM, cos' when I type blockMesh or icoFoam there are no mistakes.
But in case of paraFoam there is:
FATAL ERROR: ParaView reader module libraries do not exist

Please build the reader module before continuing:
cd $FOAM_UTILITIES/postProcessing/graphics/PV3Readers

And then

vladimir@n1:~/OpenFOAM/OpenFOAM-2.1.1/tutorials/incompressible/icoFoam/cavity> cd $FOAM_UTILITIES/postProcessing/graphics/PV3Readers
vladimir@n1:~/OpenFOAM/OpenFOAM-2.1.1/applications/utilities/postProcessing/graphics/PV3Readers> ./Allwclean
+ wclean libso vtkPV3Readers
wclean vtkPV3Readers
+ PV3blockMeshReader/Allwclean
+ rm -f '/home/vladimir/OpenFOAM/OpenFOAM-2.1.1/platforms/linux64GccDPOpt/lib/libPV3blockMeshReader*'
+ rm -rf PV3blockMeshReader/Make
+ wclean libso vtkPV3blockMesh
wclean vtkPV3blockMesh
+ PV3FoamReader/Allwclean
+ rm -f '/home/vladimir/OpenFOAM/OpenFOAM-2.1.1/platforms/linux64GccDPOpt/lib/libPV3FoamReader*'
+ rm -rf PV3FoamReader/Make
+ wclean libso vtkPV3Foam
wclean vtkPV3Foam
vladimir@n1:~/OpenFOAM/OpenFOAM-2.1.1/applications/utilities/postProcessing/graphics/PV3Readers> ./Allwmake
+ '[' -d /home/vladimir/OpenFOAM/ThirdParty-2.1.1/platforms/linux64Gcc/paraview-3.12.0 -a -r /home/vladimir/OpenFOAM/ThirdParty-2.1.1/platforms/linux64Gcc/paraview-3.12.0 ']'

without any results.
What's wrong?
Best regards...

wyldckat January 30, 2013 07:21

Greetings Lomakin and welcome to the forum!

I'm guessing that ParaView did not build with success. Try the following commands once again, although a bit different this time:

sed -i -e 's/ClearAndSelect = Clear | Select/ClearAndSelect = static_cast<int>(Clear) | static_cast<int>(Select)/' ParaView-3.12.0/Qt/Core/pqServerManagerSelectionModel.h
./makeParaView > pvmake.log 2>&1

which paraview

If the last command does not give you a path to ParaView's main binary installed on OpenFOAM's ThirdParty folder, then:
  • remove the sensitive information inside "pvmake.log";
  • compress it;
  • and attach in your next post.

But it worked well, then run again:

cd $FOAM_UTILITIES/postProcessing/graphics/PV3Readers

Best regards,

Vladimir_Lomakin January 30, 2013 08:27

1 Attachment(s)
Thank you, I did all you said.
see attachment

wyldckat January 30, 2013 08:39

Hi Lomakin,

:confused: Which openSUSE version are you using?
And more specifically, which version of CMake do you have installed?

cmake --version
Best regards,

Vladimir_Lomakin January 30, 2013 08:59

mmm... openSuse 11.3
cmake 2.8.1

wyldckat January 30, 2013 09:23


Originally Posted by Vladimir_Lomakin (Post 405016)
mmm... openSuse 11.3
cmake 2.8.1

Ah, that explains everything! :)

OK, I'll borrow some instructions from here - namely:

wget "" -O getCmake
chmod +x getCmake

Then try again the steps from the previous post.

Vladimir_Lomakin February 4, 2013 10:11

Thank you,
Despite the fact that I feel like a monkey, paraView is working.
I hope that is not the last question about openFOAM.

Thank you once again!

All times are GMT -4. The time now is 11:49.