CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Is ThirdParty-2-2-0 package corrupted? (

sudo March 11, 2013 15:26

Is ThirdParty-2-2-0 package corrupted?
I just finished compiling OpenFOAM 2.2.0 that was released a few days ago on a Xeon workstation running Ubuntu 12.10 64bit. Compilation took about 90 minutes using 6 cores, and -march=native flag for GCC. No error messages, everything compiled very smoothly. Now to the 'Fail' part :D

Following the instructions on the OpenFoam web site, I started compiling the third party software. So I typed in the terminal


~/OpenFOAM/ThirdParty-2.2.0$ ./makeParaView
but then I got the following error

did not find ParaView-3.12.0 in these directories:

abort build

The ParaView package is inside the folder compressed as gtgz, but I get an error when I try to uncompress it, so could there be a problem with the original package? The md5sum checked out fine, so I don't know what is going on here.

Any help is appreciated. Thanks.

EDIT: I downloaded the package from here:

sudo March 11, 2013 16:20

I just wanted to add that ParaView 3.14.1 was already available in the official Ubuntu 12.10 repos, so I am not sure why the latest OF ships with PV 3.12.0?!!!

So, a workaround for me was to install it from the Ubuntu repos, and then each time I need to execute

$ paraFoam
I'll use the following instead

$ paraFoam -builtin
I already tried it and it's working like a charm.

wyldckat March 11, 2013 17:20

Hi sudo,

I think they messed up the packaging this time:

Basically, you need to first unpack the 3 files contained in the ThirdParty folder:

tar xf openmpi-1.6.3.tar.bz2
tar xf ParaView-3.12.0.gtgz
tar xf scotch_6.0.0.tar.gz

Then you can build ParaView; Open-MPI and Scotch will be built when you build OpenFOAM using Allwmake.

As for sticking with ParaView-3.12.0? I can only try and guess that it was due to stability reasons. Either that, or they are planning something...

Best regards,

sudo March 12, 2013 11:22

Thanks Bruno, I tried to double click on the package but always gave me an error. Your tar commands worked perfectly.

I'll stick to ParaView 3.14 as the OpenFOAM website also recommends that for Ubuntu 12.10, and it recommends the 3.12.0 only for prior releases.

dkokron March 12, 2013 23:33

I just renamed it to ParaView-3.12.0.tgz then ran 'tar -zxf' as usual.

wyldckat March 18, 2013 17:10

Greetings to all!

Just close the loop on this: this has been solved. They've uploaded a new package with everything ready to go!

For more information:

Best regards,

All times are GMT -4. The time now is 18:00.