CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   OpenFOAM 2.2.0 installation on ICC (Intel C++ Compiler) (

vishal3 April 17, 2013 06:19

OpenFOAM 2.2.0 installation on ICC (Intel C++ Compiler)
I have installed OF220 with ICC Compiler. I have compiled openFoam, Thirdparty and openmpi successfully. It works perfectly for all tutorials.

The problem is that, I can not run the job in parrallel. When i submit the job in parallel, it creates a JOB ID but exits immediately. Can anyone tell me the solution?

Plzzzzz suggest somethin as i am very much in need.

Thanking you,

wyldckat April 17, 2013 17:13

Greetings Vishal,

Sorry, but you're not providing enough information for us to help you. Therefore, a few questions:
  1. How exactly are you submitting the job?
  2. What job scheduler are you using?
  3. Have you tried building OpenFOAM with GCC first?
  4. Are ICC's libraries installed on all of the machines that you are trying to run OpenFOAM on?
  5. Are you certain that Open-MPI is compatible with your job scheduler?
Best regards,

vishal3 April 25, 2013 02:31

I am not able to run the binaries in parallel even with directly login.

I checked the binaries using strings command but unable to find any MPI calls in that. InFact none of the binaries are linked to MPI libraries.

I didn't tried with GCC because system GCC is very old (4.2, 4.4). And requirement is version 4.6.

OpenMPI and JOb system are compatible and ICC compiler is also present on all nodes.


wyldckat April 26, 2013 20:00

Hi Vishal,

OK, try the following command on the machine that works and the machine that doesn't:

ldd $(which simpleFoam)
It will list the dependencies on libraries that this binary has got. For example, for me it gave:

$ ldd $(which simpleFoam) =>  (0x00007fffc29ff000) => /home/user/OpenFOAM/OpenFOAM-2.1.x/platforms/linux64GccDPOpt/lib/ (0x00007f5bb4c9e000) => /home/user/OpenFOAM/OpenFOAM-2.1.x/platforms/linux64GccDPOpt/lib/ (0x00007f5bb47aa000) => /home/user/OpenFOAM/OpenFOAM-2.1.x/platforms/linux64GccDPOpt/lib/ (0x00007f5bb453c000) => /home/user/OpenFOAM/OpenFOAM-2.1.x/platforms/linux64GccDPOpt/lib/ (0x00007f5bb333e000) => /home/user/OpenFOAM/OpenFOAM-2.1.x/platforms/linux64GccDPOpt/lib/ (0x00007f5bb2ea3000) => /home/user/OpenFOAM/OpenFOAM-2.1.x/platforms/linux64GccDPOpt/lib/ (0x00007f5bb2747000) => /lib/x86_64-linux-gnu/ (0x00007f5bb251c000) => /usr/lib/x86_64-linux-gnu/ (0x00007f5bb221b000) => /lib/x86_64-linux-gnu/ (0x00007f5bb1f1f000) => /lib/x86_64-linux-gnu/ (0x00007f5bb1d09000) => /lib/x86_64-linux-gnu/ (0x00007f5bb1949000) => /home/user/OpenFOAM/OpenFOAM-2.1.x/platforms/linux64GccDPOpt/lib/openmpi-1.5.3/ (0x00007f5bb173f000) => /home/user/OpenFOAM/OpenFOAM-2.1.x/platforms/linux64GccDPOpt/lib/ (0x00007f5bb14cc000) => /lib/x86_64-linux-gnu/ (0x00007f5bb12b5000)
  /lib64/ (0x00007f5bb4ef2000) => /home/user/OpenFOAM/ThirdParty-2.1.x/platforms/linux64Gcc/openmpi-1.5.3/lib/ (0x00007f5bb0f4a000) => /home/user/OpenFOAM/OpenFOAM-2.1.x/platforms/linux64GccDPOpt/lib/ (0x00007f5bb0d40000) => /lib/x86_64-linux-gnu/ (0x00007f5bb0b3c000) => /lib/x86_64-linux-gnu/ (0x00007f5bb091f000)

On the machine where it doesn't work, check if the paths for the libraries are the same as on the main machine.

If they are, check what the following commands give you on each machine:

echo $PATH

  1. The first shows the list of paths that are looked at when you want to run an application by simply stating it's name.
  2. The second one is the list of paths that are searched when looking for libraries by name.

Best regards,

All times are GMT -4. The time now is 15:03.