CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Paraview refuses to start after installation of OpenFoam (

flotus1 May 24, 2013 09:49

Paraview refuses to start after installation of OpenFoam
First of all I have to admit that I am not an expert on Linux. I wouldnt even consider myself as en experienced user. So please be patient ;)

My problem is: up to now, I was able to use Paraview 3.98.1 64Bit on OpenSuse 11.4.

Yesterday, I installed OpenFoam with the help of the description in the OF-wiki

Now when I try to run Parawiew (3.98, not the one contained in the OF installation), I get the following error:


ERROR: In /home/utkarsh/Dashboards/MyTests/NightlyMaster/ParaViewSuperbuild-Release/paraview/src/paraview/VTK/GUISupport/Qt/vtkEventQtSlotConnect.cxx, line 68
vtkEventQtSlotConnect (0xbb3b20): Cannot connect NULL objects.

What could I do to run ParaView again?

After a google search, I came up with the following site:


I noticed I had this OpenFOAM script in .bashrc adding a path to old Paraview libraries in LD_LIBRARY_PATH. After clearing that everything worked.
Apparently, I also had an extra-line in my .bashrc from the OF installation, but commenting it out, logging off and in again did not solve my problem.

Any suggestions would be welcome.

wyldckat May 24, 2013 18:22

Greetings Alex,

That's what happens when you only partially follow instructions ;)

From your description, it looks like you installed the Qt4 libraries unintentionally, since you didn't want to build ParaView from source code.
In theory, you can uninstall the Qt4 libraries like this:

su -

zypper remove libqt4-devel qt4-x11-tools qt4-assistant-adp-devel


Caution: If you are using KDE, this is not advisable!

Best regards,

flotus1 May 25, 2013 05:26

Ok, so what would be advisable if I AM using KDE?

wyldckat May 25, 2013 11:53

Hi Alex,

I was hoping you wouldn't have KDE installed :)

OK, I need to know a few details so I can try and reproduce the same error:
  1. The ParaView 3.98.1 version you have installed, how exactly did you install it?
  2. How are you making it accessible on the terminal?
  3. Did you build ParaView 3.12.0 as well, according to the installation instructions on the wiki page?
edit: OK, I've tested this on a virtual machine with OpenSUSE 11.4 64 bit with KDE and here's a quick test I ask you to do - run in the terminal the following command:

(wmUNSET; paraview)
This basically will clear the OpenFOAM shell environment and then run the ParaView version you want to use. The parenthesis makes the execution run in a sub-shell, therefore not affecting your current shell. So as soon as ParaView is closed, you can continue using OpenFOAM without any problems. At least it should, if all goes according to plan.

By the way, I was only able to reproduce the same error, because I also built ParaView 3.12.0 from source code, as instructed in the wiki page :)

Best regards,

flotus1 May 27, 2013 03:55

Thanks a lot for your effort.
  • The ParaView 3.98.1 version you have installed, how exactly did you install it?
I downloaded the binaries from "" and put them in a folder "/usr/Paraview/ParaView-3.98.1-Linux-64bit/"
  • How are you making it accessible on the terminal?
I created an "alias pv='/usr/Paraview/ParaView-3.98.1-Linux-64bit/bin/paraview'" entry in /home/username/.bashrc
But no matter if I use the alias or execute the binary explicitly, the error persists.
  • Did you build ParaView 3.12.0 as well, according to the installation instructions on the wiki page?
I did EVERY step in the installation instructions. So yes, I also built ParaView 3.12.0 from scratch.
I mostly did this because only with the "ParaFoam" application of the "full" OpenFOAM installation, I was able to visualize the output of the OpenFOAM meshing process.
I actually had no idea how to get the same visualization with ParaView 3.98.1.

run in the terminal the following command:

(wmUNSET; paraview)
OK. this creates the error message:
If 'wmUNSET' is not a typo you can use command-not-found to lookup the package that contains it, like this:
cnf wmUNSET

and runs ParaView 3.12.0. After I close this ParaView session, I still get the same error message trying to run ParaView 3.98.1. No matter if I try it in the same shell or in another shell.

wait a minute...

Forgot to un-comment the entry from the OpenFoam installation in the .bashrc.
Now if I enter

(wmUNSET; pv)
My 3.98.1 version of Paraview runs again
However in a new shell, this does not work. The error from my initial posting comes up again.
Now including

somehow to my ParaView alias seems a bit like a dirty workaround.

wyldckat May 27, 2013 16:38

Hi Alex,

You can change your alias to this:

alias pv='(wmUNSET; touch case.foam; /usr/Paraview/ParaView-3.98.1-Linux-64bit/bin/paraview --data=case.foam)'
Best regards,

flotus1 May 28, 2013 03:49

1 Attachment(s)
What exactly is this supposed to do?
When I start ParaView with this alias, I get the following error message:
Attachment 22164
Additionally, there is this case.foam item which I usually dont need.
However, if I change the alias to

alias pv='(wmUNSET; /usr/Paraview/ParaView-3.98.1-Linux-64bit/bin/paraview)'
that seems to do the trick for my purposes.

I had a quick look at the paraFoam shell script. How exactly can I get it to use the 3.98.1 version of ParaView instead?

wyldckat May 28, 2013 17:27

Hi Alex,

Sorry, I was in a hurry and I wasn't clear enough.
ParaView 3.98.1 has an internal ".foam" reader for OpenFOAM cases. The alias I had shown you would automatically work as if you were running paraFoam.

You have at least two options:
  • You can create an alias that will override the usage of paraFoam:

    alias paraFoam='(wmUNSET; touch case.foam; /usr/Paraview/ParaView-3.98.1-Linux-64bit/bin/paraview --data=case.foam)'
  • Or you can edit the paraFoam script; after the big comment header and before the "usage()" line, add these two lines:

    . $WM_PROJECT_DIR/etc/config/
    export PATH=/usr/Paraview/ParaView-3.98.1-Linux-64bit/bin/:$PATH

    Then search for these two lines:

    # reader extension

    And replace with this:

    # reader extension

Best regards,

flotus1 May 29, 2013 03:02

Thank you so much!

mahtin360 February 24, 2014 14:08

Paraview error with foam extend
Hello Bruno,

I'm getting a similar error when trying to start Paraview 4.0.1 that came with foam extend-3.0. I've recently started using Ubuntu (13.10) for the first time.

I have installed OF2.2.2 from source a few weeks ago but that stopped working, recently i installed OF2.3.0 from the deb pack and everything seems to be working so far.I followed your instructions for the installation of FE30 (

When I want to launch paraFoam having the Foam extend 3.0 environment I get following error message:


ERROR: In /home/martin/foam/foam-extend-3.0/ThirdParty/rpmBuild/BUILD/ParaView-v4.0.1-source/VTK/GUISupport/Qt/vtkEventQtSlotConnect.cxx, line 68
vtkEventQtSlotConnect (0x205bac0): Cannot connect NULL objects.

/home/martin/foam/foam-extend-3.0/bin/paraFoam: line 122: 14190 Segmentation fault      (core dumped) paraview --data="$caseFile"

opening ParaView from the third party directory by double clicking works.
Could this error be similar, i.e. due to installing OF2.2.2 from source (including the Qt4 libraries)? So could I simply remove the libraries as you have advised above?

Is there another way around this, i.e. could i link the paraFoam command to the functioning version that came with OF2.3.0?

do you have any advice for me on this?

Thanks, Martin

wyldckat March 1, 2014 19:54

Greetings Martin and welcome to the forum!

My first suspicion is that you might not have taken care of how your "~/.bashrc" file looks like.
To help you diagnose this, please run the following command:

tail ~/.bashrc
As for OpenFOAM 2.2.2 stopped working, I believe it might have something to do with the instructions I had written, as there was a typo in the command that generated the alias command for "of222". The command above should also give us some information about this.

As for foam-extend 3.0: again, it might be related to how your "~/.bashrc" file is configured or if you were following the installation steps, while the OpenFOAM 2.2.2 environment was active, which would lead to some problematic issues.

Best regards,

mahtin360 March 6, 2014 06:35

Hello Bruno,
thanks for your reply. I think I might have tried to install foam-3.0 while the 2.2 environment was active. Anyways, i got passed that stage by installing OF2.3. which so far works well. My bashrc looks like this:


tail ~/.bashrc

alias of23='. /opt/openfoam230/etc/bashrc'
alias fe30='source $HOME/foam/foam-extend-3.0/etc/bashrc'

From what I've tried so far, I can run the cases and using the touch command creating an .OpenFOAM which i can then read into paraview 4.0.1 where I have to select OpenFOAM from a list of readers.

thanks for your help

wyldckat March 6, 2014 15:42

Quick tip:

alias parafoam="touch case.foam && paraview --data=case.foam"

All times are GMT -4. The time now is 16:31.