CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   OpenFOAM 2.2.0 and 2.1.0 side by side errors (

Neraste June 10, 2013 03:02

OpenFOAM 2.2.0 and 2.1.0 side by side errors
1 Attachment(s)
Hello all OpenFOAM community users !

I am running an x86 version of openSuSE 12.3 and I am experiencing problems to get OpenFOAM 2.2.0 and 2.1.0 co-existing.

I have installed OF 2.2.0 directly through RPM packages, and all the dependencies for this version have been installed. OF 2.2.0 works well on my system.

Then, for some reasons, I have had to install OF 2.1.0 and keep OF 2.2.0. I have tried to install it through RPM packages too (option --force). I have installed Scotch and Paraview successfully, but when it came to OpenFOAM, I get the following error:


error: Failed dependencies: is needed by OpenFOAM-2.1.0-1.i586 is needed by OpenFOAM-2.1.0-1.i586

I Well, then, I decided to remove 2.1.0 RPMs and to compile OF from sources. But I get many errors at compilation such as:

/usr/lib/gcc/i586-suse-linux/4.7/../../../../i586-suse-linux/bin/ld: cannot find -lengine
/usr/lib/gcc/i586-suse-linux/4.7/../../../../i586-suse-linux/bin/ld: cannot find -lcompressibleTurbulenceModel
/usr/lib/gcc/i586-suse-linux/4.7/../../../../i586-suse-linux/bin/ld: cannot find -lcompressibleRASModels
/usr/lib/gcc/i586-suse-linux/4.7/../../../../i586-suse-linux/bin/ld: cannot find -lbasicThermophysicalModels
/usr/lib/gcc/i586-suse-linux/4.7/../../../../i586-suse-linux/bin/ld: cannot find -lreactionThermophysicalModels
/usr/lib/gcc/i586-suse-linux/4.7/../../../../i586-suse-linux/bin/ld: cannot find -llaminarFlameSpeedModels
/usr/lib/gcc/i586-suse-linux/4.7/../../../../i586-suse-linux/bin/ld: cannot find -lfiniteVolume
/usr/lib/gcc/i586-suse-linux/4.7/../../../../i586-suse-linux/bin/ld: cannot find -ldynamicFvMesh
/usr/lib/gcc/i586-suse-linux/4.7/../../../../i586-suse-linux/bin/ld: cannot find -lOpenFOAM
collect2: error: ld returned 1 exit status
make[2]: *** [/opt/OpenFOAM-2.1.0/platforms/linuxGccDPOpt/bin/PDRFoam] Error 1
make[1]: *** [PDRFoam] Error 2
make[1]: Target `application' not remade because of errors.
make: *** [combustion] Error 2

If you want, you can find the logfile of compilation (I have aborted the process).
Attachment 22563

Hardly no binaries are compilated on bin dir, like virtually no libraries are compilated on platforms/linuxGccDPOpt/lib dir...

So I do not know how to have a working version of OF 2.1.0...

wyldckat June 10, 2013 07:46

Greetings Neraste,

This is indeed a strange error... I can only guess that the problem is due to an incorrect configuration on how to use Gcc 4.7.

OK, let's go by steps:
  1. How are you keeping the two versions apart from each other? ... from the point of view of the shell environment. If you don't understand what I mean, please read this: Advanced tips for working with the OpenFOAM shell environment
  2. For installing OpenFOAM 2.1.0, I suggest that you choose 2.1.1 instead and try following these instructions: - I have not tested them in 12.3, but I think they should work well.
    Note: these instructions do not take into account the first step on this current list.
Best regards,

Neraste June 12, 2013 04:55

Hello wyldckat

Thank you for your answer!

About the way I make each version living side by side, both versions are installed on separate folders in /opt, with their own dependencies (differently organized between 2.2.0 and 2.1.0, by the way):
  • /opt/OpenFOAM-2.1.0
  • /opt/OpenFOAM-2.2.0
  • /opt/OpenFOAM-ParaView-3.12.0 (for 2.2.0)
  • /opt/OpenFOAM-scotch-6.0.0 (for 2.2.0)
  • /opt/ThirdParty-2.1.0 (for 2.1.0, containing Paraview and Scotch)
To set up the environment for each version, I have aliases to source the right bashrc file:
  • alias startFOAM210="source /opt/OpenFOAM-2.1.0/etc/bashrc"
  • alias startFOAM220="source /opt/OpenFOAM-2.2.0/etc/bashrc"
So, I have prevented the case of messing environments up. And each bashrc have the right installation folder indication...

Well, then, what I did is to compile version 2.1.1 instead. I already knew the installation guidelines wiki. Everything has worked as expected and just works...

So, since it works, I kinda have no problem, but I am still puzzled by the 2.1.0 compilation errors...

All times are GMT -4. The time now is 17:30.