CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Installation on ubuntu 13.04 (

mvee June 18, 2013 02:06

Installation on ubuntu 13.04
Hi all

I have recently installed ubuntu 13.04, on which I would like to install openfoam. I could not fine the procedure to install openfoam v2.2.0

Can anyone please tell me the procedure? Does openfoam v2.2.0 compatible with ubuntu 12.10?

What changes are required to make it compatible with 13.04?


mvee June 19, 2013 04:30


I tried to install OF 2.2.0 on Ubuntu 13.04. When I gave command of sudo apt-get update, I did not able to install few packages that prevents me to install the OF.

Is there any other way to install it? I have followed the way similar to the installation on ubuntu 12.10.

Thanks in advance

pitpat231 June 20, 2013 05:18

paraview error on ubuntu 13.04
plsi need your advice, am kinda new to ubuntu, so i will really appreciate a simplified solution (step by step if possible). i recently installed openfoam2.2.0 on my ubuntu 13.04 OS, 64bit system. i ran the motorbike case on openfoam, it ran alright the trying to view it on paraview i get the following error ;

ERROR: In /build/buildd/paraview-3.98.0/VTK/IO/Geometry/vtkOpenFOAMReader.cxx, line 4468
vtkOpenFOAMReaderPrivate (0x23b6cc0): Error reading line 20 of /home/chijioke/OpenFOAM/chijioke-2.2.0/run/tutorials/incompressible/simpleFoam/motorBike/system/forceCoeffs: Found duplicated entries with keyword log

ERROR: In /build/buildd/paraview-3.98.0/VTK/Common/ExecutionModel/vtkExecutive.cxx, line 753
vtkPVCompositeDataPipeline (0x23afd40): Algorithm vtkPOpenFOAMReader(0x239f370) returned failure for request: vtkInformation (0x23b6c70)
Debug: Off
Modified Time: 111085
Reference Count: 1
Registered Events: (none)

pls i will really appreciate a solution from the house.
p, li { white-space: pre-wrap; }

mvee June 20, 2013 06:00

Hi pitpat231

How did you install OF? I could not.
Can you please tell me the procedure? I have followed the procedure described on OF site but got error of "certain packages are not installed".

Please tell me how to install.

Thank you

pitpat231 June 20, 2013 09:42

i actually saw the procedure on openfoam website. here is the link;

pls dose anyone have Bruno, wlydkat's email, or the Engys Guys own, i really need them to help me out with my above problem.

wyldckat June 20, 2013 16:06

Greetings to all!

@Mvee: :confused: I'm sorry, but I gotta ask this... Did you try using Google or some other online search engine to look for the following sentence?

OpenFOAM Ubuntu 13.04
I ask this because, at least for me, the first link I get points to here: - and if you click on the link for "Ubuntu 13.04", you would find all of the instructions you need to install OpenFOAM 2.2.0 :(:

@pitpat231: Uhm... did you at least try and click on my user name link? Because you should get indications about how to contact me in my user page!
As for Helyx-OS, there is a dedicated discussion board they have got here:
Either way, I see you've already gotten an answer for your question about Helyx-OS:

Also, about the problem you're having with ParaView:
  1. Edit the file "system/forceCoeffs" that you have inside the case folder "incompressible/simpleFoam/motorBike/".
  2. Find this line:

    log        true;
  3. Remove that line.
  4. Save and close the file.
  5. Try running paraFoam once again.
Best regards,

pitpat231 June 21, 2013 07:01

@Bruno, thanks alot, it worked, my paraview dosent give the error again. i managed to get the stl geometry showing in helyx, in trying to creat my mesh and running the solver i get the following error;

MPI_ABORT was invoked on rank 3 in communicator MPI_COMM_WORLD
with errorcode 1.

NOTE: invoking MPI_ABORT causes Open MPI to kill all MPI processes.
You may or may not see output from other processes, depending on
exactly when Open MPI kills them.
mpirun has exited due to process rank 3 with PID 3555 on
node chijioke-W240HU-W250HUQ exiting without calling "finalize". This may
have caused other processes in the application to be
terminated by signals sent by mpirun (as reported here).
[chijioke-W240HU-W250HUQ:03550] 1 more process has sent help message help-mpi-api.txt / mpi-abort
[chijioke-W240HU-W250HUQ:03550] Set MCA parameter "orte_base_help_aggregate" to 0 to see all help / error messages

pls how do you advice i handle this ???
thanks in advance

edit: Hi Bruno, just to add that my laptop is a intel corei7, so am running the solver on 7 proccessors.


wyldckat June 22, 2013 16:02

Hi Patrick,

I'll answer on the other dedicated thread you've got:
edit: didn't manage to do it yesterday, but chegdan is on the case :)

Best regards,

All times are GMT -4. The time now is 06:44.