CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   How to install ccm26ToFoam in OF2.2.x and convert a ccm file (

donQi October 3, 2013 22:36

How to install ccm26ToFoam in OF2.2.x and convert a ccm file
1 Attachment(s)
While compiling the ccm26ToFoam utility I got the following error:

* The license of the libccmio library is proprietary:
Users wishing to make use of its functionality should contact CD-Adapco
for possible download and terms of use.
Usage: AllwmakeLibccmio
* This script will install the libccmio library

Here the solution I found, hope can help somebody:

1) download the libccmio-2.6.1 library from the following website

2) uncompress libccmio-2.6.1.tar.gz and copy the libccmio-2.6.1 directory in


cd /your.OpenFOAMinstallation.path.../OpenFOAM/ThirdParty-2.2.x/

4) compile ccm26ToFoam

cd /your.OpenFOAMinstallation.path.../OpenFOAM/OpenFOAM-2.2.x/applications/utilities/mesh/conversion/Optional

5) copy your ccm file in the StarCCMTemplate.for.ccm directory (please file attached)

6) enter the directory where you have just copy the ccm file and launch the command


ccm26ToFoam nameFile.ccm

wyldckat October 5, 2013 07:54

Greetings donQi,

Thanks for sharing! I've added the link to this thread to this wiki page: - feel free to edit the wiki page.

As for your post, please use the [CODE] markers for the example commands you've given, as explained in the second link of my signature ;)

Best regards,

donQi October 13, 2013 23:05

Greetings Bruno, I add the [CODE] markers.

And let me take this opportunity to thank you for your excellent contributions to this Forum.

Best regards,

sudo November 4, 2013 17:19

Not working for me.
It's great that it seems to be much easier now to compile this lib. I tried to do it a few months ago and was not successful. Thanks in advance.

Now, I followed exactly what donQi outlined in the 1st post but I still can not do it. Here are my questions:
1. The untarred folder has no AllwmakeLibccmio script inside, actually it does not exist at all in the folder. So, am I missing something here?

2. It seems to me (and I am not an expert in compiling QT projects) that the downloaded file is a QT4 project. I tried opening the file in QT Creator in Ubuntu 12.10 64 bit, tried to configure the project but received two errors.

So, could you please either update the info in the first post or let me know how to run the AllwmakeLibccmio?


EDIT: The script in post #51 here:
seems to have worked. ccm26ToFoam binary file was generated, used it to convert a 2D mesh (back step tutorial) I had exported from CCM+, the polymesh folder have been updated but....ParaFoam does not show the mesh as it encountered errors. Any ideas?

sudo November 4, 2013 18:46


The script written by Bruno does work. I will post about my visualization issues in a new thread.

wflo March 23, 2014 17:54

Convert StarCCM to OPenFoam 2.2.2
Following donQi's post I was able to make it down to the 3rd step. I downloaded the libccmio-2.6.1.tar.gz and I uncompressed the file. The AllwmakeLibccmio shell script did not run but the ccm26local shell script did. Both files must run in order for it to work correct? Why does the AllwmakeLibccmio not run when I try to execute it?

wyldckat March 30, 2014 12:43

Quick answer - @wflo: Try the instructions indicated in post #4: star-ccm mesh to O\/F - post#51

All times are GMT -4. The time now is 02:06.