CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   failed to install openFoam 1.6ext (

mary mor November 23, 2013 11:32

failed to install openFoam 1.6ext
2 Attachment(s)
I tried to install OpenFOAM 1.6-ext following the instructions on Wiki by source on Ubuntu 10.04 i686. But it seems not being installed due to some errors.
I attach the log files here which are made after making Third Party and ./Allwmake in the main directory.
Can anyone please tell me what are these errors due to? I'm afraid by repeating the procedure I face the same errors.


wyldckat November 23, 2013 11:50

Hi Maryam,

I suppose you mean these instructions:

According to the output files, it seems that the application rpm has not been installed, as indicated in step #1

Best regards,

mary mor November 23, 2013 13:37

Thanks Bruno:)
Sorry about not mentioning the link.
Yes, the command rpm is not found. When I run the command again it doesn't start installing rpm and says: Also it says libstdc++5 not found.


root@maryam-desktop:~# apt-get install git-core flex bison rpm build-essential zlib1g-dev binutils-dev libstdc++5 \
> libqt4-dev qt4-dev-tools libxext-dev libxt-dev libreadline-dev libncurses-dev
Reading package lists... Done
Building dependency tree     
Reading state information... Done
git-core is already the newest version.
flex is already the newest version.
flex set to manually installed.
bison is already the newest version.
zlib1g-dev is already the newest version.
zlib1g-dev set to manually installed.
binutils-dev is already the newest version.
binutils-dev set to manually installed.
E: Couldn't find package libstdc++5

The other thing seems to be wrong is that it says Couldn't find package libstdc++5 which I ignored it in the process of installing:D

Best regards

wyldckat November 23, 2013 16:32

Hi Maryam,

I made a quick search and it seems that the missing library is part of the "universe" repository.
In order to turn it on, follow these instructions:
Er, only the part about adding the repository and updating apt-get ;)

Best regards,

mary mor November 24, 2013 07:41

Thanks Bruno,
For missing library I tried the way explained in the link, but again the same error. I searched on the net and tried some other ways...still no success.
For rpm I ran apt-get install rpm. It seems to install then. but I don't understand why it didn't install by the text presented in Wiki besides other libraries.

For removing the compiles sources of this openfoam I tried to install is it correct to run wcleanAll in the main directory and Thirdparty folder?

Thanks so much

wyldckat November 24, 2013 08:12

Hi Maryam,

If rpm is now installed and working, all you have to do is to follow the instructions from step #9 at

This is because the building process is able to update and build what was missing from the first runs.

Best regards,

mary mor November 24, 2013 15:45

Ok thanks I skipped to step 9 and I hope this time it works.

For the missing library I installed it finally. I mention it here in case someone get into trouble.
I had to add:

deb lucid-backports main universe
in sources.list as mentioned in page:
after that running:

apt-get install git-core libstdc++5

sur4j December 11, 2013 18:12


I tried to install opnefoam 1.6 ext and got to the part of the tutorial at which I had to use the third party command:


./AllMake > log.AllMake 2>&1
I left it for a while and then ran it again and nothing happened then I ran the command:


gedit log.AllMake
And got a log with the folowing errors:


Error: Directory does not exist /opt/ThirdParty-2.2.1
Error: Current directory is not $WM_THIRD_PARTY_DIR
    The environment variables are inconsistent with the installation.
    Check the OpenFOAM entries in your dot-files and source them.

I dont know what to do, I have tried to rerun the command but nothing is happening. I would really appreciate some help with this.


mary mor December 14, 2013 03:42

are you having another version of OpenFoam installed like 2.2.1?
maybe the inconsistency in .bashrc file make this problem because you call another version of openFoam too.

Best regards

nimasam December 15, 2013 02:52

as maryam said:

aybe the inconsistency in .bashrc file make this problem because you call another version of openFoam too.
you should source your extended version at bashrc, you can differ between version with alias for example

alias of221='. /opt/........'
alias of16ext='./ ......../'
then every time you open the terminal you should recall your version with of221 or of16ext

All times are GMT -4. The time now is 13:44.