CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   foam-extend-3.0 installation (

codder December 21, 2013 22:50

foam-extend-3.0 installation
Dear Foamers -

I attempted to install foam-extend-3.0 according to the instructions on:

My approach was to:

(1) Run inside ~/foam

(2) Then follow but without using

export QT_BIN_DIR=/path/to/qmake
... yet substituting:

./Allwmake.firstInstall >& log.make
I have no other prior foam installations for this user. My .bashrc contains


source /home/eric/foam/foam-extend-3.0/etc/bashrc
I did not, for example, copy a etc/ to etc/ Only the Wikki instructions were used.

(3) I then got "paraFoam -builtin" working by updating the script:

wget "" -O paraFoam

... as per this post.

Thank you so much Wikki and various contributors! Installing the extend code base was never so easy (at least for me) before.

codder December 26, 2013 18:54

I believe compiling within ~/foam/foam-extend-3.0 directory breaks compatibility with version checks performed here:


... if you desire swak4Faom, it may be better to maintain ~/OpenFOAM/OpenFoam-1.6-ext and edit within etc/bashrc:


export WM_PROJECT=foam
export WM_FORK=extend



... although I have not tried this. As a newbie, I'm not sure what other code performs version checking.

wyldckat December 30, 2013 18:01

Greetings Eric,

Many thanks for sharing your findings!

On this topic, I've finished setting up the first wiki pages at for installing foam-extend-3.0:

Most of the instructions are pointing to the official installation instructions, but I've done some tests of my own in building on Ubuntu 12.04, 12.10 and 13.10, which are all presently documented at:
Note: these instructions are considerably different from the ones presently located at - simply because I relied on the old way for 1.6-ext and because I didn't want to build with CUDA support.

Since foam-extend-3.0 is still rolling out, there are still some details that need fine tuning (which is also why I went with the old build strategy). One of them is the need to wait for the release of swak4Foam 0.3.0, as reported here:

Best regards,

tladd April 2, 2014 17:27

foam-extend-3.0 on Centos 6.5
I have been experimenting with installing foam-extend-3.0 on Centos 6.5

It turns out to be quite straightforward since the installed compiler gcc 4.4.7 is sufficiently up to date. The official instructions for extend-1.6 on Centos 5.5 (foam-extend-3.0/doc/buildInstructions/Centos/5.5) are close to what is needed for foam-extend-3.0.

The listed system packages were all installed on my version of Centos but in addition you need to install binutils-devel:
(as root)
yum install binutils-devel
Otherwise the library file libiberty.a is missing which causes the compilation of openfoam to fail

In addition if you want an automatic installation of swak4foam you should also install mercurial:
yum install mercurial

Finally you need to make it install qt-4.8.5 by setting QT_THIRD_PARTY=1. My file (in foam-extend-3.0/etc) was:
export FOAM_VERBOSE=1 # Verbose for install

compilerInstall=System # Use System compiler


export QT_THIRD_PARTY=1 # Use Third Party QT

If you use the SYSTEMOPENMPI then you need to source the module environment as with the official OpenFOAM release:
module load openmpi-x86_64

Then just
./Allwmake.firstInstall > wmake.log 2>&1

At first I tried to use the third-party gcc (because I had not realized I needed binutils-devel) but this caused problems. I had a number of issues with the system compilers but I will file bug reports on these as soon as I get my sourceforge registration. But I could not get any of the versions of gcc to compile. I had to link other wmake rules in some cases and so I was not sure if this was correct (also the spec files for 4.6 do not match the AllMake.stage1), but even after this I would get errors because the system compiler could not find the gmp etc. libraries. I fixed this with LD_LIBRARY_PATH but there was a further problem at which point I gave up and went back to make the system compiler work.

Finally I could not get the doxygen to compile correctly - the first error is
18850 Preprocessing /global/usr/apps/FOAM/foam-extend-3.0/applica/global/usr/apps/FOAM/foam-extend-3.0/applications/solvers/multiphase/interPhaseChangeFoam/phaseChangeTwoPhaseMixtures/Merkle/Merkle.H:120: Warning: reached end of file while inside a verbatim block!
18851 The command that should end the block seems to be missing!
18853 tions/solvers/multiphase/interPhaseChangeFoam/alphaEqn.H...

I think the error message fragmented the output line because I merged both streams into 1 file.

bieshuxuhe May 8, 2014 05:30

I did as Eric Bryant(foam-extend-3.0 installation) told us .
but i get

sxh@sxh-VirtualBox:~/foam/sxh-3.0/run/tutorials/incompressible/icoFoam/cavity$ paraFoam -builtin
created temporary 'cavity.foam'
/home/sxh/foam/foam-extend-3.0/bin/paraFoam: 267: /home/sxh/foam/foam-extend-3.0/bin/paraFoam: paraview: not found

could you help me ? what is wrong?



I am so sorry !
I have solve this problem by :

sudo apt-get install paraview
sorry again:o

codder May 9, 2014 00:35

follow this link instead
This thread is out-dated. It referred to installation before this wiki page was created:

Best, E

tladd May 19, 2014 11:35

foam-extend-3.0 on Centos 6.5

The wiki page is for Fedora 19. It is not necessarily the same in RHEL/CentOS 6, which is based on Fedora 12.


All times are GMT -4. The time now is 21:31.