CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   OpenFoam Extend-3.0 - libscotch 6.0 compilation Problem ( January 27, 2014 11:54

OpenFoam Extend-3.0 - libscotch 6.0 compilation Problem
1 Attachment(s)
I was trying to compile Extend 3.0 with GCC 4.4.5 and OpenMpi 1.6.5 / OpenMP 1.4.3, I encountered this error with libScotch -


mpicc -O3 -DCOMMON_FILE_COMPRESS_GZ -DCOMMON_PTHREAD -DCOMMON_RANDOM_FIXED_SEED -DSCOTCH_RENAME -DSCOTCH_PTHREAD -Drestrict=__restrict -Xlinker --no-as-needed -DSCOTCH_PTSCOTCH -shared -fPIC -c dgraph_fold_comm.c -o dgraph_fold_comm.o
/tmp/iccxUPTfC.o: In function `main':
dummysizes.c:(.text+0x51e): undefined reference to `__intel_sse2_strcpy'

Attached is the file
Attachment 28291

I tried to search over the internet with libscotch and could not find a solution. Also looks like an intel processor directive problem, should I compile with ICC?


RKC January 28, 2014 12:17

I tried compiling with ICC 12.1 and the libscotch 6.0 compiled successfully. I read on a forum that the above error is generated due to cross compiling of ICC and GCC. I think some file in scotchlib-6.0 is compiled with ICC.


chegdan January 28, 2014 12:30

This error is because things aren't quite linked up correctly with your ICC. Remember, when you select "system" as your compiler and "Icc"...OpenFOAM backs away with its hands up in the air and says "I will assume you have this Icc thing all set up correctly" and just set a few things for you. I believe to fix this, i needed


# Intel Compiler
export PATH=/opt/intel/composerxe/bin:$PATH
export LD_LIBRARY_PATH=/opt/intel/composerxe/lib/intel64:$LD_LIBRARY_PATH

in my .bashrc before anything OpenFOAM related was sourced. You can tell I am using this may be a little different in other OSs. I did this with the standard OpenFOAM and have not gotten around to trying foam-3 with it yet...maybe now is a good time for me to try.

Edit: My Icc version was the you may not have composerxe but some other <name-version>. There were several posts on other forums that showed how to correctly source Icc for older versions. January 30, 2014 12:09

Finally Compilation Sucess
The compilation with GCC worked, after I found out that the system openmpi was compiled with ICC and there was cross compilation problems. When I compiled openmpi myself the problem disappeared. The settings I used are GCC4.4.5 and OpenMPI 1.4.3. The only problem was it could not find -liberty flag and I installed the binutils locally from the instructions here

Thanks for your suggestions for ICC, I will try soon. January 31, 2014 15:21

I compiled with ICC and intel mpi. I had few hiccups, but most had solutions were from the following link:

Thanks Again

All times are GMT -4. The time now is 19:08.