CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Installation problems OF-1.6-ext on Ubuntu 12.04 and SUSE (

fedvasu March 17, 2014 10:04

Installation problems OF-1.6-ext on Ubuntu 12.04 and SUSE
Hi Foamers,

I need to install OF-1.6-ext to use "apparently" better meshing capabilities of OF-1.6-ext for moving meshes.

I have built ThirdParty part very successfully but I keep getting build errors with OF

/usr/lib64/gcc/x86_64-suse-linux/4.6/../../../../x86_64-suse-linux/bin/ld: cannot find -ldynamicFvMesh
/usr/lib64/gcc/x86_64-suse-linux/4.6/../../../../x86_64-suse-linux/bin/ld: cannot find -lengine
/usr/lib64/gcc/x86_64-suse-linux/4.6/../../../../x86_64-suse-linux/bin/ld: cannot find -ltopoChangerFvMesh
/usr/lib64/gcc/x86_64-suse-linux/4.6/../../../../x86_64-suse-linux/bin/ld: cannot find -lautoMesh

similar errors I get for my Ubuntu install as well. I have sucessfully built OF-2.2.1 and OF-2.2.2 on both systems

such lines through-out the logs, is there any dependency missing, am I doing something terrible? I have followed the instructions from openfoamwiki.

wyldckat March 22, 2014 06:01

Greetings fedvasu,

I assume you're following these instructions:

As indicated in step #12, it refers to searching for errors in the file "log.AllMake". It's the first error that usually tells the whole story, because all other errors derive from that one. If you're unable to tell apart which one is the most relevant, please attach the file "log.AllMake.tar.gz" to your next post.

edit: er, the above is regarding ThirdParty. You should also do the same as indicated in step #14.

Best regards,

fedvasu March 23, 2014 12:19

here is the log file
1 Attachment(s)
Hi WyldKat,

Here is the log file for OF compilation, I couldn't spot any error there but here it is

the above post output was from the terminal (stdout).

wyldckat March 23, 2014 12:32

Hi fedvasu,

Something isn't right here. Are you sure you ran the command exactly like this?

./Allwmake > make.log 2>&1
Best regards,

fedvasu March 23, 2014 13:21

Hi WlydKat,

yes I did run the script exactly like that, do you suggest I redo the compilation? (I mean after deleting the directory and purging all environment variables)

If so it might take some time.


wyldckat March 23, 2014 13:27

No need to rebuild from scratch. I'm just wondering what happened to the error you've originally reported :confused:

Because from that "make.log" file, everything seems to be fine. It's possible that something that went wrong in the first build attempt, was fixed in the second pass. You can try running Allwmake a third time, just to make sure everything is indeed built correctly, as it will tell you what libraries and solvers are up-to-date.

fedvasu March 26, 2014 17:05

Hi Wyldkcat,

I will update OF-1.6-ext install (the computer is offline)

in the mean-time, I would like to ask you question about mpirun with openfoam-2.3.0 install on fedora 20, I hope you don't mind, I am not trying to divert the thread topic (well a bit :))

there is no mpi directory in


CGAL-4.3/    scotch_6.0.0/
I have religiously followed all the instructions from OF-wiki

but when i run

mpirun -np4 pimpleDyMFoam -parallel

I get following error message


Sorry!  You were supposed to get help about:
But I couldn't open the help file:
    /home/vasu/OpenFOAM/ThirdParty-2.3.0/platforms/linux64Gcc/openmpi-1.6.5/share/openmpi/help-opal-runtime.txt: No such file or directory.  Sorry!
Sorry!  You were supposed to get help about:
But I couldn't open the help file:
    /home/vasu/OpenFOAM/ThirdParty-2.3.0/platforms/linux64Gcc/openmpi-1.6.5/share/openmpi/help-orte-runtime: No such file or directory.  Sorry!

the last line in my bashrc

alias of230='module load mpi/openmpi-x86_64; source $HOME/OpenFOAM/OpenFOAM-2.3.0/etc/bashrc'
I hope you can shed some light on this. and yeah mpi is installed

$ which mpirun

wyldckat March 30, 2014 13:13

Hi fedvasu,

I've finally managed to give a look into this. The same happened to me, but only because the alias line in "$HOME/.bashrc" was wrong. So edit that file and check if you have this line:

alias of230='module load mpi/openmpi-x86_64; source $HOME/OpenFOAM/OpenFOAM-2.3.0/etc/bashrc WM_NCOMPPROCS=4 WM_MPLIB=SYSTEMOPENMPI'
The one I had was this:

alias of230='module load mpi/openmpi-x86_64; source  $HOME/OpenFOAM/OpenFOAM-2.3.0/etc/bashrc FOAM_SETTINGS'
which is incorrect.

The other detail is that usually we have to log out and then log back in, in order for the module system to work properly, since apparently it's not installed by default in Fedora :( This is why there is this line in the instructions:

module load mpi/openmpi-x86_64 || export PATH=$PATH:/usr/lib64/openmpi/bin
It works fine, as long as the user doesn't change terminal window in the mean time :rolleyes:

I still need to figure out what and how to write down this situation in the wiki, since this particular step already feels very bloated to read :(

Best regards,

sita April 1, 2014 08:01

Hi all,

Sorry, a bit off-topic maybe, but I'm a bit confused by the installation instructions for OpenFOAM-1.6-ext on Ubuntu 12.04, on the openfoam-wiki.

Under 7. Configure the preferences file, there are some sed-commands to instruct OpenFOAM to use the system installations of openmpi and paraview (two sets of 3 commands). The second line in each set contains a part path_to_system_installed_openmpi or path_to_system_installed_paraview. Should I substitute the actual path on my pc there? And if so, how do I find the path to my system installed openmpi?
Also, I tried substituting the path to my system installed paraview, but then sed gives an error (unknown option... etc...).

Thanks in advance for any help,

wyldckat April 1, 2014 15:10

Greetings Sita,

You simply need to follow the instructions and perform the copy-paste to the command line. No further adjustments are necessary.

If further adjustments were needed, the instructions would either detail them in the main text or in the comments inside each block of copy-paste code, not in the middle of the command ;)

Best regards,

sita April 3, 2014 07:26

Bruno, thanks a lot! OF-1.6-ext works now!

All times are GMT -4. The time now is 20:42.