CFD Online Discussion Forums

CFD Online Discussion Forums (https://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (https://www.cfd-online.com/Forums/openfoam-installation/)
-   -   [Other] openFoam 2.3.x for windows from cfdsupport.com (https://www.cfd-online.com/Forums/openfoam-installation/139159-openfoam-2-3-x-windows-cfdsupport-com.html)

vasava July 18, 2014 05:43

openFoam 2.3.x for windows from cfdsupport.com
 
Now you can download openFoam 2.3.x for windows from the give link (http://www.cfdsupport.com/openfoam-for-windows.html). I have downloaded and checking it right now. There is ready-to-install .exe files. No-cross compiling is needed and it looks quite promising.

There is no read-me file so I am not sure about the sequence of installation. If would be nice to hear what everyone else has to say.

vasava July 18, 2014 05:48

My bad. There is a link about installation instructions (http://www.cfdsupport.com/install-op...r-windows.html).

oilsok July 23, 2014 11:40

looks nice
 
I tested this complied OpenFoam for windows.
It works well :)

but I wonder how to compile OpenFOAM on cygwin...I need to combine some solver :(

vasava July 24, 2014 03:34

I am not sure about that you can ask the support at cfdsupport.

Fabio July 24, 2014 11:07

Hi all, i'm stuck at point 6 of step 3, i don't have any

C:\cygwin64\opt\OpenFOAM\ folder, shuold i create it?

I haven't restrted the system after

run OpenFOAM-2.3.x-reg.bat

shoul be that the problem?

Theodor August 26, 2014 10:58

OpenFoam 2.3.x for Windows installation trouble
 
Hi all!
I'm newbie to OpenFOAM. I tried to install it using cfdsupport.com instructions. But when I try to run example icoFoam I recieve this error:
-bash: blockmesh: command not found
What is the reason?
Thanks in advance,
Theodor C

Wang@nitech October 1, 2014 11:07

Quote:

Originally Posted by Fabio (Post 503000)
Hi all, i'm stuck at point 6 of step 3, i don't have any

C:\cygwin64\opt\OpenFOAM\ folder, shuold i create it?

I haven't restrted the system after

run OpenFOAM-2.3.x-reg.bat

shoul be that the problem?

Hi Fabio,

Yes, you should create the directory yourself.

Wang@NIT

Wang@nitech October 1, 2014 11:10

Quote:

Originally Posted by Theodor (Post 507875)
Hi all!
I'm newbie to OpenFOAM. I tried to install it using cfdsupport.com instructions. But when I try to run example icoFoam I recieve this error:
-bash: blockmesh: command not found
What is the reason?
Thanks in advance,
Theodor C

Hi Theodor,

You should also install MS-MPI contained in the installation directory.
The file name is MSMPISetup.

Wang@NIT

Fabio October 1, 2014 11:25

Oh thank you!

This installation process is valid also for other linux only packages lika Code Aster?

Wang@nitech October 1, 2014 21:58

Quote:

Originally Posted by Fabio (Post 512582)
Oh thank you!

This installation process is valid also for other linux only packages lika Code Aster?

I'm sorry. I am new to OpenFOAM, I have no idea about that.

zombiaska October 5, 2014 05:53

As I undertand this installation is only for win 64

vasava October 6, 2014 02:37

Quote:

Originally Posted by Fabio (Post 512582)
Oh thank you!

This installation process is valid also for other linux only packages lika Code Aster?

This process is for installing openFoam on windows. You can look at openFoam website for instructions for installation on linux. Perhaps this link could help.

Logrus October 6, 2014 05:30

After installation some days ago it worked,
but recently it "crashed".Inputing commands has no respond.I checked system variables (PATH), but openfoam commands ignored(.Bash is not write that commands not found,but they are not works anymore.

Markzhou October 12, 2014 01:06

Dear Theodor,
I have the same problem as yours. How did you solve this problem?
Thank you.
Mark

Quote:

Originally Posted by Theodor (Post 507875)
Hi all!
I'm newbie to OpenFOAM. I tried to install it using cfdsupport.com instructions. But when I try to run example icoFoam I recieve this error:
-bash: blockmesh: command not found
What is the reason?
Thanks in advance,
Theodor C

------------------------

Dear Wang,
I have the same problem as Theodor's, though I installed MS-MPI contained in the installation directory. How should I DO in order to solve this problem?
Thank you.
Mark

Quote:

Originally Posted by Wang@nitech (Post 512579)
Hi Theodor,

You should also install MS-MPI contained in the installation directory.
The file name is MSMPISetup.

Wang@NIT


deepinheart October 29, 2014 07:20

Quote:

Originally Posted by oilsok (Post 502842)
I tested this complied OpenFoam for windows.
It works well :)

but I wonder how to compile OpenFOAM on cygwin...I need to combine some solver :(

Hi Oilsok,

I'm wondering the same and have asked cfd support but no reply jet. Have you got any info?

Thanks!

vasava October 29, 2014 09:28

@ Logrus and @ deepinheart: Did you update your windows installation recently? May be some one more expert can comment if updating windows has something to do with this.

Also have you tried re-installing openFoam from scratch?

schootsi November 6, 2014 09:25

can't find blockMesh
 
I installed OpenFOAM on windows using cygwin64. I'm trying to do the first tutorial, but when I run blockMesh it says:

admin@-PC /opt/OpenFOAM/OpenFOAM-2.3.x/tutorials/incompressible/icoFoam/cavity
$ blockMesh
/opt/OpenFOAM/OpenFOAM-2.3.x/platforms/cygwin64mingw-w64DPOpt/bin/blockMesh.exe: error while loading shared libraries: ?: cannot open shared object file: No such file or directory

Whereas the file is in that location, as far as I can tell. In fact it can find the directory, and in Windows I can see the file is there.

admin@-PC /opt/OpenFOAM/OpenFOAM-2.3.x/tutorials/incompressible/icoFoam/cavity
$ cd C:/cygwin64/opt/OpenFOAM/OpenFOAM-2.3.x/platforms/cygwin64mingw-w64DPOpt/bin

admin@-PC /opt/OpenFOAM/OpenFOAM-2.3.x/platforms/cygwin64mingw-w64DPOpt/bin
$ blockMesh
/opt/OpenFOAM/OpenFOAM-2.3.x/platforms/cygwin64mingw-w64DPOpt/bin/blockMesh.exe: error while loading shared libraries: ?: cannot open shared object file: No such file or directory

It seems to me this error is different from the 'command not found' blockmesh error? Does anyone have a clue what I might be doing wrong?

andras November 12, 2014 13:43

Solution for "error while loading shared libraries: ?"
 
1) Start "OpenFOAM-2.3.x-reg.bat" with admin rights (right click -> Run as Administrator). The install instructions from cfdsupport.com are missing this crucial step. Admin rights are needed for the registry key "HKLM\SYSTEM\CurrentControlSet\Control\SessionMana ger\kernel".

2) Don't source $WM_PROJECT_DIR/etc/bashrc in bash like you are used to for standard installations of OpenFOAM unter *NIX systems.

3) Simply run the solver (paths are searched automatically).


Cheers
Andras

schootsi November 12, 2014 13:52

So I reinstalled the whole thing again and blockmesh is working now. I think I may have installed the components in the wrong order or skipped ms-mpi before :o

Both blockMesh and icoFoam work now, and paraview works as well (also from cygwin), however paraFoam returns the error: -bash: paraFoam: command not found. I've seen this error on this forum on other OS's, but I couldn't find anything for the Windows situation.

Has anyone had this problem? Any thoughts on how to solve it?

Thanks in advance!

andras November 12, 2014 14:38

Work-around for parafoam:
 
In your case directory:

$ touch .foam

$ paraview .foam


Cheers
Andras


All times are GMT -4. The time now is 13:35.