CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Installation

[foam-extend.org] How can I install PARAVIEW on foam-extend 3.1 ?

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree6Likes

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   February 6, 2015, 08:58
Default
  #21
Senior Member
 
Join Date: Jul 2011
Posts: 117
Rep Power: 10
haze_1986 is on a distinguished road
Quote:
Originally Posted by wyldckat View Post
Hi haze_1986,

Then all of that means that ParaView is not installed in your system. And that the ParaView version you have on OpenFOAM 2.3.x was built specifically for OpenFOAM 2.3.x, therefore it's not installed as a "system installed" ParaView version.

Which Linux Distribution are you using? Because installing the system ParaView version depends on the Linux Distribution you are using.

Best regards,
Bruno
Indeed, mistake on my part as I thought that the 2.3.x paraview can be used. I have thus recompiled foam ext 3.1 with paraview using the instructions given by Hassan in post #8 and it works well now. I am using Ubuntu 14.04LTS by the way.

Thanks for the advise.
wyldckat likes this.
haze_1986 is offline   Reply With Quote

Old   March 4, 2015, 09:59
Default
  #22
Senior Member
 
ok
Join Date: Oct 2013
Posts: 346
Rep Power: 9
Maimouna is on a distinguished road
Dear OpenFOAM users,

I backed to you for asking general question about my machine problem. In my machine ubuntu 12.04. I have different OF versions such as OF-2.2.2, OF-2.3.0, and foam-extend-3.1. The problem now that I faced with paraview. For each version, when I tried to run the simulation using paraview, it doesn't show any even I tried the simple cases such as cavity tutorial in any of the previous versions. I tried to remove paraview and reinstall it but unfortunately that is not working. I tried different solutions given by Google and doesn't work too. What's the problem and what is your solution for such theses cases. I need your guide to the right direction to be able to show the simulation. Note that, paraview was working perfectly in my machine without any problem even I had different OpenFOAM versions.

Kind regards

Maimouna
Maimouna is offline   Reply With Quote

Old   March 7, 2015, 19:12
Default
  #23
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 10,942
Blog Entries: 42
Rep Power: 121
wyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to all
Greetings Maimouna,

Can you please provide specific details for each specific item you're referring to?
For example:
  1. When was the last time ParaView worked for you? Namely, what was the last thing you did before you broke ParaView?
  2. How exactly are you keeping OpenFOAM versions separate from each other?
  3. What error messages are you receiving when you try to run ParaView?
  4. What are the exact steps you're doing for using ParaView?
Best regards,
Bruno
__________________
wyldckat is offline   Reply With Quote

Old   March 17, 2015, 05:42
Default
  #24
Senior Member
 
ok
Join Date: Oct 2013
Posts: 346
Rep Power: 9
Maimouna is on a distinguished road
Dear Bruno,

sorry for late reply, that because I didn't recieve CFD emails (it's another problem), but when I checked manually, I got your post.

Anyway, let's answer your questions one by one
1.When was the last time ParaView worked for you? Namely, what was the last thing you did before you broke ParaView?
it was working fine before installing some FSI backages in foam-extend 3.1 ( Philip Cardiff fsi backage solvers [fluidSolidInteraction] + David Bloom backages [FOAM-FSI]).


2. How exactly are you keeping OpenFOAM versions separate from each other?
I have two directories, one is called OpenFOAM for all OpenFOAM's versions 2.2.2, 2.3.0, and another is called foam for extend version.


3. What error messages are you receiving when you try to run ParaView?
In such simple case, i.e. cavity in of222 or fe31, after running apply paraFoam, paraview window was opened but doesn't show any results as shown in the screenshot (attached picture), and no errors shown in the terminal.

4. I applied paraFoam to show the simulation.

I hope that is clear to identify the problem.

Regards with lots of thanks.

Maimouna
Attached Images
File Type: jpg Screenshot from 2015-03-17 10:34:25.jpg (36.8 KB, 32 views)
Maimouna is offline   Reply With Quote

Old   March 21, 2015, 09:44
Default
  #25
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 10,942
Blog Entries: 42
Rep Power: 121
wyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to all
Hi Maimouna,

Good thing you provided an image of what you're seeing, otherwise I wouldn't have managed to figure out what was wrong.

OK, firstly, when I asked how you were keeping versions apart, I was thinking about how you were making sure that there wasn't any collisions in the same shell when you were trying to run applications, for example, for running blockMesh. In other words, I hope you start a new terminal window or tab, whenever you need to use another version/variant of OpenFOAM and activate only one environment per terminal. For more details: http://openfoamwiki.net/index.php/In...ment_Variables

As for the problem: the problem is that in ParaView, you're missing the widget/little window that shows the controls for activating the currently loaded files. To make it show once again:
  • Run either paraview or paraFoam.
  • Then in the menu "View", click on "Object Inspector".
  • As shown in the attached image below, you should now be able to see a widget (small window) in the lower left corner, entitled "Object Inspector".
Best regards,
Bruno
Attached Images
File Type: png Screenshot from 2015-03-21 14:40:14.png (53.7 KB, 17 views)
wyldckat is offline   Reply With Quote

Old   March 22, 2015, 05:53
Default
  #26
Senior Member
 
ok
Join Date: Oct 2013
Posts: 346
Rep Power: 9
Maimouna is on a distinguished road
Many thanks Bruno, it is working now.

Regards

Maimouna
Maimouna is offline   Reply With Quote

Old   March 26, 2015, 06:48
Default
  #27
New Member
 
Norman
Join Date: Mar 2015
Posts: 6
Rep Power: 6
normy is on a distinguished road
Hi Bruno,
I have about the same problem of haze_1986. Although versions involved are fe30 and of230. The only differences are that I've considered as test case Axial_Rotor_SRF of DensityBasedTurbo and when I do for fe30 enviroment:
Code:
[eagle87@eagle87 ~]$ which paraview
/usr/bin/which: no paraview in (/home/eagle87/foam/foam-extend-3.0/ThirdParty/packages/PyFoam-0.6.1/platforms/noarch/bin:/home/eagle87/foam/eagle87-3.0/applications/bin/linux64Gcc48DPOpt:/home/eagle87/foam/site/3.0/bin/linux64Gcc48DPOpt:/home/eagle87/foam/foam-extend-3.0/applications/bin/linux64Gcc48DPOpt:/home/eagle87/foam/foam-extend-3.0/wmake:/home/eagle87/foam/foam-extend-3.0/bin:/usr/lib64/openmpi/bin:/usr/lib64/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/eagle87/bin)
I followed the same guide in https://openfoamwiki.net/index.php/I...oam-extend-3.0 and theorically Paraview should be installed in fe30.
My Linux Distribution is Centos 6.5.
Could you kindly give me some advice?
Sorry but I'm new in OpenFoam world
normy
normy is offline   Reply With Quote

Old   April 4, 2015, 07:40
Default
  #28
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 10,942
Blog Entries: 42
Rep Power: 121
wyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to all
Hi normy,

Quote:
Originally Posted by normy View Post
I followed the same guide in https://openfoamwiki.net/index.php/I...oam-extend-3.0 and theorically Paraview should be installed in fe30.
My Linux Distribution is Centos 6.5.
Could you kindly give me some advice?
I learned with OpenFOAM some years ago that we should never, ever, assume things work as we think they should

OK, foam-extend 3.0... any chance you can upgrade to 3.1, because that would make things easier, since there were several bugs fixed since then.
Either way, please follow these steps:
  1. Start a new terminal and activate only the foam-extend 3.0 shell environment.
  2. Now run these commands:
    Code:
    foam3rdParty
    ./AllMake.stage4 > log.stage4 2>&1
    gzip < log.stage4 > log.stage4.gz
  3. Now attach the file "log.stage4.gz" - which is present in the folder "~/foam/foam-extend-3.0/ThirdParty" - to your next post.
This way I can diagnose what went wrong.

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   June 10, 2015, 15:32
Default Paraview not found for foam-extend 3.1
  #29
New Member
 
despodan
Join Date: May 2015
Location: Cottbus
Posts: 7
Rep Power: 6
Daneish is on a distinguished road
Send a message via Skype™ to Daneish
Hi,
I have looked at the previous post. and tried what the others have done but still i dont know why paraview is not found. I'm using ubuntu 14.10 where paraview works well for openfoam 2.3.1.
In the case of foam-extend 3.1 I have problems. My problem is identical to haze_1986's problem. However when followed the solution from post #8, the problem still exists.
Can anyone help me solve this problem? Can i get the paraview associate with the openfoam2.3.1 work for foam extend 3.1?
Please help,

Manu thanks,
Daneish
Attached Files
File Type: gz log.gz (5.5 KB, 2 views)
Daneish is offline   Reply With Quote

Old   June 11, 2015, 02:29
Default [SOLVED]Paraview not found for foam-extend 3.1
  #30
New Member
 
despodan
Join Date: May 2015
Location: Cottbus
Posts: 7
Rep Power: 6
Daneish is on a distinguished road
Send a message via Skype™ to Daneish
Hi,

I would like to inform you that i solved my problem. My solution was influenced by Mr Bruno's post on checking
Code:
which paraview
ls -l /usr/bin/paraview
I simply installed a system version of paraview and is now recognized when i run the the paraFoam command. To do this use:
Code:
sudo apt-get install paraview
For further information and summary
I used a Ubuntu 14.10 OS , where OpenFOAM 2.3.1 was previously installed. Now my foam-extend 3.1 works!
Daneish is offline   Reply With Quote

Old   November 22, 2017, 23:09
Default
  #31
New Member
 
Sam
Join Date: Nov 2017
Posts: 24
Rep Power: 3
anufagbemi is on a distinguished road
I had the same problem and here are 2 ways i resolved it, however not in the most elegant manner.

1. Go to your home folder where the openfoam-extend is located by
Code:
cd $WM_PROJECT_USER_DIR
then install paraview using

Code:
sudo apt-get install paraview
This should install the 5.0.1 version which i find not compatible around foam-extend solvers. One way around it for example if working with fsiFoam is to type

Code:
cd fluid
paraFoam -nativeReader
and you should be able to view your results

2. Second option is assuming your already have the OpenFOAM installed which automatically has paraview on it, you can open a New Terminal in the case folder
type in the alias command of your OpenFOAM version then type
Code:
paraFoam
that should be able to help you visualize your results.
anufagbemi is offline   Reply With Quote

Old   September 6, 2019, 03:01
Default Paraview command not found
  #32
New Member
 
Saif Ali Khan
Join Date: Aug 2019
Posts: 4
Rep Power: 2
poseidon_CFD is on a distinguished road
Hi Bruno,


I am a bit new to OpenFOAM so please bear with me if i go wrong somewhere.

I currently have OF 301 in my UBUNTU 18.04 and downloaded foam-extend-4.1 using the instructions given in a post on this website. I tried running the tutorials but when I try to run 'paraFoam' it gives me the following error:-


created temporary 'flange.OpenFOAM'
/home/vortex/foam/foam-extend-4.1/bin/paraFoam: line 145: paraview: command not found



Can you please help me out in this?
poseidon_CFD is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[snappyHexMesh] snappyHexMesh error "Cannot determine normal vector from patches." lethu OpenFOAM Meshing & Mesh Conversion 0 July 10, 2017 04:15
error with reactingFoam BakedAlmonds OpenFOAM Running, Solving & CFD 4 June 22, 2016 02:21
[mesh manipulation] Importing Multiple Meshes thomasnwalshiii OpenFOAM Meshing & Mesh Conversion 18 December 19, 2015 18:57
simpleFoam parallel AndrewMortimer OpenFOAM Running, Solving & CFD 12 August 7, 2015 18:45
fvSchemes in FOAM extend 3.1 Shenan OpenFOAM Running, Solving & CFD 3 December 22, 2014 09:45


All times are GMT -4. The time now is 12:17.