CFD Online Discussion Forums

CFD Online Discussion Forums (https://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (https://www.cfd-online.com/Forums/openfoam-installation/)
-   -   [foam-extend.org] How can I install PARAVIEW on foam-extend 3.1 ? (https://www.cfd-online.com/Forums/openfoam-installation/139300-how-can-i-install-paraview-foam-extend-3-1-a.html)

steven123 July 21, 2014 13:56

How can I install PARAVIEW on foam-extend 3.1 ?
 
How can I install PARAVIEW on foam-extend 3.1 ? Like openfoam... typing "paraFoam" to open paraview...

steven123 July 21, 2014 19:41

paraView and foam-extend-3.1 (problem)
 
1 Attachment(s)
I installed the foam-extend-3.1. But after running a tutorial case, I found this problem. I believe the ParaView was not installed. Could someone tell me how I can install it. Sorry to ask in this area of ​​posting, but nobody in the other posts know answer me this. Thanks for attention friends!

Attachment 32474

alexeym July 22, 2014 03:12

Hi,

error message suggests you to install paraview. You can do it as usual in Ubuntu, either using apt-get, or synaptic, or 'Software center'.

chriss85 July 22, 2014 03:20

Have you included the line for OpenFOAM in your .bashrc as mentioned on the installation page?

steven123 July 22, 2014 21:08

"ParaFoam" does not open on foam-extend 3.1
 
1 Attachment(s)
On my computer I have installed foam-extend-3.1. However, paraview doesn't open. This is my output message from the terminal:

Code:

a@a-Aspire-V3-571:~/foam/foam-extend-3.1/tutorials/incompressible/icoFoam/cavity$ paraFoam
created temporary 'cavity.OpenFOAM'
/home/a/foam/foam-extend-3.1/bin/paraFoam: line 142: paraview: command not found

I BELIEVE THAT PARAVIEW IS NOT INSTALLED. I think inside "ThirdParty" folder is the installation package. Then I try to do it.. Inside ThirdParty folder, running a there are AllMake's ...The "AllMake.stage4" is for Paraview:
Attachment 32495

When I type ./AllMake.stage4, I got this error:
Code:

a@a-Aspire-V3-571:~/foam/foam-extend-3.1/ThirdParty$ ./AllMake.stage4

This system rpm command: rpm --force-debian

========================================
Starting ThirdParty AllMake: Stage4
========================================

Using system installed QT

WARNING:
WARNING: Skipping the installation of ParaView-4.0.1.
WARNING: Please make sure the QT_BIN_DIR environment variable properly
WARNING: initialized in the file prefs.sh or prefs.csh
WARNING: The command $QT_BIN_DIR/qmake needs to be valid
WARNING:
========================================
Done ThirdParty AllMake: Stage4
========================================


Someone knows how can I solve it?


Best Regards,

Steven

steven123 July 22, 2014 21:40

Im a beginer, can you give me the steps? thanks :)

steven123 July 22, 2014 22:02

If I install paraView out of foam-extend this folder, ie install regardless of foam-extend as if it had not installed foam-extend on my computer work? Or should I install through the files contained in ThirdParty? If I can install by this way (and if it is easier this way), perhaps it would be better, instead of trying to solve this problem so I posted, because may be too difficult to solve.

hassan1201 July 23, 2014 02:27

Below are build instructions for Ubuntu 14.04.

These instructions assume that you install in the default location, which is
~/foam/ . Create this folder with:

cd ~
mkdir foam


* Obtain and unpack source code (if you read this, you probably already have):

The recommended way is to get the source code through git source code
management system. This way, you can get updates and bugfixes easily by running
"git pull". To install into the default location run:

cd ~/foam
git clone git://git.code.sf.net/p/openfoam-extend/foam-extend-3.1


Alternatively, you can download a snapshot (.tgz) of the source code from:
http://sourceforge.net/projects/open...am-extend-3.1/


* Update your Ubuntu installation:

sudo apt-get update
sudo apt-get upgrade

* Install required packages:

sudo apt-get install git-core build-essential binutils-dev flex \
zlib1g-dev qt4-dev-tools libqt4-dev libncurses5-dev libiberty-dev \
libxt-dev rpm mercurial graphviz openmpi-bin libopenmpi-dev cmake


* For Ubuntu 14.04, you need to customize some of the ThirdParty packages
in order to enable the usage of system-provided packages, and to enable
the compilation of other, like bison-2.7.

Here is a list of sed commands that will do just that. You can copy/paste
the following block of commands in a control terminal in order to make
the necessary adjustments. You will need to be located at the root of your
foam-extend-3.1 installation for those commands to work.

################################################## ##################
#
# Create a prefs.sh file
cp etc/prefs.sh-EXAMPLE etc/prefs.sh

# Use openmpi 1.6.5 as supplied by Ubuntu 14.04
sed -i s/"#export WM_MPLIB=SYSTEMOPENMPI"/"export WM_MPLIB=SYSTEMOPENMPI"/g etc/prefs.sh
sed -i s/"#export OPENMPI_DIR=path_to_system_installed_openmpi"/"export OPENMPI_DIR=\/usr"/g etc/prefs.sh
sed -i s/"#export OPENMPI_BIN_DIR=\$OPENMPI_DIR\/bin"/"export OPENMPI_BIN_DIR=\$OPENMPI_DIR\/bin"/g etc/prefs.sh

# Use Qt 4.8.6 as provided by Ubuntu 14.04
sed -i s/"#export QT_DIR=path_to_system_installed_qt"/"export QT_DIR=\/usr"/g etc/prefs.sh
sed -i s/"#export QT_BIN_DIR=\$QT_DIR\/bin"/"export QT_BIN_DIR=\$QT_DIR\/bin"/g etc/prefs.sh

# Use cmake 2.8.12.2 as provided by Ubuntu 14.04
sed -i s/"( rpm_make -p cmake"/"#( rpm_make -p cmake"/g ThirdParty/AllMake.stage1

# Compile and install bison-2.7 from the ThirdParty packages.
sed -i 0,/"#( rpm_make -p bison-2.7"/s//"( rpm_make -p bison-2.7"/ ThirdParty/AllMake.stage1

#
################################################## ##################


* Set environment variables:

cd ~/foam/foam-extend-3.1
. etc/bashrc

Optionally, set environment variable for compiling Cuda solvers, for example
(replace "sm_30" with value according to your GPU architecture):

export CUDA_ARCH=sm_30


* Compile:

./Allwmake.firstInstall


* Create user directory:

mkdir -p $FOAM_RUN


And you are ready to start.

chriss85 July 23, 2014 04:05

I don't use OF-extend, so I can't really help there.
Paraview comes with the vanilla OF distribution, you might be able to use that instead.

steven123 July 23, 2014 09:26

I I follow these procedures .. then after I typed ./AllMake.stage4 inside ThirdParty, this error appeared:


Code:

========================================
Starting ThirdParty AllMake: Stage4
========================================

Using system installed QT

Package name      : ParaView-4.0.1
Package URL      : http://downloads.sourceforge.net/project/openfoam-extend/foam-extend-3.1/ThirdParty/ParaView-v4.0.1-source.tgz
RPM spec file name: ParaView-4.0.1.spec
Additional flags  : --define=_qmakePath $QT_BIN_DIR/qmake
Updating the ThirdParty environment variables before building package ParaView-4.0.1
RPM file name    : /home/a/foam/foam-extend-3.1/ThirdParty/rpmBuild/RPMS/x86_64/ParaView-4.0.1-linux64GccDPOpt.x86_64.rpm
Making package ParaView-4.0.1 using RPM.
Building package ParaView-4.0.1 using SPEC file : ParaView-4.0.1.spec. Optional args: --define=_qmakePath $QT_BIN_DIR/qmake
Executing(%prep): /bin/sh -e /home/a/foam/foam-extend-3.1/ThirdParty/rpmBuild/tmp/rpm-tmp.VwvK1g
+ umask 022
+ cd /home/a/foam/foam-extend-3.1/ThirdParty/rpmBuild/BUILD
+ cd /home/a/foam/foam-extend-3.1/ThirdParty/rpmBuild/BUILD
+ rm -rf ParaView-v4.0.1-source
+ + /bin/tar/bin/gzip -xf -
 -dc /home/a/foam/foam-extend-3.1/ThirdParty/rpmBuild/SOURCES/ParaView-v4.0.1-source.tgz
+ STATUS=0
+ [ 0 -ne 0 ]
+ cd ParaView-v4.0.1-source
+ exit 0
Executing(%build): /bin/sh -e /home/a/foam/foam-extend-3.1/ThirdParty/rpmBuild/tmp/rpm-tmp.YtUIAh
+ umask 022
+ cd /home/a/foam/foam-extend-3.1/ThirdParty/rpmBuild/BUILD
+ cd ParaView-v4.0.1-source
+ [ -n gcc ]
+ export CC=gcc
+ [ -n g++ ]
+ export CXX=g++
+ [ -n -m64 -fPIC ]
+ export CFLAGS=-m64 -fPIC
+ [ -n -m64 -fPIC ]
+ export CXXFLAGS=-m64 -fPIC
+ [ -n -m64 ]
+ export LDFLAGS=-m64
+ set +x

Compilation options:
    _withVerbose    : false
    _withMesa        : false
    _withMPI        : false
    _withPython      : false
    _withQt          : true
    _qmakePath      : /usr/bin/qmake
    _mesaIncludePath : Undefined
    _mesaLibPath    : Undefined
    _pythonLibPath  : Undefined

+ addCMakeVariable VTK_USE_TK:BOOL=OFF
+ [ -n VTK_USE_TK:BOOL=OFF ]
+ CMAKE_VARIABLES= -DVTK_USE_TK:BOOL=OFF
+ shift
+ [ -n  ]
+ addCMakeVariable BUILD_SHARED_LIBS:BOOL=ON VTK_USE_RPATH:BOOL=OFF
+ [ -n BUILD_SHARED_LIBS:BOOL=ON ]
+ CMAKE_VARIABLES= -DVTK_USE_TK:BOOL=OFF -DBUILD_SHARED_LIBS:BOOL=ON
+ shift
+ [ -n VTK_USE_RPATH:BOOL=OFF ]
+ CMAKE_VARIABLES= -DVTK_USE_TK:BOOL=OFF -DBUILD_SHARED_LIBS:BOOL=ON -DVTK_USE_RPATH:BOOL=OFF
+ shift
+ [ -n  ]
+ addCMakeVariable CMAKE_BUILD_TYPE:STRING=Release
+ [ -n CMAKE_BUILD_TYPE:STRING=Release ]
+ CMAKE_VARIABLES= -DVTK_USE_TK:BOOL=OFF -DBUILD_SHARED_LIBS:BOOL=ON -DVTK_USE_RPATH:BOOL=OFF -DCMAKE_BUILD_TYPE:STRING=Release
+ shift
+ [ -n  ]
+ addCMakeVariable PARAVIEW_INSTALL_DEVELOPMENT_FILES:BOOL=ON
+ [ -n PARAVIEW_INSTALL_DEVELOPMENT_FILES:BOOL=ON ]
+ CMAKE_VARIABLES= -DVTK_USE_TK:BOOL=OFF -DBUILD_SHARED_LIBS:BOOL=ON -DVTK_USE_RPATH:BOOL=OFF -DCMAKE_BUILD_TYPE:STRING=Release -DPARAVIEW_INSTALL_DEVELOPMENT_FILES:BOOL=ON
+ shift
+ [ -n  ]
+ addCMakeVariable PARAVIEW_GENERATE_PROXY_DOCUMENTATION:BOOL=ON
+ [ -n PARAVIEW_GENERATE_PROXY_DOCUMENTATION:BOOL=ON ]
+ CMAKE_VARIABLES= -DVTK_USE_TK:BOOL=OFF -DBUILD_SHARED_LIBS:BOOL=ON -DVTK_USE_RPATH:BOOL=OFF -DCMAKE_BUILD_TYPE:STRING=Release -DPARAVIEW_INSTALL_DEVELOPMENT_FILES:BOOL=ON -DPARAVIEW_GENERATE_PROXY_DOCUMENTATION:BOOL=ON
+ shift
+ [ -n  ]
+ addCMakeVariable QT_QMAKE_EXECUTABLE:FILEPATH=/usr/bin/qmake
+ [ -n QT_QMAKE_EXECUTABLE:FILEPATH=/usr/bin/qmake ]
+ CMAKE_VARIABLES= -DVTK_USE_TK:BOOL=OFF -DBUILD_SHARED_LIBS:BOOL=ON -DVTK_USE_RPATH:BOOL=OFF -DCMAKE_BUILD_TYPE:STRING=Release -DPARAVIEW_INSTALL_DEVELOPMENT_FILES:BOOL=ON -DPARAVIEW_GENERATE_PROXY_DOCUMENTATION:BOOL=ON -DQT_QMAKE_EXECUTABLE:FILEPATH=/usr/bin/qmake
+ shift
+ [ -n  ]
+ echo CMAKE_VARIABLES:  -DVTK_USE_TK:BOOL=OFF -DBUILD_SHARED_LIBS:BOOL=ON -DVTK_USE_RPATH:BOOL=OFF -DCMAKE_BUILD_TYPE:STRING=Release -DPARAVIEW_INSTALL_DEVELOPMENT_FILES:BOOL=ON -DPARAVIEW_GENERATE_PROXY_DOCUMENTATION:BOOL=ON -DQT_QMAKE_EXECUTABLE:FILEPATH=/usr/bin/qmake
CMAKE_VARIABLES:  -DVTK_USE_TK:BOOL=OFF -DBUILD_SHARED_LIBS:BOOL=ON -DVTK_USE_RPATH:BOOL=OFF -DCMAKE_BUILD_TYPE:STRING=Release -DPARAVIEW_INSTALL_DEVELOPMENT_FILES:BOOL=ON -DPARAVIEW_GENERATE_PROXY_DOCUMENTATION:BOOL=ON -DQT_QMAKE_EXECUTABLE:FILEPATH=/usr/bin/qmake
+ mkdir -p ./buildObj
+ cd ./buildObj
+ cmake -DCMAKE_INSTALL_PREFIX:PATH=/home/a/foam/foam-extend-3.1/ThirdParty/packages/ParaView-4.0.1/platforms/linux64GccDPOpt -DVTK_USE_TK:BOOL=OFF -DBUILD_SHARED_LIBS:BOOL=ON -DVTK_USE_RPATH:BOOL=OFF -DCMAKE_BUILD_TYPE:STRING=Release -DPARAVIEW_INSTALL_DEVELOPMENT_FILES:BOOL=ON -DPARAVIEW_GENERATE_PROXY_DOCUMENTATION:BOOL=ON -DQT_QMAKE_EXECUTABLE:FILEPATH=/usr/bin/qmake ..
/home/a/foam/foam-extend-3.1/ThirdParty/rpmBuild/tmp/rpm-tmp.YtUIAh: 80: /home/a/foam/foam-extend-3.1/ThirdParty/rpmBuild/tmp/rpm-tmp.YtUIAh: cmake: not found
error: Bad exit status from /home/a/foam/foam-extend-3.1/ThirdParty/rpmBuild/tmp/rpm-tmp.YtUIAh (%build)


RPM build errors:
    Bad exit status from /home/a/foam/foam-extend-3.1/ThirdParty/rpmBuild/tmp/rpm-tmp.YtUIAh (%build)
Installing package: ParaView-4.0.1
  Uninstalling ParaView-4.0.1 using RPM: ParaView-4.0.1-linux64GccDPOpt.x86_64
  Installing ParaView-4.0.1 using RPM file: /home/a/foam/foam-extend-3.1/ThirdParty/rpmBuild/RPMS/x86_64/ParaView-4.0.1-linux64GccDPOpt.x86_64.rpm
error: open of /home/a/foam/foam-extend-3.1/ThirdParty/rpmBuild/RPMS/x86_64/ParaView-4.0.1-linux64GccDPOpt.x86_64.rpm failed: No such file or directory
Done installing package

========================================
Done ThirdParty AllMake: Stage4


steven123 July 23, 2014 10:14

Can I use paraview from openfoam-2.3 installation to see my results from cases of foam-extend? If yes .. I'll install it (openfoam 2.3), because this problem is difficult to solve ...

ayhan515 July 24, 2014 05:03

you could download and install paraview as a standalone software from below site.

http://www.paraview.org/download/

it is not short way but i use for now.
then create a dummy file named "anything.foam" in your case folder,
open paraview
File ->
Open ->
change "Files of type" to All Files (*)
select
"anything.foam" file
double click.

i hope more professional helps come.

best regards.

chriss85 July 24, 2014 09:20

You can probably also use the paraFoam version from an OpenFOAM installation by writing a short script that sources the OpenFOAM version that includes paraFoam, start paraFoam and source the OF-Extend version again.

wyldckat July 26, 2014 11:24

Greetings to all!

@steven123: The error message you showed in post #10 is letting you know that cmake is not installed:
Quote:

Originally Posted by steven123 (Post 502827)
Code:

tmp.YtUIAh: 80: /home/a/foam/foam-extend-3.1/ThirdParty/rpmBuild/tmp/rpm-tmp.YtUIAh: cmake: not found

If you look at the post #8 by Hassan, you'll see the following 3 lines of code:
Code:

sudo apt-get install git-core build-essential binutils-dev flex \
zlib1g-dev qt4-dev-tools libqt4-dev libncurses5-dev libiberty-dev \
libxt-dev rpm mercurial graphviz openmpi-bin libopenmpi-dev cmake

The backslash "\" at the end of each line indicates that the text will continue on the next line. In other words, the complete line is this:
Code:

sudo apt-get install git-core build-essential binutils-dev flex zlib1g-dev qt4-dev-tools libqt4-dev libncurses5-dev libiberty-dev libxt-dev rpm mercurial graphviz openmpi-bin libopenmpi-dev cmake
Now, if you run the above line in the terminal, does it give you any error messages?

Best regards,
Bruno

haze_1986 February 4, 2015 04:24

same problem here. following the instructions here to use system installed paraview didn't work
http://www.tfd.chalmers.se/~hani/kur...OwnLaptop.html

Problem with this uncommenting and running this line
Code:

sed -i -e 's=\.OpenFOAM=\.foam=' foam-extend-3.1/bin/paraFoam
since you are already in foam-extend-3.1 directory

And I guess there are implications when you do this, it changes the right file but it wouldn't work when running paraFoam in foam 3.1 extend
Code:

sed -i -e 's=\.OpenFOAM=\.foam=' bin/paraFoam

wyldckat February 4, 2015 14:59

Greetings haze_1986,

Sorry, I'm confused by your description :(

Does the last command line you provided fix the problem or not?
  1. If it does, then feel free to send an email to the author of that page, reporting that error. The email address is provided here: http://www.tfd.chalmers.se/~hani/kurser/OS_CFD/
  2. If it doesn't, then have you confirmed if ParaView is properly installed in your system?
    • If it is installed properly, then what is the specific problem?
Best regards,
Bruno

haze_1986 February 5, 2015 01:15

Quote:

Originally Posted by wyldckat (Post 530424)
Greetings haze_1986,

Sorry, I'm confused by your description :(

Does the last command line you provided fix the problem or not?
  1. If it does, then feel free to send an email to the author of that page, reporting that error. The email address is provided here: http://www.tfd.chalmers.se/~hani/kurser/OS_CFD/
  2. If it doesn't, then have you confirmed if ParaView is properly installed in your system?
    • If it is installed properly, then what is the specific problem?
Best regards,
Bruno

Hi Bruno, thanks for the info, but the updated line doesn't allow us to use system installed paraview as well. Based on the instructions it is a multi version install, and parafoam works for the other versions, just not in extend 3.1.

Just a detailed explanation to what I have done and the error message:
Code:

sed -i -e 's=\.OpenFOAM=\.foam=' foam-extend-3.1/bin/paraFoam
Code:

sed: can't read foam-extend-3.1/bin/paraFoam: No such file or directory
I realised I am actually already in foam-extend-3.1, so I used this line instead
Code:

sed -i -e 's=\.OpenFOAM=\.foam=' bin/paraFoam
The paraFoam file has been successfully edited, no errors here.

I followed the compilation instruction to compile foam extend 3.1, no errors in the compilation log but in the foam 3.1 extend environment I am unable to run paraFoam, it will say that paraview is not installed.

wyldckat February 5, 2015 15:29

Hi haze_1986,
Quote:

Originally Posted by haze_1986 (Post 530465)
I am unable to run paraFoam, it will say that paraview is not installed.

Mmm... OK, then how exactly have you installed ParaView?

In other words, what were the exact commands or steps you've followed to install ParaView?

And if it's installed on your system, then what do these commands give you?
Code:

which paraview
ls -l /usr/bin/paraview

Best regards,
Bruno

haze_1986 February 5, 2015 15:37

Quote:

Originally Posted by wyldckat (Post 530613)
Hi haze_1986,

Mmm... OK, then how exactly have you installed ParaView?

In other words, what were the exact commands or steps you've followed to install ParaView?

And if it's installed on your system, then what do these commands give you?
Code:

which paraview
ls -l /usr/bin/paraview

Best regards,
Bruno

Hi Bruno, I have installed paraview based on building them following the instructions while compiling 2.3.x as shown in the link.

In the f31 environment,
which paraview does not give me anything,
ls -l /usr/bin/paraview gave an error
Code:

cannot access /usr/bin/paraview: No such file or directory
In the OF23x environment,
which paraview gave
Code:

/home/haze/OpenFOAM/ThirdParty-2.3.x/platforms/linux64Gcc/ParaView-4.1.0/bin/paraview
ls -l /usr/bin/paraview gave an error
Code:

cannot access /usr/bin/paraview: No such file or directory

wyldckat February 6, 2015 08:48

Hi haze_1986,

Then all of that means that ParaView is not installed in your system. And that the ParaView version you have on OpenFOAM 2.3.x was built specifically for OpenFOAM 2.3.x, therefore it's not installed as a "system installed" ParaView version.

Which Linux Distribution are you using? Because installing the system ParaView version depends on the Linux Distribution you are using.

Best regards,
Bruno


All times are GMT -4. The time now is 22:53.