CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Installation

[OpenFOAM.org] ParaView intsllation problem

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree2Likes
  • 1 Post By pbachant
  • 1 Post By pbachant

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   June 7, 2015, 10:47
Default ParaView intsllation problem
  #1
New Member
 
Srinivasa Rao M
Join Date: Sep 2014
Location: Hyderabad
Posts: 9
Rep Power: 7
Srinivasa Rao is on a distinguished road
I have downloaded OpenFOAM OpenFOAM-2.4.0.tgz and Third-Party ThirdParty-2.4.0.tgz and installed as per the procedure given in Source pack installation on ubuntu 15.04.

I could run the openfoam but couldnt run paraFoam in the cavity problem

the error coming is something like this

FATAL ERROR: ParaView reader module libraries do not exist

Please build the reader module before continuing:
cd $FOAM_UTILITIES/postProcessing/graphics/PV4Readers
./Allwclean
./Allwmake


and i did what it said like ./Allwclean and ./Allwmake was done but the same problem repeated
Please suggest me what to do inorder to run paraFoam
Srinivasa Rao is offline   Reply With Quote

Old   June 7, 2015, 20:55
Default
  #2
Senior Member
 
Pete Bachant
Join Date: Jun 2012
Location: Boston, MA
Posts: 171
Rep Power: 9
pbachant is on a distinguished road
Can you build ParaView okay? I am getting the same error because ParaView will not build:

Code:
[ 14%] Building CXX object VTK/Rendering/OpenGL/CMakeFiles/vtkRenderingOpenGL.dir/vtkXOpenGLRenderWindow.cxx.o
In file included from /usr/include/GL/glx.h:333:0,
                 from /home/pete/OpenFOAM/ThirdParty-2.4.x/ParaView-4.1.0/VTK/Rendering/OpenGL/vtkXOpenGLRenderWindow.cxx:31:
/usr/include/GL/glxext.h:480:143: error: ‘GLintptr’ has not been declared
 typedef void ( *PFNGLXCOPYBUFFERSUBDATANVPROC) (Display *dpy, GLXContext readCtx, GLXContext writeCtx, GLenum readTarget, GLenum writeTarget, GLintptr readOffset, GLintptr writeOffset, GLsizeiptr size);
LuckyTran likes this.
__________________
Home | Twitter | GitHub
pbachant is offline   Reply With Quote

Old   June 7, 2015, 23:19
Default What is the way out
  #3
New Member
 
Srinivasa Rao M
Join Date: Sep 2014
Location: Hyderabad
Posts: 9
Rep Power: 7
Srinivasa Rao is on a distinguished road
So what can be the way out
i just need to use paraview with openfoam
Srinivasa Rao is offline   Reply With Quote

Old   June 8, 2015, 14:42
Default
  #4
New Member
 
marko
Join Date: Apr 2014
Posts: 3
Rep Power: 7
marko is on a distinguished road
The same problem I am experiencing. Any suggestions on how to solve
marko is offline   Reply With Quote

Old   June 8, 2015, 14:47
Default
  #5
Senior Member
 
Pete Bachant
Join Date: Jun 2012
Location: Boston, MA
Posts: 171
Rep Power: 9
pbachant is on a distinguished road
See here for a temporary fix: http://openfoam.org/mantisbt/view.php?id=1734
LuckyTran likes this.
__________________
Home | Twitter | GitHub
pbachant is offline   Reply With Quote

Old   June 8, 2015, 18:35
Default
  #6
New Member
 
marko
Join Date: Apr 2014
Posts: 3
Rep Power: 7
marko is on a distinguished road
Thank you very much pbachant for the useful link.

Tested it and it works like a charm
marko is offline   Reply With Quote

Old   August 25, 2015, 07:27
Default Thx
  #7
Jok
New Member
 
Johannes
Join Date: Jul 2015
Posts: 1
Rep Power: 0
Jok is on a distinguished road
Sorry for digging out this older thread.

Quote:
Originally Posted by pbachant View Post
See here for a temporary fix: http://openfoam.org/mantisbt/view.php?id=1734
Thank you very munch.
Finally I found something that works (after hours of fruitless seach!)


I'm using a virtual machine (VirtualBox 5)
host: windows 7 (64 bit)
guest: debian 8 "Jessie"

I was trying to build OpenFOAM-2.4.0 from Source.
I followed the official instructions: http://www.openfoam.org/download/source.php.

In the Third-Party-2.4.0 folder ./makeParaView4 created the same error message as mentioned above.
Jok is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
ParaView Execute problem insta OpenFOAM Installation 2 June 9, 2014 03:37
[General] Problem in using paraview meballav ParaView 11 October 12, 2012 17:03
[OpenFOAM] Installation problem with ParaView 3.8.0 on openSUSE 11.2 aero_ ParaView 14 August 2, 2010 19:13
Yet another Paraview problem gascortado OpenFOAM 5 February 21, 2010 07:39
[OpenFOAM] Problem with Colors in ParaView sven ParaView 1 May 31, 2009 09:13


All times are GMT -4. The time now is 05:16.