CFD Online Discussion Forums

CFD Online Discussion Forums (https://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (https://www.cfd-online.com/Forums/openfoam-installation/)
-   -   [OpenFOAM.com] Ubuntu 14.04: installation going bizzard (https://www.cfd-online.com/Forums/openfoam-installation/169517-ubuntu-14-04-installation-going-bizzard.html)

aerospain April 12, 2016 08:59

Ubuntu 14.04: installation going bizzard
 
I just hope that ESI is not trying to follow other companies' steps and make the OF installation harder with every new version.

I have v2.4 installed, it took some time to build and make back in the day but every little step was very clear.

With version 3.0+ they have included new (LES)kwSST models, which I prefer rather than SA-IDDES. I have tried to install this new version, without removing the previous one (just in case) ... and I'm glad of my decision.

First of all, the Docker way is rubbish. Once I exited the docker environment I couldn't find the example icoFoam cavity simulation. If the advise not to run graphics when inside Docker, anything generated in there should be easily available.

Therefore, I decided to install OF from source. The first strange thing I've noticed, the source (tar.gz) was rather smaller than older versions.
Now, my problem is I cannot install following the (very small) instructions provided in the webpage.

Could anyone, PLEASE, either share with me good instructions for installation? or, improve that URL (http://www.openfoam.com/code/build-guide.php) so we don't become dissapointed and stop using OpenFOAM?

Thanks!

wyldckat April 12, 2016 18:35

Quick question: If you roughly follow the instructions given at the following wiki page for OpenFOAM 3.0.1: https://openfoamwiki.net/index.php/I...u#Ubuntu_14.04 - doesn't it work with OpenFOAM+ 3.0+ as well? I haven't had the time needed to try this myself :(

As for improving the instructions at http://openfoam.com, it's best that you report this directly at their bug tracker: http://www.openfoam.com/code/bug-reporting.php

aerospain April 12, 2016 20:33

Thanks wyldckat,
I will test those instructions tomorrow and let you know.

Carlos

aerospain April 13, 2016 06:02

Thanks again Wyldckat!

Following the instructions at https://openfoamwiki.net/index.php/I...u#Ubuntu_14.04 and going into the first link http://www.openfoam.org/download/ubuntu.php to install OpenFOAM-3.0.1 as a new installation has worked just fine.

"Worked just fine"? Installation has gone smoothly, a couple of tutorial cases have worked ok, paraview4.4.0 has opened with paraFoam command, and I have been able to open an old case of mine with paraFoam too.

cheers!!!
C.

aerospain April 13, 2016 11:42

well, sad to say this.

But the 3.0.1 version you have helped me to install is not the one I was interested in.

You see, I want to use the new DES models implemented in 3.0+, namely, kOmegaSST DES, DDES and IDDES. And, these are not available in version 3.0.1.

What is going on? is ESI following the steps of other software companies ????

pgh April 13, 2016 12:19

Binaries for openfoam-v3.0+ is available via docker only. If you donot want to use docker then you have to compile OpenFOAM source code by yourself. You can follow simple instruction from here
http://openfoam.com/documentation/sy...quirements.php

Also in docker environment, you are supposed to copy tutorial from their default location to your home area and then run it . Then even when you excited docker environment , tutorial will be there . Parafoam work fine in docker environment .

wyldckat April 16, 2016 14:33

Greetings to all!

@Carlos: I've learned over the years with OpenFOAM that every single detail, no matter how small, is more important than we want it to be. For example, "9.81" and "98.1" is not the same, but failing to notice that the dot is in the wrong place, is the difference between Earth's standard gravity versus 10 times Earth's gravity.


Quote:

Originally Posted by aerospain (Post 594871)
But the 3.0.1 version you have helped me to install is not the one I was interested in.

Want I meant when I wrote this:
Quote:

Originally Posted by wyldckat (Post 594744)
If you roughly follow the instructions given at the following wiki page for OpenFOAM 3.0.1

was that you could follow the instructions on that wiki page, but adapt yourself to using OpenFOAM+ 3.0+, instead of using OpenfOAM 3.0.1. Because the installation instructions are very similar.

Nonetheless, I've finally managed to take a look into this and here is the wiki page that has the detailed instructions on how to install OpenFOAM+ 3.0+ from source code in Ubuntu 14.04 and they are now written here: http://openfoamwiki.net/index.php/In...M+-3.0+/Ubuntu

It's not as simple as installing via apt-get, but it's the next best thing, since you only have to follow each step... very carefully follow each step ;)


Quote:

Originally Posted by aerospain (Post 594871)
What is going on? is ESI following the steps of other software companies ????

They are sort-of doing the same as RedHat did with Fedora and RHEL: https://en.wikipedia.org/wiki/Fedora_Project - OpenFOAM+ is an evolutionary step, which will naturally have growing pains when it starts evolving. And evolution doesn't always get things right at the first attempt... which is why OpenFOAM+ can be at the forefront for testing new features that need more time to mature before they can/should go into OpenFOAM ;)

Best regards,
Bruno

aerospain April 19, 2016 14:03

Thanks Bruno,

I will follow the steps in that wiki link you sent me :p

I just hope that ESI does not step into darkness (for us) when submerged in that evolutionary quest :cool:

cheers!

aerospain April 19, 2016 14:44

well ...

following the steps exactly as they are written in that link does not work.

when i get to step 6 "For building OpenFOAM+ itself, it depends on whether you have installed the i686 or x86_64 architecture of Ubuntu."
I run the command for my x86_64 architecture, namely: "source $HOME/OpenFOAM/OpenFOAM-v3.0+/etc/bashrc" ... getting the following error messages:
-bash: /opt/OpenFOAM-v3.0+/bin/foamEtcFile: No such file or directory
-bash: /opt/OpenFOAM-v3.0+/bin/foamCleanPath: No such file or directory
-bash: /opt/OpenFOAM-v3.0+/bin/foamCleanPath: No such file or directory
-bash: /opt/OpenFOAM-v3.0+/bin/foamCleanPath: No such file or directory
-bash: /opt/OpenFOAM-v3.0+/etc/config/settings.sh: No such file or directory
-bash: /opt/OpenFOAM-v3.0+/etc/config/aliases.sh: No such file or directory
-bash: /opt/OpenFOAM-v3.0+/bin/foamEtcFile: No such file or directory
-bash: /opt/OpenFOAM-v3.0+/bin/foamEtcFile: No such file or directory
-bash: /opt/OpenFOAM-v3.0+/bin/foamEtcFile: No such file or directory
-bash: /opt/OpenFOAM-v3.0+/bin/foamEtcFile: No such file or directory
-bash: /opt/OpenFOAM-v3.0+/bin/foamCleanPath: No such file or directory
-bash: /opt/OpenFOAM-v3.0+/bin/foamCleanPath: No such file or directory
-bash: /opt/OpenFOAM-v3.0+/bin/foamCleanPath: No such file or directory

i'm inside my ~/OpenFOAM folder (at home) So, I imagine I should have OF30+ folder in /opt/. ... I run the previous command again, getting a different message this time:
-bash: /home/carlos/OpenFOAM/OpenFOAM-v3.0+/etc/bashrc: No such file or directory

I move the folder back again to where the instructions say the .tar.gz file should be extracted, and try to follow step 7: "Save an alias in the personal .bashrc file, simply by running the following command" ... no error message this time.

Next step, though, step 8: "cd $WM_THIRD_PARTY_DIR" gives a new error: "-bash: cd: /opt/ThirdParty-v3.0+: No such file or directory"

Why 'it' keeps looking into /opt/ directory when the instructions tell us to work under home?

I'll just go into the ThirdParty folder extracted from .tar.gz into ~/OpenFOAM/ the usual way: "cd ThirdParty-v3.0+" and keep following instructions.

But, a new error, actually the same as before appears in step 8 when running "wmSET $FOAM_SETTINGS" and, that is: "-bash: /opt/OpenFOAM-v3.0+/etc/bashrc: No such file or directory"

So ... conclusion ... I will try 3.0+ in a few months when they fix the installation procedure. Installation steps that ESI has inherited from OpenFOAM, they just need to build onto it ...

good luck to them ...

wyldckat April 19, 2016 18:05

Quick answer: The problem is that the other installations of OpenFOAM that you have are in conflict with OpenFOAM+, but not in the way you're thinking... the problem is common with any OpenFOAM version, when the installation folders are very different, due to the definition made in the shell variable "FOAM_INST_DIR". For more details, you can read this page: http://openfoamwiki.net/index.php/In...with_the_Shell


As for fixing the current problem, please edit the file "~/.bashrc" and change this line:
Code:

source /opt/openfoam30/etc/bashrc
To this:
Code:

alias of30="source /opt/openfoam30/etc/bashrc"
Save the file. Next time you need OpenFOAM 3.0.1, you can run this command:
Code:

of30
which will load the shell environment for OpenFOAM 3.0.1. But make sure to run in a new terminal.

Now, going back to trying to install 3.0+, start a new terminal and try the steps again starting from and including step #6.

aerospain April 20, 2016 04:12

Still getting errors in step 8

I don't think it's a matter of defining alias at this point, when no installation has been finalized yet.

The installation instructions tell me to work under /home/.../OpenFOAM/, but I get errors because files in /opt/OpenFOAM-v3.0+/ are not found.

command of30+ gives me the same type of error of files not found. This I might understand since the installation has not been done yet.

wyldckat April 20, 2016 17:23

Not so quick answer: If you want to understand a bit better what is going on wrong, run this command:
Code:

echo $FOAM_INST_DIR
It will show you this:
Code:

/opt
Then run these two commands:
Code:

wmUNSET
echo $FOAM_INST_DIR

It should now show nothing, just an empty line.


Now try running this command:
Code:

of30+
If everything works as I expect, it will not show any error messages.


Now start a new terminal and try running this command again:
Code:

echo $FOAM_INST_DIR
And "/opt" is back again.

Then run this command:
Code:

of30+
And you should get the same exact error messages you've been getting so far.


So, what happened? Because you have a lost source command in the file "~/.bashrc", you are automatically loading the shell environment for a specific OpenFOAM version, namely the one installed at "/opt".


All times are GMT -4. The time now is 11:28.