CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Installation

[OpenFOAM.org] Install openFOAM 3.0.1 in Ubuntu 16.04 LTS from Deb packs

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   May 12, 2016, 05:30
Default Install openFOAM 3.0.1 in Ubuntu 16.04 LTS from Deb packs
  #1
New Member
 
Pierluigi Olmati
Join Date: Apr 2016
Location: Tokyo
Posts: 21
Rep Power: 6
Pier84 is on a distinguished road
Hi All,

I installed Ubuntu 16.04 LTS, from Ubuntu 15, and openFOAM 3.0.1 disappeared from the opt folder.

I tied to install it again following:
http://openfoam.org/download/3-0-1-ubuntu/
but I obtained this error:

olmati@PO1:~$ sudo apt-get install openfoam30
Reading package lists... DoneBuilding dependency tree
Reading state information... Done
E: Unable to locate package openfoam30

Do you have any suggestion?

Thanks,
Pierluigi
Pier84 is offline   Reply With Quote

Old   June 1, 2016, 09:40
Default
  #2
Member
 
Join Date: Feb 2016
Posts: 36
Rep Power: 6
LeeRuns is on a distinguished road
did you try opening a new terminal window? That fixed it for me
LeeRuns is offline   Reply With Quote

Old   June 14, 2016, 10:13
Default
  #3
New Member
 
Pierluigi Olmati
Join Date: Apr 2016
Location: Tokyo
Posts: 21
Rep Power: 6
Pier84 is on a distinguished road
Hi,

Thanks for the suggestion. Anyway I installed again the Ubuntu 14 on my calcs machine.

Thanks,
PO
Pier84 is offline   Reply With Quote

Old   June 17, 2016, 13:02
Default E: Unable to locate package openfoam30
  #4
New Member
 
JImmy Rojas
Join Date: Jun 2016
Posts: 3
Rep Power: 6
jandrey is on a distinguished road
Hello all,

I am trying to install OpenFoam on Ubuntu 16.04 LTS by following the simple instructions in the website. The first command is fine, the second one gives me a few errors and the third one ($ sudo apt-get install openfoam30) says "Unable to locate package openfoam30".

Can someone please help me? Thanks a lot!

Here it is:
Code:
$ sudo add-apt-repository http://www.openfoam.org/download/ubuntu
$ sudo apt-get update

Ign:1 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:2 http://us.archive.ubuntu.com/ubuntu xenial InRelease                     
Hit:3 http://security.ubuntu.com/ubuntu xenial-security InRelease              
Hit:4 http://dl.google.com/linux/chrome/deb stable Release                     
Hit:5 http://us.archive.ubuntu.com/ubuntu xenial-updates InRelease             
Hit:6 http://us.archive.ubuntu.com/ubuntu xenial-backports InRelease           
Hit:8 https://apt.dockerproject.org/repo ubuntu-xenial InRelease               
Ign:7 http://download.openfoam.org/ubuntu xenial InRelease                     
Ign:10 http://download.openfoam.org/ubuntu xenial Release
Ign:11 http://download.openfoam.org/ubuntu xenial/main amd64 Packages
Ign:12 http://download.openfoam.org/ubuntu xenial/main i386 Packages
Ign:13 http://download.openfoam.org/ubuntu xenial/main all Packages
Ign:14 http://download.openfoam.org/ubuntu xenial/main Translation-en_US
Ign:15 http://download.openfoam.org/ubuntu xenial/main Translation-en
Ign:16 http://download.openfoam.org/ubuntu xenial/main amd64 DEP-11 Metadata
Ign:17 http://download.openfoam.org/ubuntu xenial/main DEP-11 64x64 Icons
Ign:11 http://download.openfoam.org/ubuntu xenial/main amd64 Packages
Ign:12 http://download.openfoam.org/ubuntu xenial/main i386 Packages
Ign:13 http://download.openfoam.org/ubuntu xenial/main all Packages
Ign:14 http://download.openfoam.org/ubuntu xenial/main Translation-en_US
Ign:15 http://download.openfoam.org/ubuntu xenial/main Translation-en
Ign:16 http://download.openfoam.org/ubuntu xenial/main amd64 DEP-11 Metadata
Ign:17 http://download.openfoam.org/ubuntu xenial/main DEP-11 64x64 Icons
Ign:11 http://download.openfoam.org/ubuntu xenial/main amd64 Packages
Ign:12 http://download.openfoam.org/ubuntu xenial/main i386 Packages
Ign:13 http://download.openfoam.org/ubuntu xenial/main all Packages
Ign:14 http://download.openfoam.org/ubuntu xenial/main Translation-en_US
Ign:15 http://download.openfoam.org/ubuntu xenial/main Translation-en
Ign:16 http://download.openfoam.org/ubuntu xenial/main amd64 DEP-11 Metadata
Ign:17 http://download.openfoam.org/ubuntu xenial/main DEP-11 64x64 Icons
Ign:11 http://download.openfoam.org/ubuntu xenial/main amd64 Packages
Ign:12 http://download.openfoam.org/ubuntu xenial/main i386 Packages
Ign:13 http://download.openfoam.org/ubuntu xenial/main all Packages
Ign:14 http://download.openfoam.org/ubuntu xenial/main Translation-en_US
Ign:15 http://download.openfoam.org/ubuntu xenial/main Translation-en
Ign:16 http://download.openfoam.org/ubuntu xenial/main amd64 DEP-11 Metadata
Ign:17 http://download.openfoam.org/ubuntu xenial/main DEP-11 64x64 Icons
Ign:11 http://download.openfoam.org/ubuntu xenial/main amd64 Packages
Ign:12 http://download.openfoam.org/ubuntu xenial/main i386 Packages
Ign:13 http://download.openfoam.org/ubuntu xenial/main all Packages
Ign:14 http://download.openfoam.org/ubuntu xenial/main Translation-en_US
Ign:15 http://download.openfoam.org/ubuntu xenial/main Translation-en
Ign:16 http://download.openfoam.org/ubuntu xenial/main amd64 DEP-11 Metadata
Ign:17 http://download.openfoam.org/ubuntu xenial/main DEP-11 64x64 Icons
Err:11 http://download.openfoam.org/ubuntu xenial/main amd64 Packages
  404  Not Found
Err:12 http://download.openfoam.org/ubuntu xenial/main i386 Packages
  404  Not Found
Ign:13 http://download.openfoam.org/ubuntu xenial/main all Packages
Ign:14 http://download.openfoam.org/ubuntu xenial/main Translation-en_US
Ign:15 http://download.openfoam.org/ubuntu xenial/main Translation-en
Ign:16 http://download.openfoam.org/ubuntu xenial/main amd64 DEP-11 Metadata
Ign:17 http://download.openfoam.org/ubuntu xenial/main DEP-11 64x64 Icons
Reading package lists... Done
W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:54 and /etc/apt/sources.list.d/openfoam.list:1
W: Target Packages (main/binary-i386/Packages) is configured multiple times in /etc/apt/sources.list:54 and /etc/apt/sources.list.d/openfoam.list:1
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:54 and /etc/apt/sources.list.d/openfoam.list:1
W: Target Translations (main/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list:54 and /etc/apt/sources.list.d/openfoam.list:1
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:54 and /etc/apt/sources.list.d/openfoam.list:1
W: Target DEP-11 (main/dep11/Components-amd64.yml) is configured multiple times in /etc/apt/sources.list:54 and /etc/apt/sources.list.d/openfoam.list:1
W: Target DEP-11-icons (main/dep11/icons-64x64.tar) is configured multiple times in /etc/apt/sources.list:54 and /etc/apt/sources.list.d/openfoam.list:1
W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list.d/google-chrome.list:3 and /etc/apt/sources.list.d/google.list:1
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list.d/google-chrome.list:3 and /etc/apt/sources.list.d/google.list:1
W: Target Translations (main/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list.d/google-chrome.list:3 and /etc/apt/sources.list.d/google.list:1
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list.d/google-chrome.list:3 and /etc/apt/sources.list.d/google.list:1
W: Target DEP-11 (main/dep11/Components-amd64.yml) is configured multiple times in /etc/apt/sources.list.d/google-chrome.list:3 and /etc/apt/sources.list.d/google.list:1
W: Target DEP-11-icons (main/dep11/icons-64x64.tar) is configured multiple times in /etc/apt/sources.list.d/google-chrome.list:3 and /etc/apt/sources.list.d/google.list:1
W: The repository 'http://www.openfoam.org/download/ubuntu xenial Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch http://download.openfoam.org/ubuntu/...amd64/Packages  404  Not Found
E: Failed to fetch http://download.openfoam.org/ubuntu/...-i386/Packages  404  Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.
W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:54 and /etc/apt/sources.list.d/openfoam.list:1
W: Target Packages (main/binary-i386/Packages) is configured multiple times in /etc/apt/sources.list:54 and /etc/apt/sources.list.d/openfoam.list:1
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:54 and /etc/apt/sources.list.d/openfoam.list:1
W: Target Translations (main/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list:54 and /etc/apt/sources.list.d/openfoam.list:1
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:54 and /etc/apt/sources.list.d/openfoam.list:1
W: Target DEP-11 (main/dep11/Components-amd64.yml) is configured multiple times in /etc/apt/sources.list:54 and /etc/apt/sources.list.d/openfoam.list:1
W: Target DEP-11-icons (main/dep11/icons-64x64.tar) is configured multiple times in /etc/apt/sources.list:54 and /etc/apt/sources.list.d/openfoam.list:1
W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list.d/google-chrome.list:3 and /etc/apt/sources.list.d/google.list:1
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list.d/google-chrome.list:3 and /etc/apt/sources.list.d/google.list:1
W: Target Translations (main/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list.d/google-chrome.list:3 and /etc/apt/sources.list.d/google.list:1
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list.d/google-chrome.list:3 and /etc/apt/sources.list.d/google.list:1
W: Target DEP-11 (main/dep11/Components-amd64.yml) is configured multiple times in /etc/apt/sources.list.d/google-chrome.list:3 and /etc/apt/sources.list.d/google.list:1
W: Target DEP-11-icons (main/dep11/icons-64x64.tar) is configured multiple times in /etc/apt/sources.list.d/google-chrome.list:3 and /etc/apt/sources.list.d/google.list:1

$ sudo apt-get install openfoam30

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package openfoam30

Last edited by wyldckat; June 18, 2016 at 17:23. Reason: Added [CODE][/CODE] markers
jandrey is offline   Reply With Quote

Old   June 18, 2016, 17:22
Default
  #5
Retired Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 10,957
Blog Entries: 45
Rep Power: 122
wyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to all
Quick answer: Quoting from the online page:
Quote:
Ubuntu Versions

OpenFOAM and Paraview are currently available for the following versions of Ubuntu:
  • 14.04 LTS, codename trusty
  • 15.10, codename wily
This means that the Deb packages for Ubuntu 16.04 are not yet available.

If you have the patience to build from source code, you can find detailed steps here: https://openfoamwiki.net/index.php/I...u#Ubuntu_16.04
wyldckat is offline   Reply With Quote

Reply

Tags
openfoam 3.0.1, ubuntu 16.04 lts

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[OpenFOAM.org] openFoam 2.3.x install on Ubuntu 16.04 in windows 10 AndyBloke OpenFOAM Installation 5 April 8, 2018 18:57
[OpenFOAM.com] Installation of OpenFOAM 1.7.1 on Ubuntu 16.04 MM_Khan OpenFOAM Installation 11 September 3, 2017 10:22
[OpenFOAM.com] OpenFOAM v1.7.1 on Ubuntu 14.04 LTS reza_65 OpenFOAM Installation 3 August 28, 2017 15:29
OpenFOAM v3.0+ ?? SBusch OpenFOAM 22 December 26, 2016 15:24
How to Install OpenFOAM on 64 Ubuntu 9.04 hansel OpenFOAM Installation 62 March 19, 2010 15:43


All times are GMT -4. The time now is 05:20.