CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

Unable to add openfoam 4 source repo location on Linux Mint 18

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree2Likes
  • 1 Post By aran
  • 1 Post By wyldckat

Reply
 
LinkBack Thread Tools Display Modes
Old   July 4, 2016, 23:24
Smile FIXED: Unable to add openfoam 4 source repo location on Linux Mint 18
  #1
New Member
 
Ash
Join Date: Jul 2016
Posts: 2
Rep Power: 0
aran is on a distinguished road
FIXED: I changed
Code:
sudo add-apt-repository http://download.openfoam.org/ubuntu
to

Code:
sudo add-apt-repository deb http://download.openfoam.org/ubuntu xenial main
Hi!
I am using linux mint 18 and I am trying to add the openfoam source repo to my sources repository list but I am unable to do so! I have tried adding it via the cli and the software manager interface and nothing has happened.

and when I add the http://download.openfoam.org/ubuntu manually to sources.list, apt refuses to update claiming a malformed line error.

Code:
sudo apt-get update
E: Malformed line 2 in source list /etc/apt/sources.list (type)
E: The list of sources could not be read.
P.S: I did enable universe repositories
Edison_Ge likes this.

Last edited by aran; July 5, 2016 at 18:02. Reason: Added extra details. FIXED
aran is offline   Reply With Quote

Old   September 9, 2016, 09:37
Default
  #2
Member
 
edison
Join Date: May 2009
Location: Australia
Posts: 35
Rep Power: 10
Edison_Ge is on a distinguished road
How did you managed to get the repositories? I have linux mint as well but can't install OpenFOAM 4.0. Did you manged installing it using the ubuntu repo?
Edison_Ge is offline   Reply With Quote

Old   September 9, 2016, 09:45
Default
  #3
New Member
 
Ash
Join Date: Jul 2016
Posts: 2
Rep Power: 0
aran is on a distinguished road
Hey Edison,

I was using linux mint 18 and I couldn't get it to work with whatever instructions were given on the CFD.Direct site. So I installed openfoam 4 on ubuntu xenial and checked the sources list. I then used that entry in the ubuntu sources list for the linux mint sources list.

This is the command I ran in Linux mint 18:-
Code:
 sudo add-apt-repository deb http://download.openfoam.org/ubuntu xenial main
After this follow the openfoam install instructions from CFD.Direct. The only problem is that everytime I update linux mint it gives me a key error for the repository, but I just ignore that.
aran is offline   Reply With Quote

Old   September 9, 2016, 17:43
Default
  #4
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 10,020
Blog Entries: 39
Rep Power: 109
wyldckat is a glorious beacon of lightwyldckat is a glorious beacon of lightwyldckat is a glorious beacon of lightwyldckat is a glorious beacon of lightwyldckat is a glorious beacon of lightwyldckat is a glorious beacon of light
Quick note: Regarding the key error, the fix for it is in the official installation instructions: http://openfoam.org/download/4-0-ubuntu/ - and I quote:
Quote:
1. [...]and to add the public key (gpg.key) for the repository to enable package signatures to be verified.
Code:
#...
sudo sh -c "wget -O - http://dl.openfoam.org/gpg.key | apt-key add -"
The last line is the one that will add the key.
aran likes this.
__________________
wyldckat is offline   Reply With Quote

Old   September 12, 2016, 04:42
Default
  #5
Member
 
edison
Join Date: May 2009
Location: Australia
Posts: 35
Rep Power: 10
Edison_Ge is on a distinguished road
Quote:
Originally Posted by aran View Post
Hey Edison,

I was using linux mint 18 and I couldn't get it to work with whatever instructions were given on the CFD.Direct site. So I installed openfoam 4 on ubuntu xenial and checked the sources list. I then used that entry in the ubuntu sources list for the linux mint sources list.

This is the command I ran in Linux mint 18:-
Code:
 sudo add-apt-repository deb http://download.openfoam.org/ubuntu xenial main
After this follow the openfoam install instructions from CFD.Direct. The only problem is that everytime I update linux mint it gives me a key error for the repository, but I just ignore that.
Thax aran, I will try it.
Edison_Ge is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error creating ParaView-4.1.0 OpenFOAM 2.3.0 tlcoons OpenFOAM Installation 13 April 20, 2016 17:34
Suggestion for a new sub-forum at OpenFOAM's Forum wyldckat Site Help, Feedback & Discussions 20 October 28, 2014 10:04
SparceImage v1.7.x Issue on MAC OS X rcarmi OpenFOAM Installation on Windows, Mac and other Unsupported Platforms 4 August 14, 2014 06:42
Error bulding swak4Foam sfigato OpenFOAM Installation 18 August 22, 2013 12:41
DxFoam reader update hjasak OpenFOAM Post-Processing 69 April 24, 2008 01:24


All times are GMT -4. The time now is 19:00.