CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Installation

[OpenFOAM.com] v1606+ Compilation error - ptscotch.h not found

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree4Likes
  • 1 Post By TmsO

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   July 7, 2016, 16:14
Default v1606+ Compilation error - ptscotch.h not found
  #1
New Member
 
Tommaso
Join Date: Jul 2016
Posts: 3
Rep Power: 8
TmsO is on a distinguished road
Hi everyone,

I wonder if anyone could help me....I've just downloaded the new OF version 1606 and I'm trying to compile it. Unluckily I got the following error:

Code:
/home/tommaso/App/OpenFOAM/OpenFOAM-v1606+/src/parallel/decompose/ptscotchDecomp
wmake libso ptscotchDecomp
/home/tommaso/App/OpenFOAM/OpenFOAM-v1606+/src/parallel/decompose/ptscotchDecomp
wmakeLnInclude: linking include files to ./lnInclude
Making dependency list for source file ptscotchDecomp.C
could not open file ptscotch.h for source file ptscotchDecomp.C due to No such file or directory
g++ -std=c++0x -m64 -Dlinux64 -DWM_ARCH_OPTION=64 -DWM_DP -DWM_LABEL_SIZE=32 -Wall -Wextra -Wold-style-cast -Wnon-virtual-dtor -Wno-unused-parameter -Wno-invalid-offsetof -O3  -DNoRepository -ftemplate-depth-100 -DOMPI_SKIP_MPICXX -I/usr/lib/openmpi/include/openmpi/opal/mca/event/libevent2021/libevent -I/usr/lib/openmpi/include/openmpi/opal/mca/event/libevent2021/libevent/include -I/usr/lib/openmpi/include -I/usr/lib/openmpi/include/openmpi -pthread -I/include -I/home/tommaso/App/OpenFOAM/ThirdParty-v1606+/platforms/linux64GccInt32/scotch_6.0.3/include/openmpi-system -I/usr/include/scotch -I../decompositionMethods/lnInclude -IlnInclude -I. -I/home/tommaso/App/OpenFOAM/OpenFOAM-v1606+/src/OpenFOAM/lnInclude -I/home/tommaso/App/OpenFOAM/OpenFOAM-v1606+/src/OSspecific/POSIX/lnInclude   -fPIC -c ptscotchDecomp.C -o /home/tommaso/App/OpenFOAM/OpenFOAM-v1606+/platforms/linux64GccDPInt32OptSYSTEMOPENMPI/src/parallel/decompose/ptscotchDecomp/ptscotchDecomp.o
ptscotchDecomp.C:214:26: fatal error: ptscotch.h: No such file or directory
compilation terminated.
/home/tommaso/App/OpenFOAM/OpenFOAM-v1606+/wmake/rules/General/transform:8: recipe for target '/home/tommaso/App/OpenFOAM/OpenFOAM-v1606+/platforms/linux64GccDPInt32OptSYSTEMOPENMPI/src/parallel/decompose/ptscotchDecomp/ptscotchDecomp.o' failed
make: *** [/home/tommaso/App/OpenFOAM/OpenFOAM-v1606+/platforms/linux64GccDPInt32OptSYSTEMOPENMPI/src/parallel/decompose/ptscotchDecomp/ptscotchDecomp.o] Error 1
It looks like that the compiler cannot find ptscotch.h for some reason.
My libraries/compilers etc are all up to date.

I'm not much of an expert on this sort of things, so I hope to get some help.

Cheers,
Tommaso
sourav90 likes this.

Last edited by wyldckat; September 9, 2016 at 18:52. Reason: Added [CODE][/CODE] markers
TmsO is offline   Reply With Quote

Old   August 18, 2016, 12:35
Default changing Compiler
  #2
New Member
 
Stefan
Join Date: Oct 2015
Posts: 24
Rep Power: 9
StefanW is on a distinguished road
Hey Tommaso,

just got the same problem doing the installation on a cluster of the university.

Just got the advise to check whether the "bashrc" file contains the right "standard-Compiler- and MPI-version" which is supposed from the admins.

So i changed the compiler to the "Icc" one by changing the code of the bashrc
"""
#- Compiler:
# WM_COMPILER = Gcc | Gcc45 | Gcc46 | Gcc47 | Gcc48 | Gcc49| Clang | Icc
#######export WM_COMPILER=Gcc
export WM_COMPILER=Icc
"""

and the MPI-Version to "SYSTEMOPENMPI"
"""
export WM_MPLIB=SYSTEMOPENMPI
"""

The installation is running now since 3 hours and didn't crash like the last times. Fingers crossed it runs through all the steps...

I hope that may help you.

Regards

Stefan
StefanW is offline   Reply With Quote

Old   August 19, 2016, 05:03
Default Installation fail
  #3
New Member
 
Stefan
Join Date: Oct 2015
Posts: 24
Rep Power: 9
StefanW is on a distinguished road
Hello,

the installation failed also, again at the ptscotch.h file.

I will talk to the admins and let you know.

Regards Stefan
StefanW is offline   Reply With Quote

Old   September 7, 2016, 11:13
Default Solved!
  #4
New Member
 
Tommaso
Join Date: Jul 2016
Posts: 3
Rep Power: 8
TmsO is on a distinguished road
Hello Stephan,

thanks for you reply and sorry for the delay. I had to put the project in the backburner for a while and I resumed it not long ago.

Finally I managed to get everything working just by installing ptscotch with:

sudo apt-get install ptscotch

eveything compiled and now it's working!

Thanks again!
TmsO is offline   Reply With Quote

Old   September 9, 2016, 18:50
Default
  #5
Retired Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 10,969
Blog Entries: 45
Rep Power: 126
wyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to all
Quick answer: Sorry for the delay in responding to this, but it was only fairly recently that I managed to document the detailed installation steps for installing OpenFOAM+ v1606+ on a few systems: https://openfoamwiki.net/index.php/I...AM%2B-v1606%2B

Nonetheless, there is no clear indication in the details you've all provided, in order to diagnose why "ptscotch" is not getting built properly.
For those who are still having problems with this, please run the following commands:
Code:
cd $WM_THIRD_PARTY_DIR
./Allwmake > log.make 2>&1

gzip < log.make > log.make.gz
Then please attach the file "log.make.gz" to your next post, which will provide the complete output of the attempt at building Scotch and PTScotch.


edit: I forgot to mention that if you downloaded the package "ThirdParty-v1606+.tgz" soon after the release of v1606+, it was updated again a few days later to fix one or two issues with the build scripts. That might have been the origin of the very first reported issue here.
__________________

Last edited by wyldckat; September 9, 2016 at 18:51. Reason: see "edit:"
wyldckat is offline   Reply With Quote

Old   October 5, 2017, 04:11
Default Problems with ptscotch and OpenFoam
  #6
New Member
 
Rosemarie Meuer
Join Date: Oct 2017
Posts: 1
Rep Power: 0
rmeuer is on a distinguished road
I am having the same problem with OpenFoam16.12. I have attached the error messages from ptscotch.
Attached Files
File Type: gz log.make.gz (5.4 KB, 23 views)
rmeuer is offline   Reply With Quote

Old   October 24, 2022, 12:28
Default
  #7
New Member
 
Victor Eijkhout
Join Date: Oct 2022
Posts: 1
Rep Power: 0
VictorEijkhout is on a distinguished road
Scotch & Ptscotch...


I installed scotch/ptscotch myself and then added include & lib directories to the compiler. That worked for me. In my case that meant editing



Code:
wmake/rules/linux64Gcc/c++
VictorEijkhout is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Building OpenFOAM1.7.0 from source ata OpenFOAM Installation 46 March 6, 2022 14:21
problem during mpi in server: expected Scalar, found on line 0 the word 'nan' muth OpenFOAM Running, Solving & CFD 3 August 27, 2018 05:18
dsmcInitialise - dsmcFoam archymedes OpenFOAM Pre-Processing 94 July 15, 2016 17:14
OpenFOAM 1.7.1 installation problem on OpenSUSE 11.3 flakid OpenFOAM Installation 16 December 28, 2010 09:48
Compilation Error.... Arnab Siemens 4 September 12, 2004 16:54


All times are GMT -4. The time now is 07:27.