CFD Online Discussion Forums

CFD Online Discussion Forums (https://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (https://www.cfd-online.com/Forums/openfoam-installation/)
-   -   [OpenFOAM.org] 4.0: Paraview 5.0 wont run after reinstall (https://www.cfd-online.com/Forums/openfoam-installation/177658-4-0-paraview-5-0-wont-run-after-reinstall.html)

pupo September 18, 2016 11:30

4.0: Paraview 5.0 wont run after reinstall
 
Helo everyone!

I can't get paraview to run after a reinstall. The error i get is :

Code:

FATAL ERROR: ParaView reader module libraries do not exist

Please build the reader module before continuing:
cd $FOAM_UTILITIES/postProcessing/graphics/PVReaders
./Allwclean
./Allwmake

and if i follow those instructions i get a

Code:

./Allwmake : PV_PLUGIN_PATH not valid - it is unset

I'm a bit lost since I've tried purging openFoam and reinstalled as a fresh install several times in several fashions and everything is working fine except for paraview. A few threads already discussed this issue, but must of them cover older versions of OpenFOAM and most of the suggested commands don't seem to work anymore.

Any help would be appreciated!

Cheers,
Pedro

pupo September 18, 2016 12:20

uhhh... apparentely you need to close and open a new terminal before paraFoam works. I can't believe i spent the last three hours panicking over this without ever closing my terminal once.

I apologize for the stupidity :(

wyldckat September 18, 2016 16:53

Greetings Pedro,

Don't worry, it can happen to anyone.
Can you please indicate which installation instructions you've followed? I ask this so that this kind of situation doesn't happen again.

Best regards,
Bruno

pupo September 19, 2016 06:48

sure!

i tried following this:

Code:

cd ~/OpenFOAM
rm -rf OpenFOAM-1.4
rm -rf linux
cd
rm -rf ~/.OpemFOAM-1.4


from this thread. the first command seems to be outdated, so i just navigated to /opt/ folder and removed (rm -rf) both the paraview and parafoam folders.

Alternatively, i just ran:

Code:

sudo apt-get purge openFoam*
sudo apt-get purge paraview*

which completely obliterated openfoam and paraview from my computer. finally, I installed the software again with:

Code:

sudo apt-get -y install openfoam4
If you close your console and open it again, everything should be working as normal.


All times are GMT -4. The time now is 16:03.