CFD Online Discussion Forums

CFD Online Discussion Forums (https://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (https://www.cfd-online.com/Forums/openfoam-installation/)
-   -   [OpenFOAM.com] v1606+ Problems of installation on iMac (https://www.cfd-online.com/Forums/openfoam-installation/179041-v1606-problems-installation-imac.html)

Intercooled October 21, 2016 17:54

v1606+ Problems of installation on iMac
 
Hi all,

I tried to install the new openFoam v1606 on my iMac.
The instruction appear so simple that I really don't think so many
problems I met.

First I installed Docker and Docker toolbox, without particular problem.
After that I launched installMacOpenFOAM+, but I found problem of time out
of connection....
I start to search documentation about this error, and the useful suggestion is
add to the DNS system the address 8.8.8.8, which solved the problem.
Now the image are now installed, happy to this I have continue following
the instruction "chmod +x startMacOpenFOAM+", ok and finally
"./startMacOpenFOAM+ " and now other error:

"Error response from daemon: Mounts denied:
The path /etc/sudoers.d
is not shared from OS X and is not known to Docker.
You can configure shared paths from Docker -> Preferences... -> File Sharing.
See https://docs.docker.com/docker-for-m...fs/#namespaces for more info.
.
Error: failed to start containers: of_v1606_plus
You cannot attach to a stopped container, start it first"

I have tried to solve this error but till now I have not found any solution.

Do anyone have same problem?

Any help is very appreciate.

pgh October 25, 2016 10:33

Hi

i) Make sure you have installed docker toolbox only .(Note the other docker run natively on machine but is in beta phase and script does not support it )
ii) if you have installed docker tool box , click on docker terminal toolbox and type command
"docker images " and "docker ps -a" . Let me know what 's the output

Also i assume , you have run following command for installation
docker-machine ssh default $HOME/installMacOpenFOAM+ $HOME

Intercooled October 27, 2016 12:56

Error with Docker
 
Hi Pawan,

I have installed also Docker due to an error.
Anyway I remove Docker, re-install the Docker Toolbox only,
an the error that appear into the Docker Quickstart Terminal is:

Cannot connect to the Docker daemon. Is the docker daemon running on this host?

Any command I try to insert generate these message error.

Do you have some other suggestion about?

Thanks

Intercooled October 28, 2016 06:10

Solved
 
Hi all,

I have solved the problem caused by the firewall which blocks some connections.

Thanks for help

igor November 15, 2016 20:22

Quote:

Originally Posted by Intercooled (Post 623301)
Hi all,

I have solved the problem caused by the firewall which blocks some connections.

Thanks for help

Hi Intercooled,

Would you mind to share how exactly you have solved this issue?

I am facing the same problem.

Thanks!


All times are GMT -4. The time now is 10:25.