CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Installation

[foam-extend.org] paraFoam not working in Foam-extended 3.2

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   December 19, 2016, 16:22
Default paraFoam not working in Foam-extended 3.2
  #1
New Member
 
Join Date: Dec 2016
Posts: 5
Rep Power: 4
Osman is on a distinguished road
Hello,

I am a newbie in the forum. I have installed foam-extended-3.2 in Ubuntu 16.04 version. Everything is going fine. I have done meshing and also run the simulation perfectly (I was doing cavity tutorial of incompressible icoFoam cases). Then, while I was writing 'paraFoam &' command in the terminal, paraview is opening but, shutting down instantly, showing the following message in the terminal:

Quote:
created temporary 'cavity.OpenFOAM'
Read float past end of buffer
Read float past end of buffer
Read float past end of buffer
Read float past end of buffer
ERROR: In /build/paraview-arsa8T/paraview-5.0.1+dfsg1/ParaViewCore/ServerImplementation/Core/vtkSIProxy.cxx, line 310
vtkSISourceProxy (0x4937e30): Failed to create vtkXdmfReader. Aborting for debugging purposes
Can someone say, what's the problem? I followed this link (https://openfoamwiki.net/index.php/I...oam-extend-3.2) for installation. Thanks.
Osman is offline   Reply With Quote

Old   December 27, 2016, 12:44
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 10,943
Blog Entries: 42
Rep Power: 121
wyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to all
Quick questions:
  1. What does the following command give you?
    Code:
    which paraview
  2. Did you install ParaView manually or was it built by the script "Allwmake.firstInstall"?
  3. What is the content of the file "etc/prefs.sh"? You can check by running:
    Code:
    foam
    cat etc/prefs.sh
__________________
wyldckat is offline   Reply With Quote

Old   January 3, 2017, 19:11
Default
  #3
New Member
 
Join Date: Dec 2016
Posts: 5
Rep Power: 4
Osman is on a distinguished road
Hello,

First I want to apologize for my late response as I was out for holiday.

1.
Quote:
/usr/bin/paraview
2. I am not sure about it. But, before installing foam-extend-3.2, I installed Openfoam 4.0. ParaFoam is perfectly working for OF 4.0.

3.
Quote:
export WM_THIRD_PARTY_USE_BISON_27=1
export QT_BIN_DIR=/usr/bin/qmake
export QT_BIN_DIR=/usr/bin/qmake-qt4
Osman is offline   Reply With Quote

Old   May 25, 2017, 21:39
Default
  #4
New Member
 
Metikurke
Join Date: May 2017
Posts: 21
Rep Power: 4
Metikurke is on a distinguished road
Hello,

I am also facing the same problem while using the foam extend 4.0. I have tried everything possible, I have also checked my installation comletely, and tried finding solutions in the forum. But no where it has been discussed. The error report as follows,

/Work/tutorials/incompressible/icoFoam/cavity$ ERROR: In /build/paraview-arsa8T/paraview-5.0.1+dfsg1/ParaViewCore/ServerImplementation/Core/vtkSIProxy.cxx, line 310
vtkSISourceProxy (0x4304c10): Failed to create vtkXdmfReader. Aborting for debugging purposes.

[1]+ Aborted (core dumped) paraview


It would be really great if you can give me the solution.

Thank you
Metikurke is offline   Reply With Quote

Old   May 26, 2017, 06:07
Default
  #5
New Member
 
Metikurke
Join Date: May 2017
Posts: 21
Rep Power: 4
Metikurke is on a distinguished road
With Regard to above problem tried running, paraview a.foam now its working properly.
Metikurke is offline   Reply With Quote

Old   November 30, 2017, 12:55
Default
  #6
Member
 
James Gross
Join Date: Nov 2017
Posts: 64
Rep Power: 4
jgross is on a distinguished road
Osman, I am having the same issue. I had installed Paraview with OpenFOAM 5 previously before installation of Foam Extend 4.0. When I type the above commands, I receive the same message as you.

Quote:
/usr/bin/paraview
and

Quote:
export WM_THIRD_PARTY_USE_BISON_27=1
export WM_THIRD_PARTY_USE_BISON_27=1
export QT_BIN_DIR=/path/to/qmake_directory
export CUDA_ARCH=sm_30
Did you ever manage to get ParaFOAM working with Foam Extend 4.0?

Thank you.
jgross is offline   Reply With Quote

Old   December 5, 2017, 07:39
Default
  #7
Member
 
James Gross
Join Date: Nov 2017
Posts: 64
Rep Power: 4
jgross is on a distinguished road
I managed to fix it so that paraFoam command works with extend-4.0. I achieved this by modifying the PARAVIEW_DIR in the foam folder such that it calls the Paraview that was installed during extend-4.0 installation, rather than the newer version of Paraview from the previous OpenFOAM 5.0 installation.

Some of the details of this procedure were found online, but I can't seem to find a link for it right now. I hope this helps people that may have this issue in the future.

James
jgross is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[CGNS] CGNS converters available mbeaudoin OpenFOAM Meshing & Mesh Conversion 137 December 14, 2018 05:20
InterDyMFoam+simpleFunctionObject Elham OpenFOAM Running, Solving & CFD 5 July 10, 2017 12:59
Incompatible dimensions for operation ruben23 OpenFOAM Running, Solving & CFD 2 June 12, 2015 05:14
Derivative of velocity and mean velocity hiuluom OpenFOAM Post-Processing 1 May 30, 2015 00:42
centOS 5.6 : paraFoam not working yossi OpenFOAM Installation 2 October 9, 2013 02:41


All times are GMT -4. The time now is 06:11.