CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Installation

[OpenFOAM.com] Problems building OF-1.7.x version, Ubuntu 16.04, Gcc-5.4.0

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   February 16, 2017, 11:45
Default Problems building OF-1.7.x version, Ubuntu 16.04, Gcc-5.4.0
  #1
New Member
 
Sandip Wadekar
Join Date: Oct 2014
Posts: 17
Rep Power: 9
wadekar is on a distinguished road
Hello foamers

I am using OF-1.7.x version, Ubuntu 16.04, Gcc-5.4.0.
I am compiling XiFoam, but i am not getting the error
I think, this error is from the thermoPhysicalModels/reactionThermo, but this library is compling fine .
can someone help with this problem ?
PHP Code:
Make/linux64GccDPOpt/XiFoam.oIn function `main':
XiFoam.C:(.text.startup+0x718): undefined reference to 
`Foam::hhuCombustionThermo::New(Foam::fvMesh const&)'
collect2: error: ld returned 1 exit status
/home/wadekar/OpenFOAM/OpenFOAM-1.7.x/wmake/Makefile:150: recipe for target '
/home/wadekar/OpenFOAM/OpenFOAM-1.7.x/applications/bin/linux64GccDPOpt/XiFoam' failed
make: *** [/home/wadekar/OpenFOAM/OpenFOAM-1.7.x/applications/bin/linux64GccDPOpt/XiFoam] Error 1 
wadekar is offline   Reply With Quote

Old   February 20, 2017, 17:39
Default
  #2
Retired Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 10,965
Blog Entries: 45
Rep Power: 126
wyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to all
Quick answer: GCC 5.4.0 is not a supported version to be used for building OpenFOAM 1.7.x. The last known GCC series known to work is GCC 4.5, as reported here: https://openfoamwiki.net/index.php/I...ibility_Matrix

For building OpenFOAM 1.7.1 on Ubuntu 16.04, see the following instructions as a reference of the steps you need to do with 1.7.x: https://openfoamwiki.net/index.php/I...u#Ubuntu_16.04
__________________
wyldckat is offline   Reply With Quote

Old   February 22, 2017, 11:11
Default
  #3
New Member
 
Sandip Wadekar
Join Date: Oct 2014
Posts: 17
Rep Power: 9
wadekar is on a distinguished road
Quote:
Originally Posted by wyldckat View Post
Quick answer: GCC 5.4.0 is not a supported version to be used for building OpenFOAM 1.7.x. The last known GCC series known to work is GCC 4.5, as reported here: https://openfoamwiki.net/index.php/I...ibility_Matrix

For building OpenFOAM 1.7.1 on Ubuntu 16.04, see the following instructions as a reference of the steps you need to do with 1.7.x: https://openfoamwiki.net/index.php/I...u#Ubuntu_16.04
Thank you sir

It works fine
wadekar is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[ICEM] Problems with coedge curves and surfaces tommymoose ANSYS Meshing & Geometry 6 December 1, 2020 11:12
Problems with Industrial Building Ventilation jjperez FLUENT 0 February 8, 2012 10:46
OpenFOAM 1.6.x, 1.7.0 and 1.7.x are not fully prepared to work with gcc-4.5.x wyldckat OpenFOAM Bugs 18 October 21, 2010 05:51
How to Install OpenFOAM on 64 Ubuntu 9.04 hansel OpenFOAM Installation 62 March 19, 2010 14:43
Problems installin OpenFoam-1.5-dev in Ubuntu 8 tmata2002 OpenFOAM Installation 2 September 23, 2009 10:50


All times are GMT -4. The time now is 12:38.