CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Installation

[OpenFOAM.com] v1612+ cmake-VERSION error during install

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree1Likes
  • 1 Post By bbrown57

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   May 25, 2017, 09:19
Default v1612+ cmake-VERSION error during install
  #1
New Member
 
Brian
Join Date: May 2017
Posts: 4
Rep Power: 4
bbrown57 is on a distinguished road
I am attempting to install OpenFOAM v1612+ by following the instructions found here: https://openfoamwiki.net/index.php/I...CentOS_SL_RHEL.
I am running into an error during step 9, specifically this part "./makeCmake > log.makeCM 2>&1". It finishes almost instantly and the log file simply contains:

# cat log.makeCM

Error: see 'makeCmake -help' for usage
The cmake-VERSION was not specified

I'm at a loss as I've installed OpenFOAM 4.1 with the instructions without issues several times.

Edit: I am installing on Scientific Linux 6.8.

Edit 2: I just tried on our new SL7.2 cluster with the same results.

Last edited by bbrown57; May 25, 2017 at 10:55. Reason: Adding additional info
bbrown57 is offline   Reply With Quote

Old   May 27, 2017, 08:44
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 10,943
Blog Entries: 42
Rep Power: 121
wyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to all
Greetings Brian,

My apologies, I have now revised the instructions on the wiki: https://openfoamwiki.net/index.php/I...HEL#CentOS_6.8

The problem was that I assumed that OpenFOAM+ v1612+ was using the same "makeCmake" script as OpenFOAM 4... but it isn't and back when I wrote the instructions, I somehow missed that detail when testing the instructions.

The missing detail is that we need to run makeCmake like this:
Code:
./makeCmake cmake-3.2.1 > log.makeCM 2>&1
Best regards,
Bruno
__________________
wyldckat is offline   Reply With Quote

Old   June 5, 2017, 11:10
Default
  #3
New Member
 
Brian
Join Date: May 2017
Posts: 4
Rep Power: 4
bbrown57 is on a distinguished road
This fixed the issue. Thank you.
wyldckat likes this.
bbrown57 is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[OpenFOAM.com] MacOS via Docker: Cannot install Paraview with Qt and CMake guessit1000 OpenFOAM Installation 0 July 15, 2018 15:42
[PyFoam] Problems with installing PyFoam Christoph_84 OpenFOAM Community Contributions 33 October 29, 2015 15:34
How to install an old version of Openfoam on OpenSUSE 13.1 Wang@nitech OpenFOAM Installation 2 October 14, 2014 00:03
CFX11 + Fortran compiler ? Mohan CFX 20 March 30, 2011 19:56
Install development version on Ubuntu hsieh OpenFOAM Installation 9 December 31, 2007 09:18


All times are GMT -4. The time now is 08:38.