CFD Online Discussion Forums

CFD Online Discussion Forums (https://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (https://www.cfd-online.com/Forums/openfoam-installation/)
-   -   [OpenFOAM.com] v1706 ParaFoam failed to start (https://www.cfd-online.com/Forums/openfoam-installation/192942-v1706-parafoam-failed-start.html)

media September 14, 2017 00:04

v1706 ParaFoam failed to start
 
Hi there

I have just installed OpenFOAM using Docker on Ubuntu. When tried to run paraFoam I got this error:

This application failed to start because it could not find or load the Qt platform plugin "xcb"
in "".

Reinstalling the application may fix this problem.
/opt/OpenFOAM/OpenFOAM-v1706/bin/paraFoam: line 305: 929 Aborted (core dumped) paraview


Any help or suggestion to resolve this error is highly appreciated.

gdum October 2, 2017 18:53

I have the same problem. I hope someone overthere can help us.

dajuno October 10, 2017 15:57

Same here. Would be great to get some hints on how to fix this issue!

Thanks

cesaralonzo October 20, 2017 11:39

same problem on mac

Lloyd15 November 10, 2017 14:25

Same thing happened to me on a macbook. Did anyone find a solution ?

pgh November 13, 2017 04:32

Hi

Linux
Please set this environment variable and it will work in Linux platforms

export QT_PLUGIN_PATH=$WM_THIRD_PARTY_DIR/platforms/linux64Gcc/qt-5.9.0/plugins


For Mac,
we donot support , paraview/paraFoam in Mac version . Please install native binaries from
paraview.org for your system .

https://www.paraview.org/download/

Regards
Pawan

joshmccraney June 25, 2018 12:07

Did anyone get this to work? I followed the link but still have the initial error.


All times are GMT -4. The time now is 16:48.