CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Installation

OpenFOAM-v1712 installation with intel and mpt - Kahip

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   March 12, 2018, 10:43
Default OpenFOAM-v1712 installation with intel and mpt - Kahip
  #1
New Member
 
cecile
Join Date: Oct 2015
Posts: 6
Rep Power: 4
cecile is on a distinguished road
Hello,

I am currently trying to install OpenFoam v1712 on a cluster with intel compiler 16 and mpt 2.12.

I managed recently to install OpenFoam 4.1 with intel compiler 16 and mpt 2.12 but with OpenFoam v1712 I have issues with Kahip building. There are lots of error like this one :


/sw/compil/gcc/5.2.0/include/c++/5.2.0/bits/stl_iterator_base_types.h(154): error: name followed by "::" must be a class or namespace name
typedef typename _Iterator::iterator_category iterator_category;
^
detected during:
instantiation of class "std::__iterator_traits<_Iterator, void> [with _Iterator=PathID={unsigned int}]" at line 163
instantiation of class "std::iterator_traits<_Iterator> [with _Iterator=PathID={unsigned int}]" at line 31 of "partition/coarsening/matching/gpa/path_set.cpp"

My Allwmake.log file is invalid (?) and I didn't manage to attach it.

I don't know why it is looking in gcc directory since i use intel compiler ....or i think I use Intel.

If anyone has a suggestion to help me .....

Thanks in advance ,

CÚcile
cecile is offline   Reply With Quote

Old   March 13, 2018, 05:41
Default
  #2
New Member
 
cecile
Join Date: Oct 2015
Posts: 6
Rep Power: 4
cecile is on a distinguished road
Hello !

Ok, I managed to solve this issue : my libstdc++ librairie wasn't the good one !

Now I have another issue compiling openFoam sources.
It stops at the very beginning with this error :

db/dictionary/dictionarySearch.C(327): error: invalid type conversion: "Foam::dictionary::const_searcher" to "const Foam::dictionary::searcher &"
return static_cast<const searcher&>(finder);
^
The full log file is attached.

Does anyone has ever encountered such an error ? What is it due to ?

Thanks in advance

Have a nice day
Attached Files
File Type: txt ofwmake.txt (4.1 KB, 1 views)
cecile is offline   Reply With Quote

Old   March 22, 2018, 09:55
Default
  #3
Senior Member
 
Mark Olesen
Join Date: Mar 2009
Location: http://olesenm.github.io/
Posts: 837
Rep Power: 23
olesen will become famous soon enough
Quote:
Originally Posted by cecile View Post
Hello !

Ok, I managed to solve this issue : my libstdc++ librairie wasn't the good one !

Now I have another issue compiling openFoam sources.
It stops at the very beginning with this error :

db/dictionary/dictionarySearch.C(327): error: invalid type conversion: "Foam::dictionary::const_searcher" to "const Foam::dictionary::searcher &"
return static_cast<const searcher&>(finder);
^
The full log file is attached.

Does anyone has ever encountered such an error ? What is it due to ?
This is an interesting one. This should normally work, but obviously doesn't in your case. The intent is to search within the dictionary (normally read-only), but allow explicit casting to the other (read/write) version.

It's rather unfortunate if you've waited a long time and received no answer, but it's only by chance that I read the forum.

I've opened an issue
https://develop.openfoam.com/Develop...lus/issues/780

but I think I would need your assistance to ensure that we get a fix that actually works for you.

/mark
olesen is offline   Reply With Quote

Old   March 22, 2018, 09:56
Default
  #4
Senior Member
 
Mark Olesen
Join Date: Mar 2009
Location: http://olesenm.github.io/
Posts: 837
Rep Power: 23
olesen will become famous soon enough
Sorry double posted, but please do follow up on this on the gitlab side.
Thanks
/mark
olesen is offline   Reply With Quote

Old   March 22, 2018, 09:58
Default
  #5
Senior Member
 
Mark Olesen
Join Date: Mar 2009
Location: http://olesenm.github.io/
Posts: 837
Rep Power: 23
olesen will become famous soon enough
Quote:
Originally Posted by cecile View Post
Hello,

I am currently trying to install OpenFoam v1712 on a cluster with intel compiler 16 and mpt 2.12.

I managed recently to install OpenFoam 4.1 with intel compiler 16 and mpt 2.12 but with OpenFoam v1712 I have issues with Kahip building. There are lots of error like this one :
For Gcc we've added -fpermissive when compiling kahip.
I think that your intel compiler might also be too old.
olesen is offline   Reply With Quote

Old   March 23, 2018, 05:44
Default
  #6
New Member
 
cecile
Join Date: Oct 2015
Posts: 6
Rep Power: 4
cecile is on a distinguished road
Thank you Mark for your answer !

Concerning kahip i am currently trying to install intel 2018 but i have license pb so it may take a while ...

For the second issue I will follow up on this on the gitlab side and let you know .

Thanks again
CÚcile
cecile is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Compile OF2.1 with Intel Icc and Intel MPI hewei OpenFOAM Installation 7 February 12, 2013 16:18


All times are GMT -4. The time now is 05:42.