CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Installation

[OpenFOAM.com] paraFoam problem on MacOS after installing openFoam

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   March 6, 2019, 15:24
Question paraFoam problem on MacOS after installing openFoam
  #1
New Member
 
Panos Koniavitis
Join Date: Oct 2017
Posts: 6
Rep Power: 5
PanosK is on a distinguished road
Hi all,

I am fairly new with openFoam and I am trying to find my way through. I have installed the latest version of openFOAM OpenFOAM-v1812 following the guidelines from here:https://www.openfoam.com/download/in...binary-mac.php

The installation was smooth and I was able to run perfectly the cavity tutorial (I can see the progress on the screen and the results in the directory). My problem is when I try to run paraFoam.

What I initially got was (an apparently common problem)
$ paraFoam
$ Created temporary 'cavity.OpenFOAM'
$ QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-ofuser'
$ QXcbConnection: Could not connect to display
$ /opt/OpenFOAM/OpenFOAM-v1812/bin/paraFoam: line 312: 836 Aborted paraview

I then followed the guidelines from here: ParaView command not found

and I now get a problem with some libraries
$ /opt/OpenFOAM/ThirdParty-v1812/platforms/linux64Gcc/ParaView-5.6.0/lib/paraview: error while loading shared libraries: libmpi.so.12: cannot open shared object file: No such file or directory

Do I need these mpi libraries for this?

thanks a lot in advance!

Panos
PanosK is offline   Reply With Quote

Old   March 6, 2019, 20:38
Default
  #2
Retired Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 10,958
Blog Entries: 45
Rep Power: 122
wyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to all
Quick note: For future reference, PanosK found the answer in this post: QXcbConnection: Could not connect to display :0 - post #5.
__________________
wyldckat is offline   Reply With Quote

Reply

Tags
parafoam, parafoam paraview error

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenFOAM course for beginners Jibran OpenFOAM Announcements from Other Sources 2 November 4, 2019 09:51
[OpenFOAM.org] Problem in installing OpenFOAM 2.3.0 !!! omid20110 OpenFOAM Installation 6 August 1, 2016 12:20
[OpenFOAM.org] Problem with GLIBCXX when installing OpenFOAM using ICC compiler huynhthienloc OpenFOAM Installation 2 May 2, 2016 01:12
Problem Installing OpenFOAM at Ubuntu Maralady OpenFOAM Installation 1 August 25, 2013 19:22
Adventure of fisrst openfoam installation on Ubuntu 710 jussi OpenFOAM Installation 0 April 24, 2008 15:25


All times are GMT -4. The time now is 19:26.