CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Installation

[foam-extend.org] Installation foam-extend-4.1 on Ubuntu 19.04

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   May 17, 2019, 06:15
Default Installation foam-extend-4.1 on Ubuntu 19.04
  #1
New Member
 
Alessandro Tassone
Join Date: Mar 2016
Posts: 2
Rep Power: 0
zethani is on a distinguished road
Hello everyone,
I am trying to install both OpenFOAM and foam-extend on a virtual machine running Ubuntu 19.04 (host Windows 7, VirtualBox) following these instructions: https://pingpong.chalmers.se/public/...o?item=4764601

Everything went smoothly for OpenFOAM, but I have found a lot of issues for foam-extend, i.e. Allwmake reports several errors and cavity tutorial fails to run.

I tried to follow the instructions on the wiki (http://openfoamwiki.net/index.php/In...end-4.0/Ubuntu, for Ubuntu 18.04) but, again, Allwmake reports about 1000 errors. Moreover, the dependencies gcc-5 g++-5 are not retrieved by apt-get and, apparantely, they are deprecated.

I am wondering maybe if Ubuntu 19.04 is not yet supported by foam-extend. Did anyone try to install it?

Many thanks

Alessandro
zethani is offline   Reply With Quote

Old   June 16, 2019, 15:40
Default
  #2
Retired Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 10,956
Blog Entries: 45
Rep Power: 122
wyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to all
Quick answer: I don't know if you've solved this issue, but if not, here's a similar thread: foam-extend-4.0 Debian Testing bison problem fseterr.c - this is because Debian Testing should be similar in versions to Ubuntu 19.04.
__________________
wyldckat is offline   Reply With Quote

Old   December 8, 2019, 04:44
Default
  #3
New Member
 
Elyas_Kermani
Join Date: Dec 2015
Location: Iran
Posts: 12
Rep Power: 6
Elyas_Mosibat is on a distinguished road
Quote:
Originally Posted by zethani View Post
Hello everyone,
I am trying to install both OpenFOAM and foam-extend on a virtual machine running Ubuntu 19.04 (host Windows 7, VirtualBox) following these instructions: https://pingpong.chalmers.se/public/...o?item=4764601

Everything went smoothly for OpenFOAM, but I have found a lot of issues for foam-extend, i.e. Allwmake reports several errors and cavity tutorial fails to run.

I tried to follow the instructions on the wiki (http://openfoamwiki.net/index.php/In...end-4.0/Ubuntu, for Ubuntu 18.04) but, again, Allwmake reports about 1000 errors. Moreover, the dependencies gcc-5 g++-5 are not retrieved by apt-get and, apparantely, they are deprecated.

I am wondering maybe if Ubuntu 19.04 is not yet supported by foam-extend. Did anyone try to install it?

Many thanks

Alessandro



Hi Alessandro,


I have the same problem when I am trying to install Foam-extend 4.0 on ubuntu 19.10. Could you please explain how you solved the problem? thanks,
Elyas_Mosibat is offline   Reply With Quote

Old   April 26, 2020, 09:17
Default Gcc 4.3.3
  #4
New Member
 
Elaxender david
Join Date: Nov 2017
Posts: 17
Rep Power: 4
Engin.shlxtn is on a distinguished road
Hi


I have same problem. It required gcc-4.3.3.
Engin.shlxtn is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[OpenFOAM.org] Open FOAM 4.1 installation on Ubuntu 17.04 (32 bit). Openguy OpenFOAM Installation 2 September 7, 2017 10:33
error with reactingFoam BakedAlmonds OpenFOAM Running, Solving & CFD 4 June 22, 2016 02:21
ParaView-4.0.1 did not compile for foam extend 3.0 installation mhkenergy OpenFOAM Installation 8 June 4, 2014 02:26
[blockMesh] non-orthogonal faces and incorrect orientation? nennbs OpenFOAM Meshing & Mesh Conversion 7 April 17, 2013 05:42
is internalField(U) equivalent to zeroGradient? immortality OpenFOAM Running, Solving & CFD 7 March 29, 2013 01:27


All times are GMT -4. The time now is 16:27.