CFD Online Discussion Forums

CFD Online Discussion Forums (https://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (https://www.cfd-online.com/Forums/openfoam-installation/)
-   -   [OpenFOAM.org] Installation on Ubuntu Subsytem - Failed to fetch (https://www.cfd-online.com/Forums/openfoam-installation/218660-installation-ubuntu-subsytem-failed-fetch.html)

engingreed June 28, 2019 12:52

Installation on Ubuntu Subsytem - Failed to fetch
 
Hello everyone,

Manytimes, I installed OpenFoam on my home computer and office pc. However, nowadays I can not re-install OpenFoam on my home pc. I tried everything and look at every forum. But I could not solve the problem. While I tried to install OF, I follow the instructures. But after, sudo apt-get update; I write the sudo apt-get -y install openfoam6 and I get this:
Code:

E: Failed to fetch https://netix.dl.sourceforge.net/pro...0620_amd64.deb  Could not handshake: The TLS connection was non-properly terminated. [IP: 87.121.121.2 443]
E: Failed to fetch https://netix.dl.sourceforge.net/pro...0221_amd64.deb  Could not handshake: The TLS connection was non-properly terminated. [IP: 87.121.121.2 443]E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

In upper lines I saw this:
Code:

Need to get 153 MB/318 MB of archives.
After this operation, 1929 MB of additional disk space will be used.
Get:3 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 libgstreamer1.0-0 amd64 1.14.4-1~ubuntu18.04.1 [862 kB]Err:1 https://netix.dl.sourceforge.net/pro...am/foam/ubuntu bionic/main amd64 openfoam6 amd64 20190620
  Could not handshake: The TLS connection was non-properly terminated. [IP: 87.121.121.2 443]
Err:2 https://netix.dl.sourceforge.net/pro...am/foam/ubuntu bionic/main amd64 paraviewopenfoam56 amd64 0-20190221
  Could not handshake: The TLS connection was non-properly terminated. [IP: 87.121.121.2 443]
Get:4 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 libgstreamer-plugins-base1.0-0 amd64 1.14.4-1ubuntu1.1~ubuntu18.04.1 [684 kB]
Get:5 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 linux-libc-dev amd64 4.15.0-54.58 [1004 kB]
Get:6 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 gstreamer1.0-plugins-base amd64 1.14.4-1ubuntu1.1~ubuntu18.04.1 [585 kB]
Fetched 3136 kB in 12s (257 kB/s)


wyldckat July 9, 2019 19:56

Quick answer: After a quick search for:
Code:

ubuntu wsl Could not handshake: The TLS connection was non-properly terminated.
it seems that it's due to a proxy error for HTTPS handling. Brief instructions on how to fix that are provided here: https://askubuntu.com/a/1014978

engingreed August 3, 2019 11:45

Quote:

Originally Posted by wyldckat (Post 738497)
Quick answer: After a quick search for:
Code:

ubuntu wsl Could not handshake: The TLS connection was non-properly terminated.
it seems that it's due to a proxy error for HTTPS handling. Brief instructions on how to fix that are provided here: https://askubuntu.com/a/1014978

OK the problem was occured becaouse of my antivir-software. It solved now. Thank you.!!:D:D

VVN October 7, 2020 15:06

I am getting the same error. Do I need to restart the process of installation from beginning or do we have any other solution? Please help

petros October 8, 2020 08:58

Hi,

The error related to the initial post was due to the fact that an antivirus tool was blocking the installation.

If this is not the case for you, clean everything and restart the installation following step by step the respective guides. See here.

Best,
Petros

VVN October 8, 2020 14:26

Thank you for reply. The error was due to bad network. But I restarted the process by entering:

sudo apt-get update

sudo apt-get -y install openfoam8

and it worked :)


All times are GMT -4. The time now is 12:32.