CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Installation

[OpenFOAM.org] OpenFOAM 2.3.1 on Ubuntu 16.04

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   December 1, 2019, 09:56
Default OpenFOAM 2.3.1 on Ubuntu 16.04
  #1
Member
 
M Malik
Join Date: Jan 2019
Posts: 48
Rep Power: 3
mmalik is on a distinguished road
Hi.

Trying to install OF231 on Ubuntu 16.04. I have previously installed it on Ubuntu 14.04 and was working well.

However, 16.04 is giving me weird error. I have attached the log error.

I tried following #3 from (Problems installing OpenFOAM 2.4.0 on Fedora 23) but not helpful.

Any help will be appreciated.
Attached Files
File Type: gz log.make.tar.gz (19.4 KB, 5 views)
mmalik is offline   Reply With Quote

Old   December 3, 2019, 13:04
Default
  #2
Member
 
M Malik
Join Date: Jan 2019
Posts: 48
Rep Power: 3
mmalik is on a distinguished road
Same issue and I tried following Post #3 but still wmake fails.

OF 2.3.1 on Ubuntu 16.04

[Moderator note: Moved from Installing OpenFOAM-2.3.x]

Last edited by wyldckat; December 3, 2019 at 15:33. Reason: see "Moderator note"
mmalik is offline   Reply With Quote

Old   December 3, 2019, 15:30
Default
  #3
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 10,956
Blog Entries: 43
Rep Power: 122
wyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to all
Quote:
Originally Posted by mmalik View Post
Same issue and I tried following Post #3 but still wmake fails.

OF 2.3.1 on Ubuntu 16.04
Quick answer: details, details, details... if you don't provide any specific output on the error messages you are getting, there is nothing I can do.

Furthermore, there are specific step-by-step installation instructions for the versions you stated: https://openfoamwiki.net/index.php/I...u#Ubuntu_16.04


edit: I then went looking for past posts of yours and moved your post above to the original thread you started asking about this. Please be more specific about which installation instructions you've followed. If you have not tried the instructions from the link I've provided, please do so.
__________________

Last edited by wyldckat; December 3, 2019 at 15:34. Reason: see "edit:"
wyldckat is offline   Reply With Quote

Old   December 3, 2019, 18:17
Default
  #4
Member
 
M Malik
Join Date: Jan 2019
Posts: 48
Rep Power: 3
mmalik is on a distinguished road
Apologies. I followed the steps provided in (https://openfoamwiki.net/index.php/I...u#Ubuntu_16.04) Section 2.6 Ubuntu 16.04.

I have attached the error log. I am able to install other version of OF (OF4.x, OF6).

Not sure what I am doing incorrectly.
Attached Files
File Type: gz log.make.gz (12.6 KB, 0 views)
File Type: gz logs.tar.gz (26.2 KB, 0 views)
mmalik is offline   Reply With Quote

Old   December 4, 2019, 16:54
Default
  #5
HPE
Senior Member
 
Herpes Free Engineer
Join Date: Sep 2019
Location: The Home Under The Ground with the Lost Boys
Posts: 619
Rep Power: 7
HPE is on a distinguished road
Is there any reason why you want to compile such an old OpenFOAM version? If might be related to a personal piece of code, we can try to modify it for you, so that you can compile the newest versions of OpenFOAM. Just saying.
HPE is offline   Reply With Quote

Old   December 5, 2019, 04:25
Default
  #6
Member
 
M Malik
Join Date: Jan 2019
Posts: 48
Rep Power: 3
mmalik is on a distinguished road
Hello HPE. Yes, I am working electrospray/electrohydrodynamic process. I have a modified solver on OF231 (interFoam with electric field component) which I am trying to verify with some experimental results. I am getting droplet production for organic solvents such as Triethylene glycol. But as I increase the conductivity, my simulation crashes.

So thought to make it work on the old version and then update it.

If you can help me modify to newer version, that would be highly appreciated. Should I attach the solver here?
mmalik is offline   Reply With Quote

Reply

Tags
openfoam 2.3.1, openfoam 2.3.x, ubuntu 16.04

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[OpenFOAM.org] OpenFOAM 7 installation on ubuntu 16.04 LTS kerim OpenFOAM Installation 2 October 10, 2019 00:04
[OpenFOAM.org] OpenFOAM 5 source pack installation on Ubuntu 16.04 CjjJoy OpenFOAM Installation 23 June 6, 2018 10:55
[OpenFOAM.org] OpenFOAM 2.3.0 ubuntu 16.04 FlyBob91 OpenFOAM Installation 5 November 17, 2017 07:11
[OpenFOAM.org] OpenFOAM missing after upgrade to Ubuntu 16.04 Storyteller OpenFOAM Installation 2 May 1, 2016 18:14
[OpenFOAM.org] Problem of openFOAM 2.3.1 installation in Ubuntu 14.04LTS mukut OpenFOAM Installation 9 January 19, 2015 00:48


All times are GMT -4. The time now is 19:32.