CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Installation

[OpenFOAM.com] Problem when running Paraview on ubuntu bash for windows 10

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   April 26, 2020, 19:07
Post Problem when running Paraview on ubuntu bash for windows 10
  #1
New Member
 
nazim
Join Date: Nov 2018
Location: France
Posts: 4
Rep Power: 3
Nazim is on a distinguished road
Hello everyone,

I have used OpenFoam in the past on computers of my university, but that time because of coronavirus and some other things I have to install OpenFoam and all I need on my personal computer.

I'm under windows 10 and installed OpenFoam correctly as I have tested that some functionalities like blockMesh are working correctly.

The problem is when I tried to open paraview on the bash that I have now on windows. I have the following error message:

[Jmx-MSI:13736] *** Process received signal ***
[Jmx-MSI:13736] Signal: Segmentation fault (11)
[Jmx-MSI:13736] Signal code: Address not mapped (1)
[Jmx-MSI:13736] Failing at address: 0x44000098
[Jmx-MSI:13736] [ 0] /lib/x86_64-linux-gnu/libc.so.6(+0x3ef20)[0x7f49d6c3ef20]
[Jmx-MSI:13736] [ 1] /home/ubuntu_jmx/OpenFOAM/ThirdParty-v1912/platforms/linux64Gcc63/openmpi-1.10.7/lib64/libmpi.so.12(PMPI_Comm_set_errhandler+0x50)[0x7f49c5b8d0a0]
[Jmx-MSI:13736] [ 2] /home/ubuntu_jmx/ParaView-5.8.0-MPI-Linux-Python3.7-64bit/bin/../lib/libvtkParallelMPI-pv5.8.so.1(_ZN18vtkMPICommunicator20GetWorldCommun icatorEv+0x52)[0x7f49c5e27c62]
[Jmx-MSI:13736] [ 3] /home/ubuntu_jmx/ParaView-5.8.0-MPI-Linux-Python3.7-64bit/bin/../lib/libvtkParallelMPI-pv5.8.so.1(_ZN16vtkMPIController10InitializeEPiPPP ci+0x25)[0x7f49c5e2e2f5]
[Jmx-MSI:13736] [ 4] /home/ubuntu_jmx/ParaView-5.8.0-MPI-Linux-Python3.7-64bit/bin/../lib/libvtkRemotingCore-pv5.8.so.1(_ZN16vtkProcessModule10InitializeENS_12 ProcessTypesERiRPPc+0x163)[0x7f49d31ea103]
[Jmx-MSI:13736] [ 5] /home/ubuntu_jmx/ParaView-5.8.0-MPI-Linux-Python3.7-64bit/bin/../lib/libvtkRemotingApplication-pv5.8.so.1(_ZN23vtkInitializationHelper10Initializ eEiPPciP12vtkPVOptions+0xe7)[0x7f49ca9970a7]
[Jmx-MSI:13736] [ 6] /home/ubuntu_jmx/ParaView-5.8.0-MPI-Linux-Python3.7-64bit/bin/../lib/libpqCore-pv5.8.so.1(_ZN17pqApplicationCoreC1ERiPPcP9pqOptio nsP7QObject+0x1c3)[0x7f49d53a7543]
[Jmx-MSI:13736] [ 7] /home/ubuntu_jmx/ParaView-5.8.0-MPI-Linux-Python3.7-64bit/bin/../lib/libpqApplicationComponents-pv5.8.so.1(_ZN19pqPVApplicationCoreC1ERiPPcP9pqOpt ions+0x1c)[0x7f49d68916cc]
[Jmx-MSI:13736] [ 8] /home/ubuntu_jmx/ParaView-5.8.0-MPI-Linux-Python3.7-64bit/bin/paraview[0x40c3e2]
[Jmx-MSI:13736] [ 9] /home/ubuntu_jmx/ParaView-5.8.0-MPI-Linux-Python3.7-64bit/bin/paraview[0x407734]
[Jmx-MSI:13736] [10] /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xe7)[0x7f49d6c21b97]
[Jmx-MSI:13736] [11] /home/ubuntu_jmx/ParaView-5.8.0-MPI-Linux-Python3.7-64bit/bin/paraview[0x407a7d] [Jmx-MSI:13736] *** End of error message *** Segmentation fault (core dumped)

The problem is that I don't understand much of these line, if anyone could help me. I will give some additional details below this paragraph.

I untared in my home of the bash (in my case ubuntu_jmx) Paraview and it seem to get installed correctly.

You have to understand that I installed correctly the windows version of it of my windows program files system and it's running correctly. It's just that I want to have paraview on the linux part (I'm not running a virtual machine or having dual boot neither, but having ubuntu from the windows store it's like having a dual boot I guess) and that's when it generates me this error

Thanks in advance

Last edited by Nazim; April 27, 2020 at 19:18.
Nazim is offline   Reply With Quote

Reply

Tags
#paraview

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[OpenFOAM.org] Installation problem for paraView 4.1 to go with OpenFOAM-2.4.0-MNF deepbandivadekar OpenFOAM Installation 2 October 25, 2017 08:45
Yet another Paraview problem gascortado OpenFOAM 5 February 21, 2010 06:39
Successful Installaton Of OpenFOAM-1.6 and Paraview in Ubuntu 9.04 AlanR OpenFOAM Installation 21 September 17, 2009 11:27
Problem in running fluent 6.3 (64 bit) on ubuntu 8.1 (64 bit) Mir5 FLUENT 3 April 29, 2009 10:32
[OpenFOAM] Could anyone please help me in running the paraview in my Ubuntu system chanduksekhar ParaView 2 February 6, 2006 09:13


All times are GMT -4. The time now is 20:39.