CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Installation

[OpenFOAM.org] Allmake not reading a file that is there

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   June 17, 2020, 15:55
Default Allmake not reading a file that is there
  #1
Senior Member
 
Josh McCraney
Join Date: Jun 2018
Posts: 164
Rep Power: 4
joshmccraney is on a distinguished road
Hi all!

In the Make/options file I have
Code:
EXE_INC = \
    -I$(LIB_SRC)/transportModels/twoPhaseMixture/lnInclude \
    -I./transportModels \
    -I$(LIB_SRC)/transportModels/incompressible/lnInclude \
    -I./transportModels/interfaceProperties/lnInclude \
    -I$(LIB_SRC)/TurbulenceModels/turbulenceModels/lnInclude \
    -I$(LIB_SRC)/TurbulenceModels/incompressible/lnInclude \
    -I./transportModels/immiscibleIncompressibleTwoPhaseMixture/lnInclude \
    -I$(LIB_SRC)/finiteVolume/lnInclude \
    -I$(LIB_SRC)/meshTools/lnInclude \
    -I$(LIB_SRC)/sampling/lnInclude

EXE_LIBS = \
    -L$(FOAM_LIBBIN) \
    -lturbulenceModels \
    -lincompressibleTurbulenceModels \
    -lfiniteVolume \
    -lfvOptions \
    -lmeshTools \
    -lsampling \
    -L$(FOAM_USER_LIBBIN) \
    -limmiscibleIncompressibleTwoPhaseMixtureSmoothed
When I run Allmake I get an error saying the immiscibleIncompressibleTwoPhaseMixture.H file is not found, but I checked and this file is located in the immiscibleIncompressibleTwoPhaseMixture folder, which is included (above green text).

Any idea how to include this file?

Thanks for your help!
joshmccraney is offline   Reply With Quote

Old   June 19, 2020, 19:50
Default
  #2
Member
 
Lisandro Maders
Join Date: Feb 2013
Posts: 98
Rep Power: 9
Lisandro Maders is on a distinguished road
I think the path is wrong? Shouldn't it be:

-I ../transportModels/immiscibleIncompressibleTwoPhaseMixture/lnInclude \

Or you could use $FOAM_RUN environmental variable to make sure you are in the correct relative path.. like:

-I $FOAM_RUN/[whatever needs to go to ->]/transportModels/immiscibleIncompressibleTwoPhaseMixture/lnInclude \
Lisandro Maders is offline   Reply With Quote

Old   June 21, 2020, 21:36
Default
  #3
Senior Member
 
Josh McCraney
Join Date: Jun 2018
Posts: 164
Rep Power: 4
joshmccraney is on a distinguished road
Quote:
Originally Posted by Lisandro Maders View Post
I think the path is wrong? Shouldn't it be:

-I ../transportModels/immiscibleIncompressibleTwoPhaseMixture/lnInclude \

Or you could use $FOAM_RUN environmental variable to make sure you are in the correct relative path.. like:

-I $FOAM_RUN/[whatever needs to go to ->]/transportModels/immiscibleIncompressibleTwoPhaseMixture/lnInclude \
Thanks for the response. I tried your first suggestion
Code:
-I ../transportModels/immiscibleIncompressibleTwoPhaseMixture/lnInclude \
but I'm getting the same error shown in post 1. Would try your second suggestion but I don't know what to put for the red text.

Any idea further?
joshmccraney is offline   Reply With Quote

Old   June 23, 2020, 20:35
Default
  #4
Member
 
Lisandro Maders
Join Date: Feb 2013
Posts: 98
Rep Power: 9
Lisandro Maders is on a distinguished road
Sorry, I thought this was some user-defined library that you have compiled.

Which library you are trying to compile? What is the content of Make/files file, and which OF version are you using?

Also, you said you checked the immiscibleIncompressibleTwoPhaseMixture in the $FOAM_SRC/transportModels/immiscibleIncompressibleTwoPhaseMixture folder, right? What about the $FOAM_SRC/transportModels/immiscibleIncompressibleTwoPhaseMixture/lnInclude folder? Can you see the immiscibleIncompressibleTwoPhaseMixture.H file?
Lisandro Maders is offline   Reply With Quote

Old   June 24, 2020, 09:38
Default
  #5
Senior Member
 
Josh McCraney
Join Date: Jun 2018
Posts: 164
Rep Power: 4
joshmccraney is on a distinguished road
Quote:
Originally Posted by Lisandro Maders View Post
Sorry, I thought this was some user-defined library that you have compiled.

Which library you are trying to compile? What is the content of Make/files file, and which OF version are you using?
You're right, this is a user-defined library. I'm using OpenFOAM 4.x. There are a few subdirectories, each with their own make files; did you want to see them all or is there a particular one you are referring to?

Quote:
Originally Posted by Lisandro Maders View Post
Also, you said you checked the immiscibleIncompressibleTwoPhaseMixture in the $FOAM_SRC/transportModels/immiscibleIncompressibleTwoPhaseMixture folder, right?
Yes.

Quote:
Originally Posted by Lisandro Maders View Post
What about the $FOAM_SRC/transportModels/immiscibleIncompressibleTwoPhaseMixture/lnInclude folder? Can you see the immiscibleIncompressibleTwoPhaseMixture.H file?
There is no lnInclude folder here; could this be the issue?

Perhaps related, but I received the following advice:

"Perhaps the link in lnInclude is broken. Have you tried building interFoamKistlerLiquidSmoothed and the required libraries in the transportModels subdirectory again from scratch by first deleting the lnInclude and compiler (in my case linux64GccDPInt32Opt) subdirectories? In case something got mixed up during a previous compilation this might fix it."

Following this advice, I execute Allwmake within the /home/josh/of4x/ThirdParty-4.x/interFoamKistlerLiquidSmoothed_v0.2/transportModels directory and get the error
Code:
/usr/bin/ld: cannot find -ltwoPhaseMixture
/usr/bin/ld: cannot find -lfiniteVolume
collect2: error: ld returned 1 exit status
/home/josh/of4x/OpenFOAM-4.x/wmake/makefiles/general:156: recipe for target '/home/josh/OpenFOAM/josh-4.x/platforms/linux64GccDPInt32Opt/lib/libinterfacePropertiesSmoothed.so' failed
make: *** [/home/josh/OpenFOAM/josh-4.x/platforms/linux64GccDPInt32Opt/lib/libinterfacePropertiesSmoothed.so] Error 1
I'm running two different versions of openfoam. There is a folder titled OpenFOAM, which contains openfoam 6 (irrelevant to this build) and there is another folder of4x which relates to openfoam 4.x.

To me, it looks like from the error highlighted in red the compilation process is trying to talk to the wrong folder. What do you think?
joshmccraney is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[swak4Foam] funkyDoCalc with OF2.3 massflow NiFl OpenFOAM Community Contributions 11 November 1, 2016 06:43
[OpenFOAM.org] Compile OF 2.3 on Mac OS X .... the patch gschaider OpenFOAM Installation 225 August 25, 2015 19:43
Custom Thermophysical Properties wsmith02 OpenFOAM 3 July 27, 2015 05:37
[swak4Foam] swak4foam building problem GGerber OpenFOAM Community Contributions 54 April 24, 2015 16:02
OpenFOAM on MinGW crosscompiler hosted on Linux allenzhao OpenFOAM Installation 127 January 30, 2009 19:08


All times are GMT -4. The time now is 13:23.