CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Installation

[OpenFOAM.org] Missing mpi.h file error

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   January 15, 2021, 04:09
Default Missing mpi.h file error
  #1
New Member
 
Ariful Islam Pranto
Join Date: Jul 2020
Posts: 11
Rep Power: 2
Pranto is on a distinguished road
I got following warnings
Code:
Warning in OpenFOAM-dev/etc/config.sh/settings: 
     MPI_ARCH_FLAGS is not set. Example: 

export MPI_ARCH_FLAGS="-DOMPI_SKIP_MPICXX"  

 Warning in OpenFOAM-dev/etc/config.sh/settings:     

MPI_ARCH_LIBS is not set. Example:          

export MPI_ARCH_LIBS="-L$MPI_ROOT/lib -lmpi"
where should I put MPI_ARCH_FLAGS? Otherwise, it gives
Code:
 UPstream.C:30:10: fatal error: mpi.h: No such file or directory

Thanks in advance
Pranto is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[foam-extend.org] Problems installing foam-extend-4.0 on openSUSE 42.2 and Ubuntu 16.04 ordinary OpenFOAM Installation 19 September 3, 2019 18:13
error compiling modified applications yvyan OpenFOAM Programming & Development 21 March 1, 2016 04:53
OpenFOAM without MPI kokizzu OpenFOAM Installation 4 May 26, 2014 09:17
[swak4Foam] Error bulding swak4Foam sfigato OpenFOAM Community Contributions 18 August 22, 2013 12:41
OpenFOAM on MinGW crosscompiler hosted on Linux allenzhao OpenFOAM Installation 127 January 30, 2009 19:08


All times are GMT -4. The time now is 11:58.