CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Installation

M1Pro: OpenFOAM 2106 works but not OpenFOAM 9

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree2Likes
  • 1 Post By sourav90
  • 1 Post By sourav90

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   January 12, 2022, 13:27
Default M1Pro: OpenFOAM 2106 works but not OpenFOAM 9
  #1
Member
 
Sourav Mandal
Join Date: Jul 2019
Posts: 55
Rep Power: 6
sourav90 is on a distinguished road
Dear all,

I am trying to run OpenFOAM on the new Mac hardware (M1Pro, 32GB RAM). There are people who make & maintain patches for macOS, but the latest hardware being new, still has some problems.

My main goal is to use OpenFOAM 9 but after installing it from the instruction given by mrklein, I am having this issue when I went on to test it:

PHP Code:
blockMesh
dyld
[60712]: symbol not found in flat namespace '_MPI_Abort'
[1]    60712 abort      blockMesh 
I tried two versions so far which lead to to same error. reported the issue but thought someone here might be able to help. The error message doesn't seem helpful to a newbie like me.

But I could make OpenFOAMv-2106 work with two patches
And adding other links as well pertaining to this
I shall be grateful if anyone can shed some light on this.
aparangement likes this.
sourav90 is offline   Reply With Quote

Old   March 9, 2023, 22:32
Default
  #2
Senior Member
 
Pierre-Olivier Dallaire
Join Date: Mar 2009
Location: Montreal, Quebec, Canada
Posts: 192
Rep Power: 16
podallaire is on a distinguished road
Hello,

I know this thread is old but I thought I would give it a shot :-)

I experienced the same behaviour on a M2 chip. For some reasons, the HomeBrew libraries and the native MacOs clang compiler are not playing nice for OpenFOAM-10. Any idea? The flat namespace error is present for any library that was installed with HomeBrew.

Regards,

PO
podallaire is offline   Reply With Quote

Old   March 9, 2023, 23:51
Default Nice native binary package
  #3
Member
 
Sourav Mandal
Join Date: Jul 2019
Posts: 55
Rep Power: 6
sourav90 is on a distinguished road
I'm not trying to compile natively on M1 now, as this version worked nicely to fulfill my requirements; the last time I checked it - gerlero/openfoam-app. Just for information, if anyone finds this useful
dlahaye likes this.
sourav90 is offline   Reply With Quote

Reply

Tags
m1pro, macos, openfoam9, openfoamv2106

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Map of the OpenFOAM Forum - Understanding where to post your questions! wyldckat OpenFOAM 10 September 2, 2021 05:29
OpenFOAM 15 and openSUSE 111 paraview works OK alberto OpenFOAM 10 March 6, 2009 05:52
64bitrhel5 OF installation instructions mirko OpenFOAM Installation 2 August 12, 2008 18:07
Adventure of fisrst openfoam installation on Ubuntu 710 jussi OpenFOAM Installation 0 April 24, 2008 14:25
Understanding how openfoam works Billy (Billy) OpenFOAM Running, Solving & CFD 1 February 8, 2005 06:41


All times are GMT -4. The time now is 20:53.