CFD Online Discussion Forums

CFD Online Discussion Forums (https://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (https://www.cfd-online.com/Forums/openfoam-installation/)
-   -   [OpenFOAM.com] Weird behavior on zsh (https://www.cfd-online.com/Forums/openfoam-installation/241107-weird-behavior-zsh.html)

xuegy February 8, 2022 21:39

Weird behavior on zsh
 
Hello all,

I'm currently using macOS with zsh. I'm having a very weird problem.
If I type commands in the terminal, there's no issue. Everything runs well.
If I run scripts in the terminal, I'm see the warning message:
Code:

--> FOAM Warning :
    From void *Foam::dlLibraryTable::openLibrary(const Foam::fileName &, bool)
    in file db/dynamicLibrary/dlLibraryTable/dlLibraryTable.C at line 188
    Could not load "libOpenFOAM.so"
dlopen(libOpenFOAM.dylib, 0x0009): tried: 'libOpenFOAM.dylib' (no such file), '/usr/local/lib/libOpenFOAM.dylib' (no such file), '/usr/lib/libOpenFOAM.dylib' (no such file), '******/libOpenFOAM.dylib' (no such file), '/usr/local/lib/libOpenFOAM.dylib' (no such file), '/usr/lib/libOpenFOAM.dylib' (no such file)

If I use bash it's all good however the bash on macOS is very outdated and I still prefer zsh. Is there any solution to this?

Thanks!


All times are GMT -4. The time now is 01:29.