CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Installation

[OpenFOAM.com] OpenFoam 2106 from source on WSL2

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   March 21, 2022, 09:38
Default OpenFoam 2106 from source on WSL2
  #1
New Member
 
Join Date: Dec 2021
Posts: 23
Rep Power: 3
MamboJambo is on a distinguished road
Hello to all,

I am installing OpenFOAM v2106 from source.

I followed the procedures in https://develop.openfoam.com/Develop...5/doc/Build.md.

However, when I run the command: foamInstallationTest



I get:
Code:
Executing foamInstallationTest Basic setup : ------------------------------------------------------------------------------- OpenFOAM: OpenFOAM-v2106 ThirdParty: ThirdParty-v2106 Shell: bash Host: pc OS: Linux version 5.10.60.1-microsoft-standard-WSL2 ------------------------------------------------------------------------------- Main OpenFOAM env variables : ------------------------------------------------------------------------------- Environment FileOrDirectory Valid Crit ------------------------------------------------------------------------------- $WM_PROJECT_USER_DIR /home/pc/OpenFOAM/pc-v2106 no no $WM_THIRD_PARTY_DIR /home/pc/OpenFOAM/ThirdParty-v2106 yes maybe $WM_PROJECT_SITE [env variable unset] no ------------------------------------------------------------------------------- OpenFOAM env variables in PATH : ------------------------------------------------------------------------------- Environment FileOrDirectory Valid Path Crit ------------------------------------------------------------------------------- $WM_PROJECT_DIR /home/pc/OpenFOAM/OpenFOAM-v2106 yes yes yes $FOAM_APPBIN .../platforms/linux64GccDPInt32Debug/bin yes yes yes $FOAM_SITE_APPBIN .../platforms/linux64GccDPInt32Debug/bin no no $FOAM_USER_APPBIN .../platforms/linux64GccDPInt32Debug/bin no no $WM_DIR /home/pc/OpenFOAM/OpenFOAM-v2106/wmake yes yes often ------------------------------------------------------------------------------- OpenFOAM env variables in LD_LIBRARY_PATH : ------------------------------------------------------------------------------- Environment FileOrDirectory Valid Path Crit ------------------------------------------------------------------------------- $FOAM_LIBBIN .../platforms/linux64GccDPInt32Debug/lib yes yes yes $FOAM_SITE_LIBBIN .../platforms/linux64GccDPInt32Debug/lib no no $FOAM_USER_LIBBIN .../platforms/linux64GccDPInt32Debug/lib no no $FOAM_EXT_LIBBIN ...v2106/platforms/linux64GccDPInt32/lib yes yes maybe $MPI_ARCH_PATH /usr/lib/x86_64-linux-gnu/openmpi yes yes yes ------------------------------------------------------------------------------- Software Components ------------------------------------------------------------------------------- Software Version Location ------------------------------------------------------------------------------- flex *** not installed *** make *** not installed *** wmake *** not installed *** gcc *** not installed *** CRITICAL ERROR g++ *** not installed *** ------------------------------------------------------------------------------- icoFoam *** not installed *** CRITICAL ERROR Summary ------------------------------------------------------------------------------- Base configuration ok. The foam installation contains 2 critical error(s). Review the output for warning messages and consult the installation guide for troubleshooting. Done

Telling me I do not have several softwares installed. However, I can run the tutorial cases, and in fact have the softwares installed... Is this a "bug" on the function?
MamboJambo is offline   Reply With Quote

Old   November 20, 2022, 08:40
Smile foamInstallationTest
  #2
New Member
 
Abhijit Deshpande
Join Date: Jan 2014
Location: Bangalore
Posts: 7
Rep Power: 11
ab.glb.cfd is on a distinguished road
I am also facing same for openfoam2206.


However when I copy all tutorials to home directory I can run icoFoam.


Really don't know what's happening within /usr/lib/openfoam/openfoam2206.


If anyone gets a solution please post it...
ab.glb.cfd is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[Other] Tabulated thermophysicalProperties library chriss85 OpenFOAM Community Contributions 62 October 2, 2022 04:50
Using PengRobinsonGas EoS with sprayFoam Jabo OpenFOAM Running, Solving & CFD 35 April 29, 2022 16:35
[foam-extend.org] problem when installing foam-extend-1.6 Thomas pan OpenFOAM Installation 7 September 9, 2015 22:53
centOS 5.6 : paraFoam not working yossi OpenFOAM Installation 2 October 9, 2013 02:41
OpenFOAM on MinGW crosscompiler hosted on Linux allenzhao OpenFOAM Installation 127 January 30, 2009 20:08


All times are GMT -4. The time now is 07:44.