CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   ParaFoam error could not find a decent visual (

davidlee March 1, 2009 00:51

I have compiled Qt 4.3.5 and t
I have compiled Qt 4.3.5 and therefore, paraview 3.3 and PV3FoamReader modules.

when running the paraFoam or paraview, for that matter, It shows the paraview window but in less than 3 seconds, it disappears. On the terminal window it displays the following:

[Yusuf@f9 cavity]$ paraFoam
ERROR: In /home/Yusuf/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering/vtkXOpenGLRenderWi ndow.cxx, line 398
vtkXOpenGLRenderWindow (0x7f8270db95f0): Could not find a decent visual

ERROR: In /home/Yusuf/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering/vtkXOpenGLRenderWi ndow.cxx, line 398
vtkXOpenGLRenderWindow (0x7f8270db95f0): Could not find a decent visual

X Error: BadValue (integer parameter out of range for operation) 2
Extension: 143 (Uknown extension)
Minor opcode: 3 (Unknown request)
Resource id: 0x21
ERROR: In /home/Yusuf/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Rendering/vtkXOpenGLRenderWi ndow.cxx, line 623
vtkXOpenGLRenderWindow (0x7f8270db95f0): Cannot create GLX context. Aborting.

/home/Yusuf/OpenFOAM/OpenFOAM-1.5/bin/paraFoam: line 83: 5491 Aborted paraview --data=$caseFile

Any clue?

Thanks in advance.

openfoam_user March 1, 2009 03:42

Dear David, I have exactly
Dear David,

I have exactly the same problem. And I don't know how to solve it !

So for the moment I don't use no more the ParaView3.3-cvs version but ParaView3.4. After having solved a problem (with icoFoam for example) I use the command 'foamToVTK'. Then I launch paraview and open VTK files.

Let me know if you find how to solve the paraFoam problem. Thanks in advance.


afiq April 3, 2010 03:13

Cannot run paraview
Dear All,

I also have exact problem as you guys, but unfortunately, everytime when I try to search in the forum, there are not actually solved.

But this time, I think I have solved the problem (for myself). The problem is with the display. Before I solved the problem, I didn't realize that my display device was not activated/installed (in my uBuntu) which I use nVidia. After I activated or install the device, the problem is solved. Not more warning, and I can use the paraview as usual now.

Good luck!

preichl October 14, 2010 01:12

I had similar errors when connecting via ssh to the machine running paraview (even with paraview 3.8.1).

Setting the environment variable via the command below worked for me.


I tried this after reading

Hope this helps anyone else in the same boat.

All times are GMT -4. The time now is 02:00.