CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   HowTo Make paraFoam from OpenFOAM15 work on OpenSuse11 by installing Qt435 in home directory (

wenterodt November 7, 2008 08:29

Since there is a lot of confus
Since there is a lot of confusion about Open Suse 11 (which needs Qt4.4) and OpenFOAM1.5 respectively ParaView3 (which needs Qt4.3), I want to try to solve the problem for all non-professionals. What is described here is a parallel installation of Qt4.3.5 in the home directory of the user, so it will not screw up the operating system, which is dependent on QT4.4. Here is what worked for me:

HowTo make paraFoam run on an OpenSuse 11 machine:

After installing OpenFOAM by following the steps (without #7) described in
perform the following three steps:

Download qt-x11-opensource-src-4.3.5.tar.gz (approx. 40MB)
and unpack it in your /tmp folder. There now should be a folder called /tmp/qt-x11-opensource-src-4.3.5 on your system

Go to that folder
cd /tmp/qt-x11-opensource-src-4.3.5
set the path you want to install Qt-4.3.5 in, e.g.
./configure -prefix ~/OpenFOAM/ThirdParty/Qt-4.3.5
you may have to accept the GNU-license. Now compile (takes some time...)
and install
make install
add the following lines to your ~/OpenFOAM/OpenFOAM-1.5/etc/bashrc at the very end
# set QT related variables
export PATH=$QT/bin:$PATH

Now paraFoam should run smoothly...

If not, maybe you have to recompile the PV3FoamReader (step 7,2 from README), but I think there should be no need to recompile ParaView (step 7,1).

I'd be glad for feedback if this worked on your machine!



sxhdhi November 11, 2008 20:46

Hi Tammo, My name is Su xia
Hi Tammo,

My name is Su xiaohui. and thanks a lot for your valuable suggestion. I think I need your help because when I do the command: ./configure -prefix ~/OpenFOAM/ThirdParty/Qt-4.3.5
the following error appearing:
Do you accept the terms of either license? yes

Creating qmake. Please wait...
g++ -c -o project.o -pipe -DQMAKE_OPENSOURCE_EDITION -I. -Igenerators -Igenerators/unix -Igenerators/win32 -Igenerators/mac -I/home/user/Desktop/tmp/qt-x11-opensource-src-4.3.5/qt-x11-opensource-src-4.3.5 /src/corelib/arch/generic -I/home/user/Desktop/tmp/qt-x11-opensource-src-4.3.5/qt-x11-opensource-src-4.3.5 /include -I/home/user/Desktop/tmp/qt-x11-opensource-src-4.3.5/qt-x11-opensource-src-4.3.5 /include/QtCore -I/home/user/Desktop/tmp/qt-x11-opensource-src-4.3.5/qt-x11-opensource-src-4.3.5 /include -I/home/user/Desktop/tmp/qt-x11-opensource-src-4.3.5/qt-x11-opensource-src-4.3.5 /include/QtCore -I/home/user/Desktop/tmp/qt-x11-opensource-src-4.3.5/qt-x11-opensource-src-4.3.5 /src/corelib/global -I/home/user/Desktop/tmp/qt-x11-opensource-src-4.3.5/qt-x11-opensource-src-4.3.5 /src/script -DQT_NO_PCRE -DQT_NO_TEXTCODEC -DQT_NO_UNICODETABLES -DQT_NO_COMPONENT -DQT_NO_STL -DQT_BUILD_QMAKE -DQT_NO_COMPRESS -I/home/user/Desktop/tmp/qt-x11-opensource-src-4.3.5/qt-x11-opensource-src-4.3.5 /mkspecs/linux-g++ -DHAVE_QCONFIG_CPP -DQT_NO_THREAD -DQT_NO_QOBJECT -DQT_NO_GEOM_VARIANT project.cpp
make: g++: Command not found
make: *** [project.o] Error 127

may I know what happen here? Thanks a lot.


gwierink November 12, 2008 02:13

Hi Xiaohui, The error messa
Hi Xiaohui,

The error message says "make: g++: Command not found". Do you have g++ installed? If you don't, you need to install it. Go to, or use YaSt or yum to install gcc and gcc-c++.

Rgds, Gijsbert

tckosvic November 12, 2008 18:36

Tammo, I followed your inst

I followed your instructions regarding parafoam on suse 11 and installing a different QT.

All went well but when I was in the directory:

I typed the command:
./configure -prefix ~/OpenFOAM/ThirdParty/Qt-4.3.5

I got response in terminal window:

""This is the Qt/X11 Open Source Edition.

You don't seem to have 'make' or 'gmake' in your PATH.
Cannot proceed.""

There is no make file in the download package. Thus, when I typed:


It also said no make.

I think that Su Xiaohui messages also said meant that there was no "make" not that there was no gcc.

Please have another look and let me know what you think problem is.

I really like your approach. I have been looking for a way to use openfoam1.5 and suse11 and get past the QT problem. I think you have a good approach and did some good work.


Tom Kosvic

sxhdhi November 13, 2008 01:30

Hi guys, good news to share
Hi guys,

good news to share with you for who are in trouble with running paraFoam!

1. first installed ubuntu 8.10
2. sudo apt-get update
sudo apt-get install libqt4-dev (make sure qt is availabe)
3. install OpenFoam
finally, I can run paraFoam.
Hope this can help you guys.



gzy_1228 November 13, 2008 02:37

Hi everyone I followed Tamm
Hi everyone
I followed Tammo's steps in my mandriva2009, but i have to recompile ParaView (step 7.1) otherwise it doesn't work.

kenhelland November 13, 2008 13:08

Hello Tammo, I have been wo
Hello Tammo,

I have been working with suse 11.0, and your approach seems the most hopeful. Here is what
has happened.

First, when I installed 11 using some auto configuration, the developement software was not loaded and I wasn't able to even get he Qt version test to work. I reloaded 11 and installed just about everything, so now my makes seem to function.

I followed the steps for installing Qt-4.3.5 as you suggest. After doing the make and make install steps, the ParaView still wants a reader specified.

I then tried step 7,2 in the Readme instructions, and I get this response (at the end):

[ 9%] Generating qrc_PV3FoamReader.cxx
[ 18%] Generating moc_PV3FoamReaderPluginImplementation.cxx
Scanning dependencies of target PV3FoamReader
[ 27%] Building CXX object CMakeFiles/PV3FoamReader.dir/moc_PV3FoamReaderPluginImplementation.o
[ 36%] Building CXX object CMakeFiles/PV3FoamReader.dir/PV3FoamReaderPluginImplementation.o
[ 45%] Building CXX object CMakeFiles/PV3FoamReader.dir/qrc_PV3FoamReader.o
make[2]: *** No rule to make target `/usr/lib/', needed by `/home/knh-q/OpenFOAM/OpenFOAM-1.5/lib/linuxGccDPOpt/'. Stop.
make[1]: *** [CMakeFiles/PV3FoamReader.dir/all] Error 2
make: *** [all] Error 2

I then moved to step 7,1 and get this response:

-- Looking for strtoll
-- Looking for strtoll - found
-- Check if system supports 64 bit streams
-- Check if system supports 64 bit streams - yes
-- Looking for malloc.h
-- Looking for malloc.h - found
-- Check if system supports 64 bit streams
-- Check if system supports 64 bit streams - yes
-- Found Qt-Version 4.4.0
-- Found Qt-Version 4.4.0
-- Application: default ParaView Client enabled
-- Application: Custom Server enabled
-- Application: DobranoViz enabled
-- Plugin: Prism enabled
-- Found Qt-Version 4.4.0
-- Configuring done
make: *** No targets specified and no makefile found. Stop.

I see the ParaView make is not finding the right Qt version, but I did confirm that the Qt-4.3.5 directory exists and looks correct.

I did the additions to the bashrc as you suggest in your step 3. Is there some "sourcing" required here? I am not a Linux guru, so all this is a bit new.

Now, maybe the worst problem. Once I do all this and log off, I am no longer able to log back on normally. The system says I have too many temporary files, and I have to go in with the failsafe boot up and delete a lot of the Qt stuff.

I am now baffled! Any ideas here?

Thanks, Ken

ep4 November 14, 2008 04:28

For the Qt version problem, wh
For the Qt version problem, what gives you the command qmake --version ?

If it doesn't return the right one, i suggest to modify your path in the terminal, before the point 7,2 instructions, using a command like: PATH=/usr/local/Trolltech/Qt-4.3.5/bin:$PATH

After that, it should use the right Qt version.

kenhelland November 14, 2008 09:16

I will give the PATH idea a tr
I will give the PATH idea a try. I think the location is different, but I will confirm this before I make the PATH change.

I still worry about the huge set of temporary files that are created. Something is wrong here.

As a fall-back solution, I am going to get the 10.3 version of SUSE.

tckosvic November 14, 2008 09:18

Su Xiaohui, Hello. I wis
Su Xiaohui,


I wish to get parafoam to work. From your email, I am considering removing suse and going to ubuntu 8.10 because of your success in getting parafoam to run.

I would like to make sure that when you run the tutorial case of Cavity, you can use Parafoam and see the grid and the velocity and pressure values in paraview.

Does parafoam ask for a reader?

Does any reader run and allow viewing of the grid and the results?

Thanks very much,

Tom Kosvic

wenterodt November 14, 2008 16:01

Nice to get that much feedback
Nice to get that much feedback, but it seems like that only Gu Zongyuan got his system to work with this howto. Well, at least that shows that it's not impossible to install OF1.5 on OS11!

As I think stepping back to Suse10.3 is no choice (while using Ubuntu sure is one) I want to ask people who had success using this howto to share their experience!

In detail:

@Thomas: You have no "make" installed! Very strange for a linux machine, but not impossible... Use Yast to install it (should be in the C++ development scheme)! The reason why there is no makefile in the folder, yet, is that the makefile is created by ./configure!

@Ken: You need to install python (via Yast). The qt files in /tmp should not be bigger than 1GB, so either you have a very small harddrive, or there are some other big files that crowd your disk... Anyhow, step 7.1 MUST fail before Qt is installed properly!

Please let us know if you made it work!


alberto November 15, 2008 14:12

Hi Tammo, I got paraview wo
Hi Tammo,

I got paraview working on openSUSE 11.0 too.

Actually the problem has _always_ been limited to the paraFoam reader, because paraview works properly on openSUSE 11.0 even with Qt 4.4, as I showed in another post, using foamToVTK.

Little info: it is normal not to have gcc/make and other development tools on openSUSE default installation. The software selection does not include them by default.

With kind regards,

kenhelland November 15, 2008 18:12

Hi Tammo, I seem to have hi
Hi Tammo,

I seem to have hit a brick wall. I have the Python interpreter installed along with lots of other python files; I added the python-xlib..just a guess.

My hard drive size is 500 G's, and about 411 G's are free.

I reinstalled OpenFOAM and then the steps for the Qt-4.3.5. After the make install step (or maybe even earlier) I am no longer able to log on (other than as a super user) and I get this message in a little window on a blank screen:

Call to inusertemp failed (temporary drives full?)
check your installation.

I did some trial and error deletions, and it seems the only way to remove this problem is delete the entire Qt-4.3.5 directory created by the make install process. The /tmp directory does not seem to cause any problems.

For the record, I am running on an Intel quad core at 2.66 MHz with 4 G memory installed.

If there is a magic solution, I would sure like to find it. At least others have had success with SUSE 11.0.

Thanks, Ken

gzy_1228 November 15, 2008 18:36

Hi ken, i find a simple way
Hi ken,
i find a simple way to solve the inusertemp failed (temporary drives full?) in my friend's laotop..install everything under kde and then inusertemp failed (temporary drives full?) maybe happens in some machine and then choose gnome or icewm or whatever...u will find openfoam and parafoam is ok.
the only thing u lose is kde...

kenhelland November 17, 2008 13:15

Hi Tammo and Gu, I think th
Hi Tammo and Gu,

I think things are working! Maybe I can escape the installation thread one of these days. I did the full Qt-4.3.5 install sequence and have run paraFoam on cavity.

Old biz: I am using a 2.66 GHz cpu, not 2.66 MHz!

I log on using KD3 and things seem fine. There is no inusertemp failure notice, so perhaps KD4 has issues. KD3 is more like my XP experience anyway.

I am struggling with ParaView, so it appears there is plenty to learn there, but I am getting images and such.

Looking back, it would be useful to have some list of critical packages that need to be installed. I see Yast can import and export such lists; many comments including mine are clearly related to not having critical software loaded.

In summation, it appears that Tammo's list of steps for SUSE 11.0 work fine as long as KD4 is not the log-on interface.

Thanks a lot all.


tckosvic November 17, 2008 15:29

Tammo, I have worked throug

I have worked through my missing make system and gotten Qt-4.3.5 to compile, make, and install into ThirdParty directory of OpenFOAM.

Now when I run paraFoam for the cavity case as in the example, I get message below:

tom@linux-l8tg:~/OpenFOAM/tom-1.5/run/tutorials/icoFoam/cavity> paraFoam

paraview: symbol lookup error: /home/tom/OpenFOAM/ThirdParty/ParaView3.3-cvs/platforms/linuxGcc/bin/libpqCore.s o: undefined symbol: _ZN14QObjectPrivate15checkWindowRoleEv


After this I went and recompiled paraFoam (7.2 step). When I ran paraFoam again I got the same message regarding undefined symbol.

I do not have enough capabilities with SUSE to diagnose problem any further.

Anyone have any ideas?


Tom Kosvic

tckosvic November 17, 2008 20:55

Tammo, It worked!!! I can

It worked!!! I can look at the grid of the cavity case using paraFoam. The parafoam does not ask me for a reader now it just opens one up.

I am using OpenFOAM 1.5 (32 bit) and SUSE 11 and GNOOME shell.

I did have to recompile both paraview and parafoam. The compile, make, and install of qt takes a very long time even though I have dual processor 3.0 ghz machine.

Thanks, Tammo.

Now, I can start doing more than just installation tasks. I need to learn how the viewer works.

Tom Kosvic

kenhelland November 19, 2008 12:34

Tom, Nice to see more succe

Nice to see more success with 11. I was close to switching to 10.3.

My compile of qt runs in about 35 minutes. The remainder of the steps are usually in the "few minutes" range. I have the quad core 2.66 GHz with 4 GB of memory.

I want to add 4 G more and try the 64-bit software as time permits.


ameya November 28, 2008 06:17

Hey Tammo, Thanks a lot dud
Hey Tammo,

Thanks a lot dude.

Your tips helped me a lot.

ParaView has strated working on my OpenSUSE 11.0

Keep up the good work.

hsieh November 28, 2008 06:53

Hi, Tammo, Thanks for the s
Hi, Tammo,

Thanks for the steps. I have also installed Qt-4.3.5 successfully on OpenSuSE 11.0 by following your steps. The only problem happened to me was that, after including "export LD_LIBRARY_PATH=$QT/lib:$LD_LIBRARY_PATH" in ~OpenFOAM/OpenFOAM-1.5/etc/bashrc, I was no longer able to log into my user account. I had to remove it by logging into root.

I have also updated to paraview 3.4 by following Bernhard's post. Paraview 3.4 fixed a couple of problem I had with paraview 3.3 - sweet!


All times are GMT -4. The time now is 21:29.