CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Critical error (

chris_j_meyer May 22, 2007 17:26

I have gone through previous p
I have gone through previous posts and have not found my particular problem dealt with. Apologies if I missed it!

I am installing on openSuse 10.2 and did not use install either the Java or gcc binaries as I assume the latest version of Suse will be up to date.

I get the following critical error when running foam InstallationTest:

Software versions
Software Version Location
gcc ...figure
WARNING: Conflicting installations:
foam settings: /home/cmeyer/OpenFOAM/linux/gcc-4.1.2/bin/gcc
current path : /usr/bin/gcc

java 1.4.2
WARNING: Conflicting installations:
foam settings: /home/cmeyer/OpenFOAM/linux/j2sdk1.4.2_05/bin/java
current path : /usr/bin/java

gzip 1.3.5 /usr/bin/gzip
tar 1.3.5 /bin/tar
icoFoam ...M/OpenFOAM-1.4/applications/bin/linuxGcc4DPOpt/icoFoam

It seems that OpenFOAM expects both gcc and JAVA in a different place. echo $PATH yields the following:

/home/cmeyer/OpenFOAM/linux/paraview-2.4.4/bin:/home/cmeyer/OpenFOAM/OpenFOAM-1. 4/src/lam- 7.1.2/platforms/linuxGcc4DPOpt/bin:/home/cmeyer/OpenFOAM/OpenFOAM-1.4/ src/mico-2.3.12/platforms/linuxGcc4DPOpt/bin:/home/cmeyer/OpenFOAM/cmeyer-1.4/ap plications/bin/linuxGcc4DPOpt:/home/cmeyer/OpenFOAM/OpenFOAM- 1.4/applications/bi n/linuxGcc4DPOpt:/home/cmeyer/OpenFOAM/OpenFOAM-1.4/wmake:/home/cmeyer/OpenFOAM/ OpenFOAM-1.4/bin:/home/cmeyer/bin:/usr/local/bin:/usr/bin:/usr/X11R6/bin:/bin:/u sr/games:/opt/gnome/bin:/opt/kde3/bin:/usr/lib/jvm/jre/bin

I am thus slightly confused by the term "current path" issued by foamInstallationTest as it obviously does not refer to $PATH, or does it?

How do I fix this, and more importantly, explain the rather confusing output.

All help deeply appreciated!

mardit June 5, 2007 12:50

in $HOME/OpenFOAM/OpenFOAM-1.4
in $HOME/OpenFOAM/OpenFOAM-1.4/.bashrc

modify this line based on your gcc version:


fluentfreak February 13, 2009 03:39

It seems that the new installa
It seems that the new installation package puts the compiler files in folders different from the ones which are defined in the setting and bash files. Make sure the compiler is copied in the folder that the settings are expecting they are:

In my case the installer copied the compiler files to:
I corrected the path in bash file and set the line corresponding to "linux" to "linux64" and it just worked!

All times are GMT -4. The time now is 08:46.