CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Installing OpenFoam141dev vtk errors (

cvv February 11, 2009 03:54

Hi everyone, I hope someone
Hi everyone,

I hope someone can help me.

Im am trying to install OpenFoam 1.4.1-dev on a SLED10.2 - 64bit machine. We have managed to get most of the compiler issues sorted out. For instance there were a couple of places where the paths were still /home/dm2/henry...

I still get problems when I want to compile Paraview. The compiler is GCC 4.2.1. and Paraview 2.4.4 is installed.

The problem I have is that when I want to run cmake get the following error.

~/OpenFOAM/OpenFOAM-1.4.1-dev/applications/utilities/postProcessing/graphics/PVF oamReader/PVFoamReader/Make/linux64GccDPOpt> cmake ../..

-- VTK not found. Set the VTK_DIR cmake cache entry to the directory containing VTKConfig.cmake. This is either the root of the build tree, or PREFIX/lib/vtk for an installation. For VTK 4.0, this is the location of UseVTK.cmake. This is either the root of the build tree or PREFIX/include/vtk for an installation.
CMake Error at CMakeLists.txt:60 (VTK_WRAP_ClientServer):
Unknown CMake command "VTK_WRAP_ClientServer".

I added the following lines in the file CMakeCache.txt in the directory ~/OpenFOAM/OpenFOAM-1.4.1-dev/applications/utilities/postProcessing/graphics/PVF oamReader/PVFoamReader
where the cmake command is pointing to:

//Path to VTK

but it looks like it stall cannot find VTK, although the file VTKConfig.cmake does reside in the above directory. If I check the variables with ccmake it does show the VTK_DIR correctly.

Any ideas?

As a side note if I run paraFoam on the cavity case for instance I get the following errors:

# Error or warning: There was a VTK Error in file: /home/dm2/henry/OpenFOAM/linuxSrc/paraview-2.4.4/GUI/Client/vtkPVWindow.cxx (2366)
vtkPVWindow (0x86bc00): Cannot read file information when no reader is specified. This probably means that the reader for the file with name: /home/carel/OpenFOAM/carel-1.4.1-dev/run/cavity/cavity.foam cannot be found
ErrorMessage end
# Error or warning: There was a VTK Error in file: /home/dm2/henry/OpenFOAM/linuxSrc/paraview-2.4.4/GUI/Widgets/ x (1335)
vtkPVApplication (0x61a890):
Returned Error on line 11:
invalid command name ""
ErrorMessage end

I believe this will dissapear once we get Paraview to compile?


All times are GMT -4. The time now is 13:00.