CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   OpenFOAM 15 with ParaView 340 on OpenSuSE 110 (

zairja February 8, 2009 01:42

Hi All, I've noticed that
Hi All,
I've noticed that many of you want to compile OpenFOAM 1.5 on OpenSuSE 11.0 along with ParaView 3.4.0 rather than 3.3-cvs available in various threads.

Well i've successfully compiled the same for the OpenSuSE 11.0 and i'm hopefull the same steps can be applied to other distributions.

I'm not a user of OpenFOAM, so apart from testing the basic functionality with Sucess, i'll appreciate if the community members/users can test it out and see if all works OK.

I'll appreciate your suggestions on the same and improvements that you find useful during installation to serve the community better.

You can find the detailed steps at the following location under OpenSuSE Link:


dmoroian February 9, 2009 05:55

I compiled OpenFOAM 1.5/1.5-de
I compiled OpenFOAM 1.5/1.5-dev on a Suse 10.0 (SLED), and I used the latest gcc (4.3.2... actually I see now on their webpage that the latest is 4.3.3) and latest ParaView (3.4.0).
Unfortunately when I try to run paraFoam I get a segmentation fault.
If I convert data to VTK format, then I can see them directly using paraview.
Anyone has similar problems?


zairja February 9, 2009 10:07

Hello Dragos, I've seen th
Hello Dragos,
I've seen this error when i was trying to use the precompiled binaries of Paraview. In all of my testing i've found that it is better not to download the precompiled binaries packages as we are building from source anyway.

The installation site does not clearly points this out. If you go to Other Platform selection than you simply needs Source. So stick with it.

Once OpenFOAM is compiled, once can then simply follow the steps to rebuild the ParaView as well the PV3FoamReader.

So can you try the following on SuSE:
1> Create a Folder OpenFOAM
2> Download and Extract OpenFOAM-1.5.General.gtgz & ThirdParty.General.gtgz
3> Modify Environment settings to suite your environment
4> Build using Allwmake
5> cd $WM_PROJECT_DIR/bin/
6> Run buildParaView3.3-cvs (if you want to use this only works successfully with QT 4.3.5 without any tweaks!)
7> cd $FOAM_UTILITIES/postProcessing/graphics/PV3FoamReader
8> Run Allwclean & Allwmake

Segmentation fault is coz of the fact that application is conflicting using libraries availabe in the system as well as the precompiled binaries that you downloaded.

I've tested the installation and i'm sure you must have seen the pages i posted, there is no precompiled binary package downloaded.

Also, check the settings section and ensure that after Environment variables are set there are no errors while testing the installation using foamInstallationTest.

We are using this in production environment (RedHat) and so far users are really happy.

Do try it out and let me know the outcome


dmoroian February 9, 2009 10:12

Hello Zairja, And thank you f
Hello Zairja,
And thank you for the suggestions.
I think the only difference between what I've done and you is

6> Run buildParaView3.3-cvs (if you want to use this only works successfully with QT 4.3.5 without any tweaks!)
I'l try it again.


dmoroian February 10, 2009 04:10

Hm, I tried even with buildPar
Hm, I tried even with buildParaview3.3-cvs (with some minor changes inside the script to work with 3.4.0) but the result is the same as previous: paraFoam exits with segmentation fault.
My changes are only three (from the back of my memory):


I had to give up python since I don't have python-dev installed on that computer, and for the moment no internet connection either. Is this python mandatory for proper functioning of the reader?


zairja February 10, 2009 06:14

Not sure Dragos, I haven't
Not sure Dragos,
I haven't done the testing with dev version. 1.5 is working fine as you can see via my webpage on suse11.0.

Can u try not to use the precompiled binaries and just do steps as i've mentioned?

Sorry about repeating it...but i don't have the complete picture on how you did it... on SLED 10.0. i generally write everything down that's why i've posted it for all to benefit from it!

May be i can try dev version. Couldn't find the downloadable package from the website or sourceforge.

Can you tell me how i can get it to test it, if possible?


dmoroian February 10, 2009 08:03

Hello Zairja, Well, the insta
Hello Zairja,
Well, the installation went as following:
1) compile gcc 4.3.2
2) compile Qt 4.3.5 as described in installing Qt 4.3.5
3) compile OpenFOAM (using Allwmake)
4) compile ParaView3.4.0 using buildParaview3.3-cvs

The above steps I had to take in order to have a running OpenFOAM (both 1.5 and 1.5-dev). Everything works with the exception of the paraview reader that gives me a segmentation fault. To overcome this issue, I use foamToVTK and read directly with paraview the resulted data.


zairja February 10, 2009 09:31

Thx Dragos, if you are on
Thx Dragos,
if you are on SLED 10 you can install RPM package directly rather than compiling gcc432

Anyway, Since you have compiled it can you check that you are using this new gcc in path for compiling.

$ which gcc
$ gcc --version
This should tell you which version you are using.

QT must be compiled with the new version too.

Then set LD_LIBRARY_PATH to have QT LIBs first and then preset path

ALso PATH should have Compiled GCC before along wth QT:
export PATH=$QT/bin:<path_to_compiled_gcc>/bin:$PATH

After this Allwmake for OpenFOAM should be done.

Then compile Paraview
$ cd $FOAM_INST_DIR/ThirdParty
$ rm -rf ParaView3.3-cvs/platforms
$ buildParaView3.3-cvs

$ cd $FOAM_UTILITIES/postProcessing/graphics/PV3FoamReader
$ ./Allwclean
$ ./Allwmake

export WM_COMPILER_DIR=<path_to_compiled_gcc>

No errors.

Please do not mix precompiled binaries along with the compiled qcc in PATH as depending on what comes first to be executed segmentation fault will occur as both versions are compiled differently.

Detailed steps of compiling using source can be found at this page since i did that on redhat system as i'm not admin of it so couldn't install packages.

Try checking the PATH and ensure that GCC is one that you used to compile OpenFOAM and QT and QT is in the path when you begin compiling Paraview.

Also after you compile ParaView you need to set the variables that it tells.
so final variables will be:

export ParaView_INST_DIR=$HOME/OpenFOAM/ThirdParty/ParaView-3.4.0

export ParaView_DIR=$HOME/OpenFOAM/ThirdParty/ParaView-3.4.0/platforms/linux64Gcc

export PV_PLUGIN_PATH=$HOME/OpenFOAM/OpenFOAM-1.5/lib/linux64GccDPOpt

export PATH=$ParaView_DIR/bin:$QT/bin:<path_to_compiled_gcc>/bin:$PATH

export WM_COMPILER_DIR=/usr


if paraview still crashes, after this do
$ ldd <path>/paraview

This will tell you of any issues with libraries it needs to run esp conflicting ones. Then simply set the correct LD_LIBRARY_PATH and try again.

This should fix things....

What i understand is that there are conflicting binaries and libraies that is causing the segmentation fault and this can be fixed by settings variables as said, since i presume that you have successfuly compiled OpenFOAM

Hope this helps....

All times are GMT -4. The time now is 20:05.