CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Iinstalling Openfoam on SunOS 58 (

mike February 1, 2009 15:40

Has anyone had any joy with th
Has anyone had any joy with this.

When I run the foamSystemCheck script I get the error :

./foamSystemCheck: syntax error at line 56: `NOCHAR=$' unexpected

zairja February 9, 2009 01:32

Hello Mike, This is proba
Hello Mike,
This is probably coz of the old "sh" shell. Solaris 8 was know for these problems and to compile the package you might need to install all the GNU versions of development packages including shells and gcc...

After that it might work.

I'd experienced similar problems when we were running scripts available written in "sh" not able to run on solaris 8.

Hope this gives you some direction.

If you can try Solaris 10 it would be nicer as it is more GNU....

Let me know if this helped you any way or if you have already solved the problem, then i'll appreciate the gist of knowledge for my reference.

Its almost 4 years that i've left solaris...


chiven April 15, 2010 22:07

Hi, Foamers, I also meet the same problem when trying to install OF-1.6 in Solaris 10. Any suggestions?

Thank you in advance.

wyldckat April 16, 2010 07:38

Greetings Chiven,

I've never used Solaris, but I think this thread could be useful to you, in case you haven't seen it yet: OpenFoam-1.5 on Solaris -- compilation problem calling octreeDataPoint(.) constructor
It also has information on how to build OpenFOAM 1.6 on Solaris. Additionally, the issues indicated in that thread have already been fixed in OpenFOAM 1.6.x.

Best regards,

chiven April 16, 2010 08:20

Hi, Bruno, thank you for you reply. It seems few people use OpenFOAM in Solaris system.

Best regards,

All times are GMT -4. The time now is 19:25.