CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   OpenFOAM 15 libreadlineso5 undefined symbol PC (

frafridr February 3, 2009 20:37

Hi, On Opteron 275 (x86_64),
On Opteron 275 (x86_64), Scientific Linux 5.2, kernel 2.6.18-92.1.22.el5 I have installed OpenFOAM 1.5
During installation I got error messages about missing foamInstallationTest was OK.
After that I run the cavity (icoFoam/cavity) example. Again everything was OK.

But when running paraFoam to visualize results I got the following response:
Using built-in specs.
Target: x86_64-unknown-linux-gnu
Configured with: ../configure --prefix=/tmp/gcc-4.3.1 --exec-prefix=/tmp/gcc-4.3.1 --enable-languages=c,c++ --enable-shared --enable-__cxa_atexit --disable-checking --with-system-zlib
Thread model: posix
gcc version 4.3.1 (GCC)
paraview: symbol lookup error: /usr/lib64/ undefined symbol: PC

I know that issue with undefined symbols was already solved in OpenFOAM 1.4.
One solution could be to compile Paraview but it seams to be to much effort.
Is it possible to solve this problem by installation of correct readline library? My presently installed readline libraries are: and

Could anybody help me to solve this problem?

Best regards.

All times are GMT -4. The time now is 11:16.