CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Trouble sourcing the bashrc for 15x (

sripplinger January 21, 2009 23:44

I've installed 1.5 on my syste
I've installed 1.5 on my system (Ubuntu 8.04). When trying to source the 1.5.x bashrc file I get several messages saying that files are missing, all of them from a $HOME/OpenFOAM/OpenFOAM-dev directory. The 1.5.x files were all obtained through the git repository as per the instructions on the main website. Why is it looking for files in this directory?

olesen January 22, 2009 05:04

This looks like a minor error
This looks like a minor error in the patches sent to the git update (ie, not your fault).

You have two possible ways to get it working:

1) In the first few lines of the bashrc file, simply uncomment the following line:

# export WM_PROJECT_VERSION=1.5.x


2) As an alternative, you can also simply set
*before* sourcing the bashrc file. You might even find this preferrable. Note that the bashrc file also respects the setting of the FOAM_INST_DIR environment variable. You could thus write something like this for a relocatable and failsafe method of sourcing the OpenFOAM files:

# point to the base of all the OpenFOAM versions:

# locate the newest (best?) OpenFOAM
for version in 1.5.x 1.5
if [ -r "$foamrc" ]
export WM_PROJECT_VERSION=$version
. $foamrc

sripplinger January 22, 2009 12:36

Thanks! I went with the first
Thanks! I went with the first option there and it seems to have worked fine. Hopefully I don't have any issues compiling now ;)

sripplinger January 22, 2009 19:04

I tried to compile 1.5.x today
I tried to compile 1.5.x today using Allwmake. This was unsuccessful. The original compile took several hours, but I don't seem to have any solvers or utilities available. I tried compiling again and recorded the output into a log. I've uploaded the log to rapidshare at:

I'm really baffled here and I'm starting to wonder if my system isn't set up right, or if the git update is still screwy.

mbeaudoin January 22, 2009 21:23

Here is a hint from your logfi
Here is a hint from your logfile:

/bin/sh: flex: not found


brosemu April 7, 2009 14:06

I'm having trouble with the git repository as well, not sure if its the same problem as Scott or not.

/Volumes/openFOAM/OpenFOAM-1.5.x -> git pull
Updating ac96a58..e08258f
error: Entry 'etc/bashrc' not uptodate. Cannot merge.

Any suggestions?

All times are GMT -4. The time now is 14:55.