CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Which Linux (

hsj November 11, 2008 10:22

Hi, I have first to install

I have first to install Linux on my machine before thinking about OpenFoam.

Which Linux distribution do you think I should install ?

When installing a Linux distribution, is it then easy to install OpenFoam ? Will I need to install extra packages to run OpenFoam ?



kumar November 11, 2008 10:47

Hi, I would suggest you to
I would suggest you to go for UBUNTU 8.... just the latest version. As I had installed Openfoam just a few days back on my machine. The reason why i say that is you can download a script from the OpenFOAM forum which you can just run to install OpenFOAM and I did the same .
It is working fine for me.
Other good thing about UBUNTU is the synaptics package manager which is quiet handy to install required packages when you want. If you cannot find the script on the forum just let me know, I will send it to you.

K.Suresh kumar

alberto November 11, 2008 11:28

I recommend openSUSE for the e
I recommend openSUSE for the ease of use, the very powerful configuration tools (YaST), and the good hardware and community support:

Installing openFOAM on it means just downloading the packages from openCFD and follow their instructions. You won't need any additional package to use openFOAM on it.

With kind regards,

sxhdhi November 12, 2008 20:51

Dear K.Suresh kumar, I now
Dear K.Suresh kumar,

I now follow your idea to install UBUNTU8.10. I still could not fix paraFoam problem. Could you please let me know which version of Qt you installed and how to install it and make it work? Thanks in Advance.


Su Xiaohui

paean November 12, 2008 21:49

Please post the error message
Please post the error message and tell us the Qt version u used.

Bao Kai

kumar November 13, 2008 05:12

Hello Su Xiaohui,
Hello Su Xiaohui,
I use Qt4 and I have no problem in opening ParaFoam or doing postprocessing.
I suggest you to go to the Synaptics package manager from the systems menu of UBUNTU and then try to search for qt4 and then install the qt4 config... files. I hope this helps you to install qt.
But i think if you had run the script correctly without any error, you shouldnt have any problem in using ParaFoam as it takes care of the qt installation and other libraries required for Qt installation.

K.Suresh kumar

hellorishi November 28, 2008 07:54

Hello, The issue of a "good

The issue of a "good" Linux system has been asked often and I have tried installing OpenFOAM atleast 11 times (on a 32bit machine). So based on my experience, I would recommend the following in brief (detailed instruction/messages in another post on the forum):

1. Install OpenSuSE 10.3
DVD version comes loaded with most of the required development packages,libraries, etc. Click everything during installation (maybe except GAMES).
Only 2 packages are missing.

2. Install following packages from the DVD using YaST:

3. Clean the Paraview platforms and recompile as mentioned in README.
~/OpenFOAM/ThirdParty> rm -rf ParaView3.3-cvs/platforms
~/OpenFOAM/ThirdParty> buildParaView3.3-cvs
~/OpenFOAM/OpenFOAM-1.5/applications/utilities/postProcessing/graphics/PV3FoamRe ader> ./Allwclean
~/OpenFOAM/OpenFOAM-1.5/applications/utilities/postProcessing/graphics/PV3FoamRe ader>./Allwmake

4. Ready to run first example as mentioned in Section 6(Getting Started) !


alberto November 28, 2008 12:56

Hello, if you use openSUSE

if you use openSUSE 10.3, you don't need to install "everything except games" (that's huge! :-)), especially if you use what provided by third party packages you can download from OpenCFD website.

I would say you need to install the default proposal + the "C/C++ development" and "Qt development" patterns.


jeboone December 5, 2008 11:45

I have Fedora 9 and I am havin
I have Fedora 9 and I am having trouble installing OpenFOAM - It looks like Fedora has QT3.3 - Has anyone installed OpenFOAM on Fedora

gwierink December 5, 2008 14:11

Hi James, In Fedora you nee
Hi James,

In Fedora you need to install Qt-4.3.5 (at least that worked for me) and rebuild ParaView. You can download the package qt-all-opensource-src-4.3.5.tar.gz from Put it in a temporary directory and unpack it by "tar xzf qt-all-opensource-src-4.3.5.tar.gz".
Then, go to the place it unpacked and configure for installation by "./configure". After that it will tell you that you can make Qt by typing "gmake" and after that "gmake install" (this may be "cmake" or just "make" for you).
Then, add this to your .profile file:

export PATH

In my case I also had to make a directory called "bin" in my home directory and copy the qmake executable there. After you have unpacked the OpenFOAM packages follow the recipe to rebuild ParaView from section 7 of the README:

A version of Qt 4.3.x must be installed to compile ParaView. The compilation is a fairly simple process using the supplied buildParaView3.3-cvs script that has worked is our tests with other packages supplied in the ThirdParty directory, namely cmake-2.4.6 and gcc-4.3.1. Execute the following:

* cd $FOAM_INST_DIR/ThirdParty
* rm -rf ParaView3.3-cvs/platforms
* buildParaView3.3-cvs

The PV3FoamReader module is an OpenFOAM utility that can be compiled in the usual manner as follows:

* cd $FOAM_UTILITIES/postProcessing/graphics/PV3FoamReader
* ./Allwclean
* ./Allwmake

Hope this helps, cheers, Gijs

jeboone December 5, 2008 18:25

It worked great - very good ex
It worked great - very good explanation of what I needed. I had searched the trolltech site for a Qt4.3 version but all the search turn up was Qt4.4 which the OpenFOAM instruction said was not compatible. I didn't need to create the bin directory and put the qmake file in it. I added PATH=$PATH:/usr/local/Trolltech/Qt-4.3.5/bin to my .bashrc file. After refreshing the path I checked
which qmake
and it was in my path so I went on with the instructions. It all is working now.

Thanks and Have a great weekend

gwierink December 6, 2008 05:22

Hi Jim, You're very welcome
Hi Jim,

You're very welcome. I am happy you got it working. The right Qt package is not so easy to find, some digging is needed

Great weekend for you too!

Cheers, Gijs

All times are GMT -4. The time now is 11:06.