CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   BuildParaView33cvs problem (

jcw July 20, 2008 10:33

Hello OF-experts! It should b
Hello OF-experts!
It should be pointed out at first that this is my first thread addressed to this forum. I have been using OF1.3 successful until now. I could solve all occuring difficulties by reading your questions and answers. Thanks to all of you.
A few days ago I started to install OF1.5. I have been successful with the Qt4.3.2 installation. I also run my first test case of icoFoam as recommended in README file. Everything works fine until I try to complete the last step of the README, precisely 'Compiling Paraview 3.3 and the PV3FoamReader module'. I get the following error message:

CMake Error: This project requires some variables to be set,
and cmake can not find them.
Please set the following variables:

Since I am not very familiar with compiling and all related programs like cmake, make, and so on I have actually meet the limits of my linux knowledge. Hopefully, someone can tell my how to solve the problem.

Some relevant information:
jw@jw02:~/OpenFOAM/OpenFOAM-1.5$ qmake --version
QMake version 2.01a
Using Qt version 4.3.2 in /usr/local/Trolltech/Qt-4.3.2/lib
jw@jw02:~$ uname -a
Linux jw02 2.4.27-3-386 #1 Wed Dec 6 00:38:33 UTC 2006 i686 GNU/Linux

I am using Debian Sarge (small cluster), which has been working excellent with OF1.3. I updated some packages from etch repository in order to install Qt4.3.2 correctly.Now, I need your help with ParaView3.

Any hints from your side? Thanks al lot in advance.


jcw July 24, 2008 04:46

No ideas? That's a pity. Pleas
No ideas? That's a pity. Please help, otherwise I can not use OF1.5, if I do not get ParaView running properly.

Thanks for your help.


gschaider July 24, 2008 05:19

Hi Christian! Probably the
Hi Christian!

Probably the OpenGL-Headers are not installed on your system. Don't know in which package they'd be found on a Debian system (something like "mesa-*-devel")


bfa July 24, 2008 05:41

Hi Christian, as far as I kno
Hi Christian,
as far as I know the OpenGL packages for Debian are called xlibmesa-gl-dev and xlibmesa-glu-dev
Install them with apt-get install xlibmesa-gl-dev

Hope it helps

elvis July 24, 2008 10:09

Hi Christian, take a look at
Hi Christian,
take a look at
and compare if you have all necessary packages installed

Build-Depends: cdbs , debhelper , autotools-dev, quilt , cmake , libqt4-dev , libopenmpi-dev, ffmpeg, libavformat-dev, libavutil-dev, libavcodec-dev, python-dev, chrpath, libglu1-mesa-dev, libxt-dev

good luck


dnomdec July 26, 2008 23:43

Hi all, I ran into a slight
Hi all,

I ran into a slightly different problem when recompiling ParaView3.3 using "buildParaView3.3-cvs".

It compiled fine, but when I start paraview, it tries to use "/usr/lib64/" instead of the version in the gcc-4.3.1 shipped with OpenFOAM 1.5, even when I source the environment. Therefore, I get this error:

"/usr/lib/ version `GLIBCXX_3.4.5' not found (required by [whatever paraview library requiring])"

When I recompile Paraview through "cmake, make, make install" with the right environment (manually set), everthing works fine.

AMD x86_64
CentOS 5 (2.6.18-53.1.21.el5)
Other things shipped with OpenFOAM 1.5

I can try to look into it more, but I need help with what "buildParaView" actually does (towards the end of "buildParaView3.3-cvs" -- sorry I am not too good with script-like things). Any suggestion is appreciated!


gbrother July 27, 2008 13:52

Ned, i just got 32-bit OF1.5 w
Ned, i just got 32-bit OF1.5 working on Debian "etch" (well, i think it's working so far).

I had to rebuild paraview also. I found that I had to compile by hand 'flex' and make symbolic links to point flex to flex++ for the Allwmake to work properly.

Rebuilding Paraview (follow the instructions to remove the paraview3.3-cvs)

I copied all my qt4.3.5 files to /usr/lib, then had to install the python2.5 application.

Then resumed the instructions to rebuild paraview, the final stage of the overall Allwmake.

The BuildParaView function is basically a ./configure command and I sent all the output to a .txt file. Both CPUs ran at 100% during the build process.

The clean up and ./allwmake process that followed were fairly short compared to the overall compilation of OF.

mattijs July 28, 2008 05:34

Hi Ned, I just got the same
Hi Ned,

I just got the same error ('GLIBCXX_3.4.5' not found) doing a rebuild on my OpenSuse10.2 machine. Found that paraview uses rpath as a link option and takes the system c++ libraries instad of using the LD_LIBRARY_PATH setting which would force it to use the OpenFOAM installed gcc-4.3.1 version.

- if you already have a build: edit platforms/linuxXXXX/CMakeCache.txt and set VTK_USE_RPATH to off (VTK_USE_RPATH:BOOL=OFF)

- or attached a revised bin/tools/buildParaViewFunctions which does that for you and rebuilds the whole thing buildParaViewFunctions

gwierink October 19, 2008 05:22

Hi everyone, Trying to inst
Hi everyone,

Trying to install OpenFOAM-1.5 and run into the same problem as Christian Wolf. When I did buildParaView3.3-cvs I get the error

CMake Error: This project requires some variables to be set,
and cmake can not find them.
Please set the following variables:

I run a 32-bit Fedora 9 system. Can anyone hint me how to install openGL, and/or whatever else is needed? Thanks in advance!

ep4 October 23, 2008 09:52

Hi, I encounter some proble

I encounter some problems to compile Paraview.
Following the README file, i get the error of Ned (July, 26) about GLIBCXX_3.4.9 (and not GLIBCXX_3.4.5). I have used the function buildParaviewFunctions given in the previous message of Mattijs Janssens but i still get the same error. Should i change something to this file seing that my error is about GLIBCXX_3.4.9 and not GLIBCXX_3.4.5 ?

I have also tried to follow the advices of Ned (the same post) making cmake, make and make install. It seems to work, i don't have problems with GLIBCXX_3.4.9 anymore but later in the compilation i have an other error message saying that the 'class QString' has no member named 'toStdString'.

Searching on the web, i found that it could be due to the fact that Qt is nor compiled with STL enable. However, desinstalling Qt 4.3.1 and recompiling it by ./configure -stl and then gmake does not work:

In file included from shared/qdesigner_stackedbox.cpp:42:
shared/orderdialog_p.h:76: error: 'Ui' has not been declared
shared/orderdialog_p.h:76: error: ISO C++ forbids declaration of 'OrderDialog' with no type
shared/orderdialog_p.h:76: error: expected ';' before 'ui'
gmake[4]: *** [.obj/release-shared/qdesigner_stackedbox.o] Fehler 1
gmake[4]: Leaving directory `/net/ric_home/ep4/Desktop/qt-x11-opensource-src-4.3.1/tools/designer/src/lib'
gmake[3]: *** [sub-lib-make_default-ordered] Fehler 2
gmake[3]: Leaving directory `/net/ric_home/ep4/Desktop/qt-x11-opensource-src-4.3.1/tools/designer/src'
gmake[2]: *** [sub-src-make_default] Fehler 2
gmake[2]: Leaving directory `/net/ric_home/ep4/Desktop/qt-x11-opensource-src-4.3.1/tools/designer'
gmake[1]: *** [sub-designer-make_default-ordered] Fehler 2
gmake[1]: Leaving directory `/net/ric_home/ep4/Desktop/qt-x11-opensource-src-4.3.1/tools'
gmake: *** [sub-tools-make_default-ordered] Fehler 2

I would be very pleased to receive some advices.

Thank you


ep4 October 24, 2008 10:49

Hi, finally, i compiled par

finally, i compiled paraview with buildParaview3.3-cvs, then cmake, make amd make install. I used the version Qt-4.4.3 by modifiying the CMakeList.txt.

However i don't see anywhere a paraview application. The paraFoam command gives me the error:
line 100: paraview: command not found
ep4@wobwslx2:/net/ric_home/ep4$ type paraview
bash: type: paraview: not found

A check on my system gives me (after an updatedb):
ep4@wobwslx2:/net/ric_home/ep4$ locate paraview

Does someone could help me to understand or resolve the problem?

Thank you


ep4 October 27, 2008 08:28

Hi everybody, i'am back wit
Hi everybody,

i'am back with the same problem. I had maybe suppressed a little bit too many lines in the CMakeLists.txt file.
Deleting only the lines 94 to 96 i still get the same error but i receive the following message when using cmake:
[root@wobwslx2 ThirdParty]# cmake ParaView3.3-cvs
CMake Error: Qt 4.3.0 or greater not found. Please check the QT_QMAKE_EXECUTABLE variable.
Qt was not found
-- Configuring done

I don't know why it says me that seing that i use the command PATH=/usr/local/Trolltech/Qt-4.4.3/bin:$PATH to indicate the version i want it uses (i also have a really old version).
And i'am asking if this message could explain that i don't get any executable called paraview after the compilation.

I really need help! Thank you in advance


All times are GMT -4. The time now is 11:58.