CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Successful Installation My report (

quartzian October 6, 2008 08:51

Hi, After 3+ weeks, I final

After 3+ weeks, I finally managed to get OF 1.5 installed on my machine. I thought I would share my experiences in case someone else has similar difficulties.

1. At first, I downloaded the sources and binaries from the main OF download site, but things did not work as advertised. First of all, the binary versions for 64 bit did not exist. I could not see the linuxAMD64 or linux64GccOpt or whatever directories (don't remember exactly now) there were supposed to be.

2. So I tried compiling from sources, and faced a lot of difficulty. In particular, I could not get any of the thirdparty codes to compile...gcc, paraview, etc. etc.

3. I also went to Prof. Jasak's website and downloaded his code to see if that would help, and also tried downloading the development version of OpenFOAM 1.4.1...but there were lots of hassles in compiling from sources ... gcc, paraview, mico, etc., etc.. I used
the buildInstructions.txt file that was on his
website, but couldn't get them to work.

I posted a few messages for help on this forum, but did not get any replies.

4. So, finally, what I did was to download rpms of everything that I could ... gcc, paraview, (I found an rpm for paraview 3.2.1 for Fedora Core 9) etc. My machine originally had Redhat EL4 installed, but I realized that there is no way I could survive in a fast-developing environment with RHEL4 ... if you want to work with open source, you need the latest packages (if you wish to go the rpm route), and they will not be available for RedHat ... so I changed the OS to FC9. Now OpenFOAM 1.5 compiled from sources, with gcc 4.3.0, and paraview also works with OF data. One thing to remember is that there are a lot of places in the make scripts where the location of the paraview libraries/binaries are hard-coded to be in the OpenFOAM ThirdParty directory, and you need to change all of them so that the system paraview is used.

My procedure is to get the data from OpenFOAM and then use foamToVTK to see the legacy vtk files in paraview. Is there another way?

5. Don't know if this means everything will run, but at least I have run many of the simple problems, and things seem to work, both in serial and parallel.

Hopefully now I can get to the fun stuff...doing some CFD with this tool and see how useful it is.

Best regards,


dkingsley October 6, 2008 11:47

It takes a bit of effort, but
It takes a bit of effort, but OpenFOAM 1.5 can be built on RHEL4 sytems. You have to start with building Gcc 4.3.x in the third party directory, and then adjust your PATH and LD_LIBRARY_PATH environment variables so that you get the newer gcc and gcc can find its shared libraries.

Then you will have to build the rest of ThirdParty and OpenFOAM itself. I believe there were a couple of low level libraries in ThirdParty that had to be compiled first before Allwmake would complete.

Our cluster is running Rocks 4.4 and RHEL4.x.

mediode April 30, 2009 03:59

1.5 on RHEL 4
Hello dkingsley, would you mind beeing more specific on how you could manage to install version 1.5 on a RHEL4 machine? E.g. how can I build the gcc in the Thirdparty? I am missing the detailled background in linux so I have to bother you .... michael

All times are GMT -4. The time now is 04:13.