CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Problem of paraFoam in OF15 (

kai September 29, 2008 12:03

Hi all, I installed OF1
Hi all,

I installed OF1.5 on my Fedora 9 system simply by extractiong all the binary packages as described in README. When I tested it with icoFoam's cavity case, the blockMesh and the solver icoFoam worked well, but the paraFoam programme told me it could not find a reader of the case. Now I can only use foamToVTK to see the result. So what is the problem and how to solve it?


ngj September 29, 2008 13:41

Hi You need QT4.3.x and yo

You need QT4.3.x and you need to compile paraFoam from scratch. Look in the README file for further informations.

It should be noted that on Fedora 9, QT4.4.x is the default, thus you need to download the source for QT4.3.x and compile that be yourself as well.

Further you will probably be needing libmpfr<something> for the gcc-compiler to be working.

Good luck,


kai October 1, 2008 02:50

Hi Niels, Thanks you for yo
Hi Niels,

Thanks you for your advice.

Yes, I tried the buildParaView3.3-cvs method mentioned in README and failed. The reason may be QT version incompliant as you said. Now, should I delete the qt-4.4.1 on my system before installing qt4.3, or just simply compile qt4.3 in the case of qt4.4.1 existing ?



make October 1, 2008 03:14

You don't need to install qt4.
You don't need to install qt4.3!
I just compiled paraview using qt4.4.2.
Simply uncomment the qt check in the CMakeLists.txt.
There is a line starting with MESSAGE(SEND_ERROR "QT ${QTVERSION }.... Add a # in front.
It compiled without error and runs perfectly. Didn't even crach once since a use it.


olesen October 1, 2008 03:31

Note that even a slight mis-ma
Note that even a slight mis-match in qt versions can cause problems. I had paraview and the OpenFOAM reader module compiled with qt 4.3.3.
One of the machines had qt 4.3.1 installed, which meant that paraview started okay, but the reader module didn't load. Updating all the workstations to the same qt4.3.3 version eliminated the problem.

kai October 1, 2008 12:36

Hi Matthias, Thanks a lot
Hi Matthias,

Thanks a lot! I just followed your advice and successfully recompiled the paraFoam with qt-4.4.1. It runs well now. I cannot understand why the install guide says that versions older or newer than qt-4.3.x are not allowed.

Best regards,


olesen October 2, 2008 02:31

Hi Kai, If you scan the par
Hi Kai,

If you scan the paraview mailing lists, you'll see that building with various qt versions, or even debug vs. release, is a constantly recurring topic. The qt API might change a little between versions, the cmake files might be too stringent in allowing/disallowing particular qt versions, there may be qt bugs that paraview triggers in particular qt versions, or simply that the paraview developers have compiled with a particular version and don't know if it works well with a newer/older version.

I hope this explains why the install guide really isn't misleading. What if the install guide stated "you should use qt-4.3.x, unless you change the CMakeLists.txt, clean out all the old build remnants (and cmake cache files, and it might be necessary to remove the entire paraview directory and do a fresh cvs checkout too) and pray that all goes well when you compile against a different qt version"?

Scan the paraview mailing lists and you'll see what I mean. I am personally grateful for the buildParaview script provided with OpenFOAM - it has greatly improved my success rate with building paraview!

All times are GMT -4. The time now is 06:43.