CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Which Linux distribution should I use (

matthias1 September 9, 2008 08:32

Hi, I tried to install OpenFO
I tried to install OpenFOAM 1.5 on the newest Versions of Ubuntu and Fedora. The OpenFOAM installation worked, however, paraFoam crashed on both of them.
Which distributions are you using? Which Qt version are you using?

lin September 9, 2008 09:51

Just for a feedback. I use
Just for a feedback.

I use Fedora9. paraFoam works,though sometime crash,but it seldom happens.

elorriaux September 9, 2008 09:57

Hello, i think the best adv

i think the best advice i can give you is to choose a distribution you are confortable with.

Whatever the distribution, it's a Linux, so you can make it working with OF, maybe considering some tweaks.

I'm using Gentoo and qt-4.3.3

I've heard that OF releases are packaged on suse, so perhaps it's a little easier with this one.

Regards, Etienne.

alberto September 9, 2008 15:31

I use openSUSE 11.0. Regard
I use openSUSE 11.0.


msrinath80 September 9, 2008 15:33

I use Debain (testing) lenny.
I use Debain (testing) lenny. I just built OpenFOAM-1.5.x from the latest git sources yesterday without any problems :-)

mbeaudoin September 9, 2008 16:50

From the Release Notes, sectio
From the Release Notes, section 2:
The 64bit binary packs of the OpenFOAM release were compiled on a machine running SuSE GNU/Linux version 10.2 and the 32bit on a machine running Ubuntu GNU/Linux version 7.1. The release has also been tested on SuSE 10.0, 10.3 and Ubuntu 8.04. We recommend that users run OpenFOAM on one of these or a similar recent version of GNU/Linux.

gschaider September 10, 2008 04:46

Hi! The general answer is t

The general answer is that if you recompile the distribution it will run on almost any Linux.

For the binary distribution I tried (just for fun) this application (just untrarred the binary packages for 64 bit into a directory, pointed the application checker to it and let it rip). The check failed for all distributions, mainly because it didn't know and (whose absence seems to be one of the main reasons for failing 1.5 installations, judging by other threads), but apart from that Fedora 8/9, Ubuntu 8.04, OpenSUSE 10.3/11.0 Mandriva 2008, SLES 10 SP1/SP2, Oracle Enterprise Linux (anyone using that for CFD? ;) ) and RHEL 5.1 seem to be fine (which is of course no guarantee that installation will fail on any other Linux). For older Linuxes the lack of a default-installed QT4 seems to be the problem.


All times are GMT -4. The time now is 22:53.